Installer wifi password prompt is not hidden and limited in size

  • Open
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 8 Jun 2019 15:15
installer wifi password prompt
(address . bug-guix@gnu.org)
20190608151502.5d22d7e8@tachikoma.lepiller.eu
Hi,

i just installed a new Guix System and had to use wifi for connecting
to the internet. Unfortunately, I found a few bugs with the wifi screen:

* The wifi screen doesn't automatically scan for wifi network, it would
be nice if it did it when you first get to that screen.
* The password prompt is not hidden, it's a simple text prompt.
* The password prompt was not large enough for my password, so I was
unable to connect. I had to use connmanctl from another tty to
connect.
* Even if already connected (outside of the installer), we still have to
choose a network. The connected network is marked with a '*' so the
code should be able to access that information, I think.

Thank you!
T
T
Tobias Geerinckx-Rice wrote on 8 Jun 2019 17:43
[PATCH 3/2] installer: Hide the Wi-Fi passphrase by default.
(address . 36132@debbugs.gnu.org)(address . 36135@debbugs.gnu.org)
20190608154338.8064-1-me@tobias.gr
* gnu/installer/newt/wifi.scm (run-wifi-password-page):
Add an #:INPUT-SHOW-CHECKBOX? to the input page.
---

Guix,

This adds a ‘[ ] Show’ checkbox to the newt installer's Wi-Fi passphrase input field, which has also been requested at least twice now. Most recently here[0].

Kind regards,

T G-R


gnu/installer/newt/wifi.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/installer/newt/wifi.scm b/gnu/installer/newt/wifi.scm
index 1cb2ef2df3..040e013293 100644
--- a/gnu/installer/newt/wifi.scm
+++ b/gnu/installer/newt/wifi.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -88,7 +89,8 @@ nmc_wifi_strength_bars."
(define (run-wifi-password-page)
"Run a page prompting user for a password and return it."
(run-input-page (G_ "Please enter the wifi password.")
- (G_ "Password required")))
+ (G_ "Password required")
+ #:input-show-checkbox? #t))
(define (run-wrong-password-page service-name)
"Run a page to inform user of a wrong password input."
--
2.21.0
L
L
Ludovic Courtès wrote on 8 Jun 2019 21:42
Re: bug#36135: installer wifi password prompt
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 36135@debbugs.gnu.org)
87zhmr984t.fsf@gnu.org
Hello,

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (10 lines)
> * The wifi screen doesn't automatically scan for wifi network, it would
> be nice if it did it when you first get to that screen.
> * The password prompt is not hidden, it's a simple text prompt.
> * The password prompt was not large enough for my password, so I was
> unable to connect. I had to use connmanctl from another tty to
> connect.
> * Even if already connected (outside of the installer), we still have to
> choose a network. The connected network is marked with a '*' so the
> code should be able to access that information, I think.

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (3 lines)
> * gnu/installer/newt/wifi.scm (run-wifi-password-page):
> Add an #:INPUT-SHOW-CHECKBOX? to the input page.

[...]

Toggle quote (2 lines)
> + #:input-show-checkbox? #t))

It’s called #:input-hide-checkbox? AFAICS.

You can double-check that it builds without warnings with:

guix system vm -v2 gnu/system/install.scm

Please add a “Partly fixes …” line. This fixes both the password length
and the password visibility issues since ‘run-input-page’ will now use
FLAG-SCROLL.

Thanks!

Ludo’.
L
L
Ludovic Courtès wrote on 8 Jun 2019 21:42
control message for bug #36135
(address . control@debbugs.gnu.org)
87y32b983i.fsf@gnu.org
retitle 36135 Installer wifi password prompt is not hidden and limited in size
quit
T
T
Tobias Geerinckx-Rice wrote on 8 Jun 2019 22:11
Re: bug#36135: installer wifi password prompt
(name . Ludovic Courtès)(address . ludo@gnu.org)
87r2836dnn.fsf@nckx
Ludo',

Ludovic Courtès wrote:
Toggle quote (11 lines)
> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>
>> * gnu/installer/newt/wifi.scm (run-wifi-password-page):
>> Add an #:INPUT-SHOW-CHECKBOX? to the input page.
>
> [...]
>
>> + #:input-show-checkbox? #t))
>
> It’s called #:input-hide-checkbox? AFAICS.

Yes. See the other patches in this ad-hoc ‘series’.

Toggle quote (4 lines)
> You can double-check that it builds without warnings with:
>
> guix system vm -v2 gnu/system/install.scm

Sure, I guess, but could you explain the point of doing so?
Reproducibility by others? I don't think patches like these
should be pushed with such light testing, and I don't see how this
can be tested in a VM.

Hence the dusty Dell Latitude mentioned earlier ;-)

It smells funny.

Toggle quote (6 lines)
> Please add a “Partly fixes …” line. This fixes both the
> password length
> and the password visibility issues since ‘run-input-page’ will
> now use
> FLAG-SCROLL.

Yah, I didn't merge the bugs for that reason, and because I'm
still trying to fix more bugs (well, mainly waiting for dd while
doing other stuff, since this can't be tested in a VM…)

Thanks!

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXPwWXAAKCRANsP+IT1Vt
eXsUAP99+t4EyPH6H4WiHpJwnTdj6eLPsFvrJedJBAthSCBbjgEA2yiMUOPt6TQ1
agEKsQ6v/ZIwCTG8WEpvBhFqQ9SA8QE=
=wdD/
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 10 Jun 2019 23:38
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
87k1dt5df2.fsf@gnu.org
Hi!

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (14 lines)
> Ludovic Courtès wrote:
>> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>>
>>> * gnu/installer/newt/wifi.scm (run-wifi-password-page):
>>> Add an #:INPUT-SHOW-CHECKBOX? to the input page.
>>
>> [...]
>>
>>> + #:input-show-checkbox? #t))
>>
>> It’s called #:input-hide-checkbox? AFAICS.
>
> Yes. See the other patches in this ad-hoc ‘series’.

OK.

Toggle quote (9 lines)
>> You can double-check that it builds without warnings with:
>>
>> guix system vm -v2 gnu/system/install.scm
>
> Sure, I guess, but could you explain the point of doing so?
> Reproducibility by others? I don't think patches like these should be
> pushed with such light testing, and I don't see how this can be tested
> in a VM.

No argument here! The patch referred to a keyword argument that does
not exist, which is why I’m indeed suggesting more testing. Simply
looking at the compiler warnings would have raised a flag.

Ludo’.
T
T
Tobias Geerinckx-Rice wrote on 11 Jun 2019 00:36
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36135@debbugs.gnu.org)
87ef41qd88.fsf@nckx
Hah,

Ludovic Courtès wrote:
Toggle quote (6 lines)
> No argument here! The patch referred to a keyword argument that
> does
> not exist, which is why I’m indeed suggesting more testing.
> Simply
> looking at the compiler warnings would have raised a flag.

There were no warnings and the code itself runs fine (believe me,
I've run it way too often already -_-') because this was written
on top of #36132.

I guess I was optimistic about its speedy acceptance.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXP7bhwAKCRANsP+IT1Vt
ebgpAQCY3+QNPoEbpTEVOqUCqjyOm2NCq6eBbAMv8Goj2dD6wwD/Y9Gvd9b7pC7q
N51MMpiKiN8WfLoUJ1x2GPjX2uxaQwo=
=tn2R
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 12 Jun 2019 11:30
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)(address . 36135@debbugs.gnu.org)
87wohrxiak.fsf@gnu.org
Hi Tobias,

Tobias Geerinckx-Rice <me@tobias.gr> skribis:

Toggle quote (10 lines)
> Ludovic Courtès wrote:
>> No argument here! The patch referred to a keyword argument that
>> does
>> not exist, which is why I’m indeed suggesting more testing. Simply
>> looking at the compiler warnings would have raised a flag.
>
> There were no warnings and the code itself runs fine (believe me, I've
> run it way too often already -_-') because this was written on top of
> #36132.

Oh, my bad! I hadn’t seen https://issues.guix.gnu.org/issue/36132.

I’ll take a look.

Ludo’.
?