Add Smalltalk Pharo VM

  • Open
  • quality assurance status badge
Details
3 participants
  • Brian Woodcox
  • Brian Woodcox
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brian Woodcox
Severity
normal
B
B
Brian Woodcox wrote on 31 May 2019 21:46
(address . guix-patches@gnu.org)
BA4D78A3-087B-4FAD-8318-0C64EED37C3B@inskydata.com
Hello,

I have added the Pharo Smalltalk VM package with this patch.

After installing this package, a user can launch an image by executing pharos-vm in the directory that contains the pharos-vm.

To keep things consistent with the current Pharo release, I decided to use the sdl2@2.0.7 and libgit2@0.25.1. If someone feels I should use the latest releases of these packages, I can submit a new patch.

Because of the way Pharo constructs the version and commit date for use internally in the Pharo VM, it is necessary to add this information to the package i.e. commit-info.

This is my first package, so go easy on me. :)

Cheers!
B
B
Brian Woodcox wrote on 1 Jun 2019 01:30
(address . guix-patches@gnu.org)
1344126D-849F-447B-B8D5-8DD66E840381@inskydata.com
I notice that there were a couple of errors when this was posted. The second one was out of my hands (caused by the mailing system).

Toggle quote (8 lines)
> On May 31, 2019, at 1:46 PM, Brian Woodcox <bw@inskydata.com> wrote:
>
> Hello,
>
> I have added the Pharo Smalltalk VM package with this patch.
>
> After installing this package, a user can launch an image by executing pharos-vm in the directory that contains the pharos-vm.

The above line should read as:

After installing this package, a user can launch an image by executing pharo in the directory that contains the pharo image.

Toggle quote (3 lines)
>
> To keep things consistent with the current Pharo release, I decided to use the sdl2@2.0.7 and libgit2@0.25.1. If someone feels I should use the latest releases of these packages, I can submit a new patch.

The above line should read as:

To keep things consistent with the current Pharo release, I decided to use the sdl2 at 2.0.7 and libgit2 at 0.25.1. If someone feels I should use the latest releases of these packages, I can submit a new patch.
Toggle quote (9 lines)
>
> Because of the way Pharo constructs the version and commit date for use internally in the Pharo VM, it is necessary to add this information to the package i.e. commit-info.
>
> This is my first package, so go easy on me. :)
>
> Cheers!
>
> <0001-Add-pharo-vm-package.patch>

My apologies.

Brian.
B
B
Brian Woodcox wrote on 1 Jun 2019 01:33
[bug#36033] Add Smalltalk Pharo VM
(address . 36033@debbugs.gnu.org)
5D2BCFF3-68DA-4497-A3D6-2B2048BCDC1D@inskydata.com
I notice that there were a couple of errors when this was posted. The second one was out of my hands (caused by the mailing system).

Toggle quote (8 lines)
> On May 31, 2019, at 1:46 PM, Brian Woodcox <bw@inskydata.com <mailto:bw@inskydata.com>> wrote:
>
> Hello,
>
> I have added the Pharo Smalltalk VM package with this patch.
>
> After installing this package, a user can launch an image by executing pharos-vm in the directory that contains the pharos-vm.

The above line should read as:

After installing this package, a user can launch an image by executing pharo in the directory that contains the pharo image.

Toggle quote (3 lines)
>
> To keep things consistent with the current Pharo release, I decided to use the sdl2@2.0.7 and libgit2@0.25.1. If someone feels I should use the latest releases of these packages, I can submit a new patch.

The above line should read as:

To keep things consistent with the current Pharo release, I decided to use the sdl2 at 2.0.7 and libgit2 at 0.25.1. If someone feels I should use the latest releases of these packages, I can submit a new patch.
Toggle quote (9 lines)
>
> Because of the way Pharo constructs the version and commit date for use internally in the Pharo VM, it is necessary to add this information to the package i.e. commit-info.
>
> This is my first package, so go easy on me. :)
>
> Cheers!
>
> <0001-Add-pharo-vm-package.patch>

My apologies.

Brian.
Attachment: file
L
L
Ludovic Courtès wrote on 1 Jun 2019 15:23
(name . Brian Woodcox)(address . bw@inskydata.com)(address . 36033@debbugs.gnu.org)
877ea5fnih.fsf@gnu.org
Hello,

Thanks for working on this, and congrats on your first package, which is
not an easy one! :-)

Some preliminary comments:

Brian Woodcox <bw@inskydata.com> skribis:

Toggle quote (5 lines)
> From 49683e04e51cd904571008fa7979a3f58ae0134c Mon Sep 17 00:00:00 2001
> From: "Brian C. Woodcox" <bw@InSkyData.com>
> Date: Fri, 31 May 2019 13:14:54 -0600
> Subject: [PATCH] Add pharo-vm package

[...]

Toggle quote (2 lines)
My understanding (but I’m no expert) is that this is a VM that can run
Pharo bytecode, but it’s not “the” Pharo VM. Is it correct?

Toggle quote (4 lines)
> +(define-public pharo-vm
> + (package
> + (name "pharo-vm")

Consequently, it looks like this should be called ‘opensmalltalk-vm’,
no?

Toggle quote (3 lines)
> + (arguments
> + `(#:tests? #f ;; no tests available

Or maybe there’s a special command to run them?

Toggle quote (10 lines)
> + ;; add symlinks
> + (symlink (string-append (assoc-ref %build-inputs "libgit2") "/lib/libgit2.so")
> + (string-append out "/lib/pharo/" pharo-version "/libgit2.so"))
> + (symlink (string-append (assoc-ref %build-inputs "libssh2") "/lib/libssh2.so")
> + (string-append out "/lib/pharo/" pharo-version "/libssh2.so"))
> + (symlink (string-append (assoc-ref %build-inputs "openssl") "/lib/libssl.so")
> + (string-append out "/lib/pharo/" pharo-version "/libssl.so"))
> + (symlink (string-append (assoc-ref %build-inputs "freetype")"/lib/libfreetype.so.6")
> + (string-append out "/lib/pharo/" pharo-version "/libfreetype.so.6")))

Those symlinks look somewhat inelegant to me. :-)

Could we instead arrange so that the VM searches for those files in
their right place? Often that involves substituting things like
“libfoo.so” in the code with the corresponding absolute file name (see
for example how this is done for Racket.)

Last question: does this Git checkout contain binaries, such as
Smalltalk images? IOW, is this being built entirely from source, or is
it bootstrap from opaque binaries? (I know that Pharo itself is or used
to be bootstrap from very old Smalltalk images and that work was ongoing
to get rid of them and have a nicer bootstrapping story.)

Thank you,
Ludo’.
B
B
Brian Woodcox wrote on 1 Jun 2019 17:08
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36033@debbugs.gnu.org)
FE90B5E5-01E3-47C4-940C-774A23F74A19@InSkyData.com
Thanks Ludo,

My comments are below.

Toggle quote (23 lines)
> On Jun 1, 2019, at 7:23 AM, Ludovic Courtès <ludo@gnu.org> wrote:
>
> Hello,
>
> Thanks for working on this, and congrats on your first package, which is
> not an easy one! :-)
>
> Some preliminary comments:
>
> Brian Woodcox <bw@inskydata.com> skribis:
>
>> From 49683e04e51cd904571008fa7979a3f58ae0134c Mon Sep 17 00:00:00 2001
>> From: "Brian C. Woodcox" <bw@InSkyData.com>
>> Date: Fri, 31 May 2019 13:14:54 -0600
>> Subject: [PATCH] Add pharo-vm package
>
> [...]
>
>> +(define %url "https://github.com/OpenSmalltalk/opensmalltalk-vm.git")
>
> My understanding (but I’m no expert) is that this is a VM that can run
> Pharo bytecode, but it’s not “the” Pharo VM. Is it correct?

“1. The virtual machine (VM) is the only component that is different for each operating system. The VM is the execution engine (similar to a JVM). It takes Pharo bytcode that is generated each time user compiles a piece of code, converts it to machine code and executes it. Pharo comes with the Cog VM a very fast JITing VM. The VM executable is named:”

Toggle quote (8 lines)
>
>> +(define-public pharo-vm
>> + (package
>> + (name "pharo-vm")
>
> Consequently, it looks like this should be called ‘opensmalltalk-vm’,
> no?
>

“Dear user, we have move PharoVM development to OpenSmalltalk-VM, please go there if you are looking for building a VM.”

In the OpenSmalltalk-VM repository they have build scripts for different vm’s such as squeak, pharo, etc..

So this is to distinguish the one we are packaging.

Toggle quote (17 lines)
>> + (arguments
>> + `(#:tests? #f ;; no tests available
>
> Or maybe there’s a special command to run them?
>
>> + ;; add symlinks
>> + (symlink (string-append (assoc-ref %build-inputs "libgit2") "/lib/libgit2.so")
>> + (string-append out "/lib/pharo/" pharo-version "/libgit2.so"))
>> + (symlink (string-append (assoc-ref %build-inputs "libssh2") "/lib/libssh2.so")
>> + (string-append out "/lib/pharo/" pharo-version "/libssh2.so"))
>> + (symlink (string-append (assoc-ref %build-inputs "openssl") "/lib/libssl.so")
>> + (string-append out "/lib/pharo/" pharo-version "/libssl.so"))
>> + (symlink (string-append (assoc-ref %build-inputs "freetype")"/lib/libfreetype.so.6")
>> + (string-append out "/lib/pharo/" pharo-version "/libfreetype.so.6")))
>
> Those symlinks look somewhat inelegant to me. :-)

Me too, unfortunately, Pharo won’t run without (most of) these. I didn’t dig deep enough in the code, but if they made some changes, I am pretty sure the symlinks could be done away with. I found in some cases that pharo found a couple of libraries in the store during the build process.

My hope is that other Pharo users might use Pharo in Guix and maybe this issue can be resolved over time.
Toggle quote (6 lines)
>
> Could we instead arrange so that the VM searches for those files in
> their right place? Often that involves substituting things like
> “libfoo.so” in the code with the corresponding absolute file name (see
> for example how this is done for Racket.)

Possibly, I would have to look into it when I have some time.
Toggle quote (7 lines)
>
> Last question: does this Git checkout contain binaries, such as
> Smalltalk images? IOW, is this being built entirely from source, or is
> it bootstrap from opaque binaries? (I know that Pharo itself is or used
> to be bootstrap from very old Smalltalk images and that work was ongoing
> to get rid of them and have a nicer bootstrapping story.)

Everything in this vm is being built from source.


And use the packages in Guix instead.

The images (which are separate from this) are definitely are built by bootstrapping which will be left to the user at this point.

I think if the developers and users were using Guix, they would enjoy it, as I have a script that will automatically populate the version and date values from any commit. And it could be installed as a separate package.

P.S. I am very new to Smalltalk as well. Just started using it a couple of months ago and thought it would be great if it was on Guix.
Toggle quote (3 lines)
>
> Thank you,
> Ludo’.
Attachment: file
L
L
Ludovic Courtès wrote on 13 Jun 2019 10:46
(name . Brian Woodcox)(address . bw@InSkyData.com)(address . 36033@debbugs.gnu.org)
87k1dp6ffk.fsf@gnu.org
Hi Brian,

Thanks for your explanations. Please let me know if you have an updated
version of the patch, or if you need guidance on specific issues.

Ludo’.
?