Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
* gnu/build/linux-boot.scm (boot-system): Fix e2fsck warning.
---
gnu/build/linux-boot.scm | 4 ++++
1 file changed, 4 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/build/linux-boot.scm b/gnu/build/linux-boot.scm
index a35d18ad7c..03f2ea245c 100644
--- a/gnu/build/linux-boot.scm
+++ b/gnu/build/linux-boot.scm
@@ -517,6 +517,8 @@ upon error."
(unless (pre-mount)
(error "pre-mount actions failed")))
+ (setenv "EXT2FS_NO_MTAB_OK" "1")
+
(if root
;; The "--root=SPEC" kernel command-line option always provides a
;; string, but the string can represent a device, a UUID, or a
@@ -533,6 +535,8 @@ upon error."
(for-each mount-file-system
(remove root-mount-point? mounts))
+ (setenv "EXT2FS_NO_MTAB_OK" #f)
+
(if to-load
(begin
(switch-root "/root")