[PATCH] gnu: emacs-idris-mode: Use recent git checkout.

  • Done
  • quality assurance status badge
Details
2 participants
  • ericbavier
  • Ricardo Wurmus
Owner
unassigned
Submitted by
ericbavier
Severity
normal

Debbugs page

ericbavier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Eric Bavier)(address . bavier@member.fsf.org)
20190531031552.16379-1-ericbavier@centurylink.net
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/emacs-xyz.scm (emacs-idris-mode)[source]: Use git-fetch.
[version]: Include revision and commit.
---
This fixes, amongst other things, syntax highlighting when used with the
latest version of idris.

gnu/packages/emacs-xyz.scm | 45 ++++++++++++++++++++------------------
1 file changed, 24 insertions(+), 21 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f74a2fc45..1d5222367a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8359,29 +8359,32 @@ key. Optionally, a mouse pop-up can be added by binding
(license license:gpl3+)))
(define-public emacs-idris-mode
- (package
- (name "emacs-idris-mode")
- (version "0.9.19")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://stable.melpa.org/packages/idris-mode-"
- version ".tar"))
- (sha256
- (base32
- "16hl2s22l3wc9drnwzw6hn7xrm49ml9lii0s6k218dgahdgsncmf"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-prop-menu" ,emacs-prop-menu)))
- (home-page
- "https://github.com/idris-hackers/idris-mode")
- (synopsis "Major mode for editing Idris code")
- (description
- "This is an Emacs mode for editing Idris code. It requires the latest
+ (let ((commit "acc8835449475d7cd205aba213fdd3d41c38ba40")
+ (revision "0"))
+ (package
+ (name "emacs-idris-mode")
+ (version (git-version "0.9.19" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/idris-hackers/idris-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "0n9xbknc68id0mf8hbfmawi8qpvrs47ix807sk9ffv2g3ik32kk6"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-prop-menu" ,emacs-prop-menu)))
+ (home-page
+ "https://github.com/idris-hackers/idris-mode")
+ (synopsis "Major mode for editing Idris code")
+ (description
+ "This is an Emacs mode for editing Idris code. It requires the latest
version of Idris, and some features may rely on the latest Git version of
Idris.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-browse-at-remote
(package
--
2.21.0
Ricardo Wurmus wrote 6 years ago
(name . Eric Bavier)(address . bavier@member.fsf.org)(address . 36018@debbugs.gnu.org)
87o93jjb15.fsf@elephly.net
Hi Eric,

Toggle quote (5 lines)
> From: Eric Bavier <bavier@member.fsf.org>
>
> * gnu/packages/emacs-xyz.scm (emacs-idris-mode)[source]: Use git-fetch.
> [version]: Include revision and commit.

LGTM!

--
Ricardo
Eric Bavier wrote 6 years ago
(address . 36018-done@debbugs.gnu.org)
329406780.62520970.1560140427339.JavaMail.zimbra@centurylink.net
Pushed in commit ac302576006c95ab9adfe7a1f9bf11f7f3846e45

Thanks,
--
`~Eric
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36018@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36018
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help