[PATCH] gnu: add gthumb

  • Done
  • quality assurance status badge
Details
2 participants
  • atai
  • Ricardo Wurmus
Owner
unassigned
Submitted by
atai
Severity
normal
A
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
20190530070238.8683-1-atai@atai.org
From: Andy Tai <atai@atai.org>

* gnu/packages/gnome.scm (gthumb): Add at 3.8.0
---
gnu/packages/gnome.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 14e63280ed..e1aa6c6fc5 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7974,3 +7974,43 @@ functionality.")
(license (list license:lgpl2.1 license:lgpl3 ; either one of these
license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
license:lgpl2.1+)))) ; smime/lib/*
+
+
+(define-public gthumb
+ (package
+ (name "gthumb")
+ (version "3.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gthumb/"
+ (version-major+minor version) "/"
+ "gthumb-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1l2s1facq1r6yvqjqc34aqfzlvb3nhkhn79xisxbbdlgrrxdq52f"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:validate-runpath? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin") ; For glib-compile-resources
+ ("gtk+:bin" ,gtk+ "bin") ; For gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("exiv2" ,exiv2)
+ ("gtk" ,gtk+)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gstreamer" ,gstreamer)
+ ("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libraw" ,libraw)))
+ (synopsis "GNOME image viewer and browser")
+ (description "GThumb is an image viewer, browser, organizer, editor and
+advanced image management tool")
+ (home-page "https://wiki.gnome.org/Apps/Ghex")
+ (license license:gpl2+)))
--
2.20.1
A
(address . 35999@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
20190530071011.9435-1-atai@atai.org
From: Andy Tai <atai@atai.org>

* gnu/packages/gnome.scm (gthumb): Add at 3.8.0
---
gnu/packages/gnome.scm | 40 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 40 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 14e63280ed..371d8b2509 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -7974,3 +7974,43 @@ functionality.")
(license (list license:lgpl2.1 license:lgpl3 ; either one of these
license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
license:lgpl2.1+)))) ; smime/lib/*
+
+
+(define-public gthumb
+ (package
+ (name "gthumb")
+ (version "3.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gthumb/"
+ (version-major+minor version) "/"
+ "gthumb-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1l2s1facq1r6yvqjqc34aqfzlvb3nhkhn79xisxbbdlgrrxdq52f"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:validate-runpath? #f))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib:bin" ,glib "bin") ; For glib-compile-resources
+ ("gtk+:bin" ,gtk+ "bin") ; For gtk-update-icon-cache
+ ("desktop-file-utils" ,desktop-file-utils) ; for update-desktop-database
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("exiv2" ,exiv2)
+ ("gtk" ,gtk+)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gstreamer" ,gstreamer)
+ ("clutter" ,clutter)
+ ("clutter-gst" ,clutter-gst)
+ ("clutter-gtk" ,clutter-gtk)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libraw" ,libraw)))
+ (synopsis "GNOME image viewer and browser")
+ (description "GThumb is an image viewer, browser, organizer, editor and
+advanced image management tool")
+ (home-page "https://wiki.gnome.org/Apps/Gthumb")
+ (license license:gpl2+)))
--
2.20.1
R
R
Ricardo Wurmus wrote on 30 May 2019 09:37
(name . Andy Tai)(address . atai@atai.org)(address . 35999@debbugs.gnu.org)
87y32ojsug.fsf@elephly.net
Hi Andy,

Toggle quote (2 lines)
> * gnu/packages/gnome.scm (gthumb): Add at 3.8.0

thanks for the patch.

(Note that the commit message should be “Add variable.”)


Toggle quote (3 lines)
> + (arguments
> + `(#:validate-runpath? #f))

It’s not a good idea to disable RUNPATH validation, because it usually
shows you that something might be wrong. In this package the problem is
that the RUNPATH does not include the lib/gthumb/extensions
directory.

I’m still fighting with a handful of binaries that don’t seem to get the
right RUNPATH, but once that’s done I’ll push the updated patch to the
master branch.

--
Ricardo
R
R
Ricardo Wurmus wrote on 30 May 2019 11:51
(name . Andy Tai)(address . atai@atai.org)(address . 35999-done@debbugs.gnu.org)
87woi8jmmw.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (21 lines)
> Hi Andy,
>
>> * gnu/packages/gnome.scm (gthumb): Add at 3.8.0
>
> thanks for the patch.
>
> (Note that the commit message should be “Add variable.”)
>
>
>> + (arguments
>> + `(#:validate-runpath? #f))
>
> It’s not a good idea to disable RUNPATH validation, because it usually
> shows you that something might be wrong. In this package the problem is
> that the RUNPATH does not include the lib/gthumb/extensions
> directory.
>
> I’m still fighting with a handful of binaries that don’t seem to get the
> right RUNPATH, but once that’s done I’ll push the updated patch to the
> master branch.

Pushed to the master branch with commit 169d63f533.
I fixed the RUNPATH problems and made sure the application doesn’t crash
with a GLib-GIO-ERROR error by adding #:glib-or-gtk? #t.

--
Ricardo
Closed
?