[PATCH 41/47] gnu: Add python-pyuserinput.

  • Open
  • quality assurance status badge
Details
One participant
  • h.nasajpour
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:34
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003445.3057-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-pyuserinput): New variable
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b9bfc1be14..0c06833cec 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15457,3 +15457,20 @@ by Igor Pavlov.")
(description
"Various helpers to pass data to untrusted environments and back.")
(license license:bsd-3)))
+
+(define-public python-pyuserinput
+ (package
+ (name "python-pyuserinput")
+ (version "0.1.11")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyUserInput" version))
+ (sha256 (base32 "0azvlzfczrxhpxi15r37cbqkbbn5ip5y28bj5kmywh7pdk85wsq0"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://github.com/PyUserInput/PyUserInput")
+ (synopsis "A simple, cross-platform module for mouse and keyboard control")
+ (description
+ "A module for cross-platform control of the mouse and keyboard in python that is simple to use.")
+ (license license:lgpl3)))
--
2.17.1
?