[PATCH 39/47] gnu: Add python-relativetimebuilder.

  • Done
  • quality assurance status badge
Details
2 participants
  • h.nasajpour
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:33
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003355.2951-1-h.nasajpour@pantherx.org
* gnu/packages/time.scm (python-relativetimebuilder): New variable
---
gnu/packages/time.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 9bbfe07803..1363843b31 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -381,6 +381,28 @@ datetime type.")
(define-public python2-aniso8601
(package-with-python2 python-aniso8601))
+(define-public python-relativetimebuilder
+ (package
+ (name "python-relativetimebuilder")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "relativetimebuilder" version))
+ (sha256 (base32 "0dxj2jci4jsqv0w4alhj9lbrw9qdxkdl2y7mnk0xns7i2ps0i1jn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (propagated-inputs
+ `(
+ ("python-aniso8601",python-aniso8601)
+ ("python-dateutil",python-dateutil)
+ ))
+ (home-page "https://bitbucket.org/nielsenb/relativetimebuilder/src/master/")
+ (synopsis "aniso8601 builder for dateutil relativedeltas")
+ (description
+ "A library for using the dateutil relativedeltas for calendar precision with aniso8601")
+ (license license:expat)))
+
(define-public datefudge
(package
(name "datefudge")
--
2.17.1
S
S
Sharlatan Hellseher wrote 6 days ago
(address . 35971-done@debbugs.gnu.org)
87ldulilko.fsf@gmail.com
Hi,

Pushed to master with refreshing to the latest version and applying some
modification:

60c1d26209f * gnu: Add python-relativetimebuilder.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmeiY0cACgkQdtcnv/Ys
0rVZWRAAmgXOlR0isotBI0uxjV0NKntX+ouf2BCJraGkbFXZK+pK7TRbVZ3HxAJK
0IeJQ+M3Wg8u/LQn/KooRDHI+iapPJbcSEQ0LkOi0O8HFK9fUegqZa6Ehr1d4kV7
+eZwNAANXkGA4bFps7PSSeaxfqFU9jUNJ7EicgqWenVXm0MXEOX5Yo5ESqIsU595
Q76Hp5rgLqRNA8xhaXu6uDDuuKBj8q2sAuFiRFxpOC7sjMYYYhYW7DtrZEN9mBbD
EUaCLYRMocbfIzIPQZ9zBndpBImy7nxu3wYdCuSGhwJyvGxU3i7FewYfKHUHqxqC
GC4FJD/MqyQNkxWo44SsfEiyXxoP21Oz1qzDXw3v21NDUEM/cUhQRxIximhEATSB
zQo65Y7DFO7Gd0gOT+nMXEJ1vnLWgxDYfEu2r81I5DBpnHWt2lzdNuTsTFtmTPLe
fzkwVdi19lhrjf2bUHttHCKyw0O1JEJVSvnqQm4NDai+2cD99UNQL84LK+kBmpdW
39PfOJRI7RQ4zcvSuvcvXsZBOI94k77/stMZ91pTDvNJobTW/+bNbBTrB7sVz2U/
Mf7UnzD1SZYn0fUaorjfo35s6TYXs6FsdP7Iw7FdclCQ0vUBV5Z17lnxiz69HMUV
ewTtECZ45yFRDBDTGFbj8Dp9HsgXMrOXkVFM8hQP59UP/uWG8eo=
=tg7c
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 35971@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35971
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch