[PATCH 3/4] gnu: python-hdf4: Update to 0.9.2.

  • Done
  • quality assurance status badge
Details
5 participants
  • Brett Gilio
  • Ludovic Courtès
  • Maxim Cournoyer
  • Marius Bakke
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
8736l3qtjx.fsf@posteo.net
From fb102715cd2b809e4d963b8f71df54bbad06c369 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 24 May 2019 19:10:33 -0500
Subject: [PATCH 3/4] gnu: python-hdf4: Update to 0.9.2.

* gnu/packages/python-xyz.scm (python-hdf4): Update to 0.9.2.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a58b788ca1..54cc0c2b27 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -370,14 +370,14 @@ and verifies that it matches the intended target hostname.")
(define-public python-hdf4
(package
(name "python-hdf4")
- (version "0.9")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri name version))
(sha256
(base32
- "1hjiyrxvxk9817qyqky3nar4y3fs4z8wxz0n884zzb5wi6skrjks"))))
+ "00sxppysk3w620g1jdskjzkybvpf8dkpzjfj3wlw5khpzw1g0hq5"))))
(build-system python-build-system)
(native-inputs `(("nose" ,python-nose)))
(propagated-inputs `(("numpy" ,python-numpy)))
--
2.21.0
Brett Gilio wrote 6 years ago
[PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
(address . 35890@debbugs.gnu.org)
87zhnbpee0.fsf@posteo.net
From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Fri, 24 May 2019 19:11:00 -0500
Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.

* gnu/packages/python-xyz.scm (python-hdf4): Update to .
---
gnu/packages/python-xyz.scm | 15 ---------------
1 file changed, 15 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 54cc0c2b27..43287d212e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
`(("hdf4" ,hdf4)
("libjpeg" ,libjpeg)
("zlib" ,zlib)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
- ;; on to import numpy. Somehow this works on their CI system.
- ;; Let's just manage PYTHONPATH here instead.
- (substitute* "runexamples.sh"
- (("export PYTHONPATH=.*") ""))
- (setenv "PYTHONPATH"
- (string-append (getcwd) ":"
- (getenv "PYTHONPATH")))
- (invoke "./runexamples.sh")
- (invoke "nosetests" "-v"))))))
(home-page "https://github.com/fhs/python-hdf4")
(synopsis "Python interface to the NCSA HDF4 library")
(description
--
2.21.0
Marius Bakke wrote 6 years ago
871s0ld3hn.fsf@devup.no
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (37 lines)
> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 24 May 2019 19:11:00 -0500
> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>
> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
> ---
> gnu/packages/python-xyz.scm | 15 ---------------
> 1 file changed, 15 deletions(-)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 54cc0c2b27..43287d212e 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
> `(("hdf4" ,hdf4)
> ("libjpeg" ,libjpeg)
> ("zlib" ,zlib)))
> - (arguments
> - `(#:phases
> - (modify-phases %standard-phases
> - (replace 'check
> - (lambda _
> - ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
> - ;; on to import numpy. Somehow this works on their CI system.
> - ;; Let's just manage PYTHONPATH here instead.
> - (substitute* "runexamples.sh"
> - (("export PYTHONPATH=.*") ""))
> - (setenv "PYTHONPATH"
> - (string-append (getcwd) ":"
> - (getenv "PYTHONPATH")))
> - (invoke "./runexamples.sh")
> - (invoke "nosetests" "-v"))))))
> (home-page "https://github.com/fhs/python-hdf4")
> (synopsis "Python interface to the NCSA HDF4 library")
> (description

While this makes the build succeed, the 'check' phase is now moot. It
appears to simply build the library for a second time, and then prints
'Ran 0 tests in N seconds...'.

Can you look into what happened to the tests between version 0.9.0 and
0.9.2?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlzqThQACgkQoqBt8qM6
VPopVwgAr86067P1Mo3Qt8gXNjw+Ec53xLdnAdAaGBX7YWPdGqF9fJ4929Rt5T6U
NBdj9rU0OOY1Ezmj+1H1vM703xcUcEdeERuHYuvmIhhhMDVy8JH7uMBunW7/G66z
MOsY2N+WLzl5O/0vtVh8K5rO4gKrnUbGexCmIGxXydzjFFjU08QXXLvdMoRQG59A
/dP+OQtcm8vapK1TI6mAU4e8ZMRssuIqJJrbCvBRusecsn06zzjEpImOli5m19f8
fQUVNEzJcBDnwBaYBKT+BKxMi2jmv0DDS+busX5haW7WYQ608MpWt61tftijMy/C
MVBmBH3HvvKGCTytj/e7n5plw/pm6A==
=UhM9
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 35890@debbugs.gnu.org)
875zpxxzaa.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (7 lines)
> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Fri, 24 May 2019 19:11:00 -0500
> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>
> * gnu/packages/python-xyz.scm (python-hdf4): Update to .

I guess you’re using the yasnippets for Emacs :)

It’s fine to do this in the same commit as the upgrade, but as Marius
wrote the tests should actually be run.

--
Ricardo
Ludovic Courtès wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)
87a7dw7979.fsf@gnu.org
Hello Brett,

Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (46 lines)
> Brett Gilio <brettg@posteo.net> writes:
>
>> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Fri, 24 May 2019 19:11:00 -0500
>> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>>
>> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
>> ---
>> gnu/packages/python-xyz.scm | 15 ---------------
>> 1 file changed, 15 deletions(-)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 54cc0c2b27..43287d212e 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
>> `(("hdf4" ,hdf4)
>> ("libjpeg" ,libjpeg)
>> ("zlib" ,zlib)))
>> - (arguments
>> - `(#:phases
>> - (modify-phases %standard-phases
>> - (replace 'check
>> - (lambda _
>> - ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
>> - ;; on to import numpy. Somehow this works on their CI system.
>> - ;; Let's just manage PYTHONPATH here instead.
>> - (substitute* "runexamples.sh"
>> - (("export PYTHONPATH=.*") ""))
>> - (setenv "PYTHONPATH"
>> - (string-append (getcwd) ":"
>> - (getenv "PYTHONPATH")))
>> - (invoke "./runexamples.sh")
>> - (invoke "nosetests" "-v"))))))
>> (home-page "https://github.com/fhs/python-hdf4")
>> (synopsis "Python interface to the NCSA HDF4 library")
>> (description
>
> While this makes the build succeed, the 'check' phase is now moot. It
> appears to simply build the library for a second time, and then prints
> 'Ran 0 tests in N seconds...'.
>
> Can you look into what happened to the tests between version 0.9.0 and
> 0.9.2?

Any update on this?

Ludo’.
Maxim Cournoyer wrote 3 years ago
control message for bug #35890
(address . control@debbugs.gnu.org)
87cze5r9pe.fsf@gmail.com
close 35890
quit
Maxim Cournoyer wrote 3 years ago
Re: bug#35890: [PATCH 3/4] gnu: python-hdf4: Update to 0.9.2.
(name . Ludovic Courtès)(address . ludo@gnu.org)
87edylr9pn.fsf_-_@gmail.com
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (52 lines)
> Hello Brett,
>
> Marius Bakke <mbakke@fastmail.com> skribis:
>
>> Brett Gilio <brettg@posteo.net> writes:
>>
>>> From 74c956284d5ff7b20e12ed4315404697320dc809 Mon Sep 17 00:00:00 2001
>>> From: Brett Gilio <brettg@posteo.net>
>>> Date: Fri, 24 May 2019 19:11:00 -0500
>>> Subject: [PATCH 4/4] gnu: python-hdf4: Remove check-phase argument.
>>>
>>> * gnu/packages/python-xyz.scm (python-hdf4): Update to .
>>> ---
>>> gnu/packages/python-xyz.scm | 15 ---------------
>>> 1 file changed, 15 deletions(-)
>>>
>>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>>> index 54cc0c2b27..43287d212e 100644
>>> --- a/gnu/packages/python-xyz.scm
>>> +++ b/gnu/packages/python-xyz.scm
>>> @@ -385,21 +385,6 @@ and verifies that it matches the intended target hostname.")
>>> `(("hdf4" ,hdf4)
>>> ("libjpeg" ,libjpeg)
>>> ("zlib" ,zlib)))
>>> - (arguments
>>> - `(#:phases
>>> - (modify-phases %standard-phases
>>> - (replace 'check
>>> - (lambda _
>>> - ;; The 'runexamples' script sets PYTHONPATH to CWD, then goes
>>> - ;; on to import numpy. Somehow this works on their CI system.
>>> - ;; Let's just manage PYTHONPATH here instead.
>>> - (substitute* "runexamples.sh"
>>> - (("export PYTHONPATH=.*") ""))
>>> - (setenv "PYTHONPATH"
>>> - (string-append (getcwd) ":"
>>> - (getenv "PYTHONPATH")))
>>> - (invoke "./runexamples.sh")
>>> - (invoke "nosetests" "-v"))))))
>>> (home-page "https://github.com/fhs/python-hdf4")
>>> (synopsis "Python interface to the NCSA HDF4 library")
>>> (description
>>
>> While this makes the build succeed, the 'check' phase is now moot. It
>> appears to simply build the library for a second time, and then prints
>> 'Ran 0 tests in N seconds...'.
>>
>> Can you look into what happened to the tests between version 0.9.0 and
>> 0.9.2?
>
> Any update on this?

No update in 3 years; closing.

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35890@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35890
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help