[PATCH] gnu: mes: Prepare for non-x86 architectures.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190515154201.31101-1-dannym@scratchpost.org
* gnu/packages/mes.scm (mes)[native-inputs]: Prepare for non-x86
architectures.
---
gnu/packages/mes.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index c45e267875..5c6b64150b 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -78,13 +78,16 @@ extensive examples, including parsers for the Javascript and C99 languages.")
("nyacc" ,nyacc)))
(native-inputs
`(("guile" ,guile-2.2)
- ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
- (%current-system))))
+ ,@(let ((target-system (or (%current-target-system)
+ (%current-system))))
+ (cond
+ ((string-prefix? "x86_64-linux" target-system)
;; Use cross-compiler rather than #:system "i686-linux" to get
;; MesCC 64 bit .go files installed ready for use with Guile.
`(("i686-linux-binutils" ,(cross-binutils triplet))
- ("i686-linux-gcc" ,(cross-gcc triplet)))
- '())
+ ("i686-linux-gcc" ,(cross-gcc triplet))))
+ (else
+ '())))
("graphviz" ,graphviz)
("help2man" ,help2man)
("perl" ,perl) ; build-aux/gitlog-to-changelog
Danny Milosavljevic wrote 6 years ago
[PATCH v2] gnu: mes: Prepare for non-x86 architectures.
(address . 35753@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190515165336.7816-1-dannym@scratchpost.org
* gnu/packages/mes.scm (mes)[native-inputs]: Prepare for non-x86
architectures.
---
gnu/packages/mes.scm | 74 +++++++++++++++++++++++---------------------
1 file changed, 38 insertions(+), 36 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index c45e267875..afb1e025b4 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -60,46 +60,48 @@ extensive examples, including parsers for the Javascript and C99 languages.")
(license (list gpl3+ lgpl3+))))
(define-public mes
- (let ((triplet "i686-unknown-linux-gnu"))
- (package
- (name "mes")
- (version "0.19")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/mes/"
- "mes-" version ".tar.gz"))
- (sha256
- (base32
- "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
- (build-system gnu-build-system)
- (supported-systems '("i686-linux" "x86_64-linux"))
- (propagated-inputs
- `(("mescc-tools" ,mescc-tools)
- ("nyacc" ,nyacc)))
- (native-inputs
- `(("guile" ,guile-2.2)
- ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
- (%current-system))))
- ;; Use cross-compiler rather than #:system "i686-linux" to get
- ;; MesCC 64 bit .go files installed ready for use with Guile.
- `(("i686-linux-binutils" ,(cross-binutils triplet))
- ("i686-linux-gcc" ,(cross-gcc triplet)))
- '())
- ("graphviz" ,graphviz)
- ("help2man" ,help2man)
- ("perl" ,perl) ; build-aux/gitlog-to-changelog
- ("texinfo" ,texinfo)))
- (arguments
- `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
- (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
- (description
- "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
+ (package
+ (name "mes")
+ (version "0.19")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/mes/"
+ "mes-" version ".tar.gz"))
+ (sha256
+ (base32
+ "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
+ (build-system gnu-build-system)
+ (supported-systems '("i686-linux" "x86_64-linux"))
+ (propagated-inputs
+ `(("mescc-tools" ,mescc-tools)
+ ("nyacc" ,nyacc)))
+ (native-inputs
+ `(("guile" ,guile-2.2)
+ ,@(let ((target-system (or (%current-target-system)
+ (%current-system))))
+ (cond
+ ((string-prefix? "x86_64-linux" target-system)
+ ;; Use cross-compiler rather than #:system "i686-linux" to get
+ ;; MesCC 64 bit .go files installed ready for use with Guile.
+ `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
+ ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
+ (else
+ '())))
+ ("graphviz" ,graphviz)
+ ("help2man" ,help2man)
+ ("perl" ,perl) ; build-aux/gitlog-to-changelog
+ ("texinfo" ,texinfo)))
+ (arguments
+ `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
+ (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
+ (description
+ "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
bootstrap to Guix and aims to help create full source bootstrapping for
GNU/Linux distributions. It consists of a mutual self-hosting Scheme
interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
Guile.")
- (home-page "https://gnu.org/software/mes")
- (license gpl3+))))
+ (home-page "https://gnu.org/software/mes")
+ (license gpl3+)))
(define-public mescc-tools
(package
Ludovic Courtès wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 35753@debbugs.gnu.org)
874l5n3odz.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (3 lines)
> * gnu/packages/mes.scm (mes)[native-inputs]: Prepare for non-x86
> architectures.

Please describe the change in terms of what’s added/remove from
‘native-inputs’.

Toggle quote (13 lines)
> + (native-inputs
> + `(("guile" ,guile-2.2)
> + ,@(let ((target-system (or (%current-target-system)
> + (%current-system))))
> + (cond
> + ((string-prefix? "x86_64-linux" target-system)
> + ;; Use cross-compiler rather than #:system "i686-linux" to get
> + ;; MesCC 64 bit .go files installed ready for use with Guile.
> + `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
> + ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
> + (else
> + '())))

LGTM, thanks!

Looking forward to Mes on ARM!

Ludo’.
Danny Milosavljevic wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
20190521223136.075ec9bb@scratchpost.org
close 35753
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzkYCgACgkQ5xo1VCww
uqVI2gf/RbRdCRz+EP9agoBpeO6UdclbGwTk2d0QyEi0wahCrjjukqb+B6ZBGbWf
mUDUaeq8kTm0ffKtr0W/Iw+cxqg7MBaqVwPOAxsYTiqmDCwFDgMKf/Nr6GmbPztA
I59RmGxqgSoIgRC9O83IzZIRsbi+mq87t5j8j7U3JSckmFvH/7QAt6woljT+eGoR
9SWAW1vvfFC38w+X6+kqvdvQNcxFWGa/OMaC880DaMEBp4N20WTcp98dCg8KlCEU
/Q+o+ywvwg5V6EfhdLatvwm0dY4f+6Kh17Wl4ftURv5VVNYOiuE7Cy7pjYgQQlGL
x2g5dlXKlzZUzdhGGPPQSJgAldt9lQ==
=eRiw
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 35753@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35753
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help