[PATCH] gnu: Add libdbusmenu.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Meiyo Peng
Owner
unassigned
Submitted by
Meiyo Peng
Severity
normal

Debbugs page

Meiyo Peng wrote 6 years ago
(address . guix-patches@gnu.org)(name . Meiyo Peng)(address . meiyo@riseup.net)
20190515045127.30916-1-meiyo@riseup.net
* gnu/packages/gtk.scm (libdbusmenu): New variable.
---
gnu/packages/gtk.scm | 51 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (68 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 6e63ca6614..a885d35080 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Meiyo Peng <meiyo@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1754,3 +1755,53 @@ popular spread sheet programs.")
shell scripts. Example of how to use @code{yad} can be consulted at
@url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
(license license:gpl3+)))
+
+(define-public libdbusmenu
+ (package
+ (name "libdbusmenu")
+ (version "16.04.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/libdbusmenu/"
+ (version-major+minor version) "/" version
+ "/+download/libdbusmenu-" version ".tar.gz"))
+ (sha256
+ (base32 "12l7z8dhl917iy9h02sxmpclnhkdjryn08r8i4sr8l3lrlm4mk5r"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ '("--sysconfdir=/etc"
+ "--localstatedir=/var"
+ ;; The shebang of the generated test files should be patched before
+ ;; enabling tests.
+ "--disable-tests")
+ #:make-flags
+ `(,(string-append "typelibdir=" (assoc-ref %outputs "out")
+ "/lib/girepository-1.0"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-environment
+ (lambda _
+ (setenv "HAVE_VALGRIND_TRUE" "")
+ (setenv "HAVE_VALGRIND_FALSE" "#")
+ #t)))))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("gtk+-2" ,gtk+-2)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("gnome-doc-utils" ,gnome-doc-utils)
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("json-glib" ,json-glib)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2)
+ ("vala" ,vala)))
+ (home-page "https://launchpad.net/libdbusmenu")
+ (synopsis "Library for passing menus over DBus")
+ (description "@code{libdbusmenu} passes a menu structure across DBus so
+that a program can create a menu simply without worrying about how it is
+displayed on the other side of the bus.")
+ (license (list license:gpl3 license:lgpl2.1 license:lgpl3))))
--
2.21.0
Ludovic Courtès wrote 6 years ago
(name . Meiyo Peng)(address . meiyo@riseup.net)(address . 35741-done@debbugs.gnu.org)
87tvdoom3i.fsf@gnu.org
Hi!

Meiyo Peng <meiyo@riseup.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/gtk.scm (libdbusmenu): New variable.

Applied!

Toggle quote (4 lines)
> + ;; The shebang of the generated test files should be patched before
> + ;; enabling tests.
> + "--disable-tests")

It would be nice if you could follow up with a patch to run the tests.

Toggle quote (2 lines)
> + (license (list license:gpl3 license:lgpl2.1 license:lgpl3))))

In a subsequent patch, I clarified the licensing here, which is
dual-license LGPLv2.1 | LGPLv3 according to the header that can be seen
here:


Thanks,
Ludo’.
Closed
Meiyo Peng wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35741-done@debbugs.gnu.org)
877eaix6z5.fsf@riseup.net
Hi Ludovic,

Ludovic Courtès writes:

Toggle quote (12 lines)
> Meiyo Peng <meiyo@riseup.net> skribis:
>
>> * gnu/packages/gtk.scm (libdbusmenu): New variable.
>
> Applied!
>
>> + ;; The shebang of the generated test files should be patched before
>> + ;; enabling tests.
>> + "--disable-tests")
>
> It would be nice if you could follow up with a patch to run the tests.

Will try.

Toggle quote (8 lines)
>> + (license (list license:gpl3 license:lgpl2.1 license:lgpl3))))
>
> In a subsequent patch, I clarified the licensing here, which is
> dual-license LGPLv2.1 | LGPLv3 according to the header that can be seen
> here:
>
> https://bazaar.launchpad.net/~dbusmenu-team/libdbusmenu/trunk.16.10/view/head:/libdbusmenu-glib/menuitem-private.h

Good catch. But this project's license is weird.


#+begin_example
Files: *
Copyright: 2009-2010 Ted Gould <ted@canonical.com>, Canonical Ltd.
License: GPL-3

Files: libdbusmenu-{glib,gtk}/*
Copyright: 2009-2010 Ted Gould <ted@canonical.com>, Canonical Ltd.
License: LGPL-2.1 | LGPL-3

Files: libdbusmenu-glib/dbus-menu.xml
Copyright: 2009-2010 Ted Gould <ted@canonical.com>, Canonical Ltd.
Copyright: 2009-2010 Aurélien Gâteau <aurelien.gateau@canonical.com>
License: LGPL-2.1 | LGPL-3

Files: tools/{dbusmenu-bench,testapp/main.c}
Copyright: 2009-2010 Aurélien Gâteau <aurelien.gateau@canonical.com>
License: LGPL-2.1 | LGPL-3

Files: debian/*
Copyright: 2009-2010 Evgeni Golov <evgeni@debian.org>
Copyright: 2009-2010 Ted Gould <ted@canonical.com>, Canonical Ltd.
Copyright: 2009-2010 Sebastien Bacher <seb128@ubuntu.com>
Copyright: 2009-2010 Ken VanDine <ken.vandine@canonical.com>
License: GPL-3
#+end_example

libdbusmenu-glib, libdbusmenu-gtk, and some files in tools are dual
licensed under LGPLv2.1 and LGPLv3. The rest files are licensed under
GPLv3. For example:

#+begin_example
#+end_example

So we should clarify it further.


--
Meiyo Peng
Closed
Ludovic Courtès wrote 6 years ago
(name . Meiyo Peng)(address . meiyo@riseup.net)(address . 35741-done@debbugs.gnu.org)
87lfyvx44p.fsf@gnu.org
Hello,

Meiyo Peng <meiyo@riseup.net> skribis:

Toggle quote (8 lines)
>>> + ;; The shebang of the generated test files should be patched before
>>> + ;; enabling tests.
>>> + "--disable-tests")
>>
>> It would be nice if you could follow up with a patch to run the tests.
>
> Will try.

Great.

Toggle quote (11 lines)
> libdbusmenu-glib, libdbusmenu-gtk, and some files in tools are dual
> licensed under LGPLv2.1 and LGPLv3. The rest files are licensed under
> GPLv3. For example:
>
> #+begin_example
> https://bazaar.launchpad.net/~dbusmenu-team/libdbusmenu/trunk.16.10/view/head:/tests/json-loader.c
> https://bazaar.launchpad.net/~dbusmenu-team/libdbusmenu/trunk.16.10/view/head:/tools/dbusmenu-dumper.c
> #+end_example
>
> So we should clarify it further.

I’d argue that ‘license’ is about the license of what we install, so the
license of the tests or build scripts (say) doesn’t matter much, but
‘dbusmenu-dumper’ is presumably something we install. So I agree:
further clarification is welcome!

Thanks for explaining,
Ludo’.
Closed
Meiyo Peng wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35741-done@debbugs.gnu.org)
87y32vpa2o.fsf@riseup.net
Hi Ludovic,

Ludovic Courtès writes:

Toggle quote (3 lines)
> I’d argue that ‘license’ is about the license of what we install, so the
> license of the tests or build scripts (say) doesn’t matter much

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35741@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35741
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help