[PATCH] services: mcron: Log to a file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190509174032.28180-1-mail@cbaines.net
This makes it easier to read the output, as it's recorded in a file.

* gnu/services/mcron.scm (mcron-shepherd-services): Add #:log-file to
make-forkexec-constructor.
---
gnu/services/mcron.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/services/mcron.scm b/gnu/services/mcron.scm
index 1b232b6cba..fd84589c19 100644
--- a/gnu/services/mcron.scm
+++ b/gnu/services/mcron.scm
@@ -121,7 +121,9 @@ files."
(cons* "GUILE_AUTO_COMPILE=0"
"PATH=/run/current-system/profile/bin"
(remove (cut string-prefix? "PATH=" <>)
- (environ)))))
+ (environ)))
+
+ #:log-file "/var/log/mcron.log"))
(stop #~(make-kill-destructor))
(actions
--
2.21.0
Ludovic Courtès wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 35656@debbugs.gnu.org)
8736lm1mna.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (5 lines)
> This makes it easier to read the output, as it's recorded in a file.
>
> * gnu/services/mcron.scm (mcron-shepherd-services): Add #:log-file to
> make-forkexec-constructor.

Good idea, LGTM!

Ludo’.
Christopher Baines wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35656-done@debbugs.gnu.org)
87woivmfjh.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (11 lines)
> Hi,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> This makes it easier to read the output, as it's recorded in a file.
>>
>> * gnu/services/mcron.scm (mcron-shepherd-services): Add #:log-file to
>> make-forkexec-constructor.
>
> Good idea, LGTM!

I've pushed this to master now, thanks for taking a look :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlzYqNJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcWxw//RgpHR3jGb/Veg5ALY9zFTUKrxJTOn4tkLVeqOrkv2pDe5b4KmdlszXy6
t6tm1zdnAGrOn590VqQFGGkT6ckQrO8qs5cb9YQNB6bztiuJ2D3YHZy7kipEoAPI
17FEUUv9L95w/XuFj4LMmy84ciwQcT4gv5WHtHx8OuAsk/pyCCXio2tsFbNpYK2k
8DudLsTEAs/ZVZHsWcfNuzJQCUbcG7rykjH0qUlG+vUFUu7JEmhBTRkW0jwJ3YdY
SSRWjPVcj1QF5VFdYg1yv/s9WByvSv3rHiyH2npJVfuKVSGMuZf2qlLP67aWeEiO
d5pFwpT2m+JKjmcggmLDeJEObfZ1xi3wkjRCCb6a5WXHO/UFaFCkFFpb81TF6uhr
D3Mp+MCmJPsamdXC/kwgFrn2JbAP4ZGL51PAckVi73N175eJp11esln5fxgYN5uL
F69zV/Cl1KOUg3hKo7vobQHhKkUO/UWbpoqjdU/WvZ7Sv0A4eAhxA1THNnHo6vPg
J3eimzO0yVKgly1F1uXJUrZP6M4d2gHFO/+UtK5apgK0h99ibjj/urjfg3dbUPXl
jJbDv3TZvi9QIonk2TryEEse9WpHLsIUGtZephCXxm6Jfn904tWv//GGnM4mA4QQ
fkfQjC23xMSSjiwS0bENOTEDozsFlyjynSoqUeW82F5WhXe2/9o=
=ycwZ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35656@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35656
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help