[PATCH] uuid: Pad resulting FAT uuid string with leading zeroes.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190505214354.24882-1-dannym@scratchpost.org
Reported by sirgazil <sirgazil@zoho.com>.

* gnu/system/uuid.scm (fat-uuid->string): Pad resulting string with leading
zeroes.
---
gnu/system/uuid.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (13 lines)
diff --git a/gnu/system/uuid.scm b/gnu/system/uuid.scm
index f13960c3e9..7204d163d0 100644
--- a/gnu/system/uuid.scm
+++ b/gnu/system/uuid.scm
@@ -175,7 +175,7 @@ ISO9660 UUID representation."
"Convert FAT32/FAT16 UUID, a 4-byte bytevector, to its string representation."
(let ((high (bytevector-uint-ref uuid 0 %fat-endianness 2))
(low (bytevector-uint-ref uuid 2 %fat-endianness 2)))
- (format #f "~:@(~x-~x~)" low high)))
+ (format #f "~:@(~4,'0x-~4,'0x~)" low high)))
(define %fat-uuid-rx
(make-regexp "^([[:xdigit:]]{4})-([[:xdigit:]]{4})$"))
Ludovic Courtès wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 35593-done@debbugs.gnu.org)
87y33gey4w.fsf@gnu.org
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (6 lines)
> Reported by sirgazil <sirgazil@zoho.com>.
>
> * gnu/system/uuid.scm (fat-uuid->string): Pad resulting string with leading
> zeroes.

Bah, I feel guilty: I pushed the same patch with a test as
6c5790a2faf8ffc401e43b13425a707394e40874, and only now do I notice that
you had fixed it too. My apologies!

Perhaps in the future you should send the patch directly in the bug
report? That would increase the likelihood that I’ll notice and won’t
duplicate work.

(Perhaps in the future I should also pay more attention to email…
tricky!)

Ludo’.
Closed
Danny Milosavljevic wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35593-done@debbugs.gnu.org)
20190509144604.7f54a1e6@scratchpost.org
Hi Ludo,

On Thu, 09 May 2019 12:10:55 +0200
Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (10 lines)
> > Reported by sirgazil <sirgazil@zoho.com>.
> >
> > * gnu/system/uuid.scm (fat-uuid->string): Pad resulting string with leading
> > zeroes.
>
> Bah, I feel guilty: I pushed the same patch with a test as
> 6c5790a2faf8ffc401e43b13425a707394e40874, and only now do I notice that
> you had fixed it too. My apologies!

Don't worry. It's good that someone fixes it, doesn't matter whether it's you
or me :)

Toggle quote (4 lines)
> Perhaps in the future you should send the patch directly in the bug
> report? That would increase the likelihood that I’ll notice and won’t
> duplicate work.

Sure!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlzUIQwACgkQ5xo1VCww
uqW+ggf/XPN0dKgdqoLsOWDp0+nN96IBnZFzCOJoCb+GOkaRwE9GOEN7HrIePKuj
mc1HuESI0/yAMU7hWjW70CQ7x9l9tfHLcq9DXL3E3c+0VGgBIHtG7S2nIqeTeaic
K5CXWZbAoM/tlMN9TTfh8zFKomnZIG/ODWFxb9ArSsFpJ3GkfZ6EGMjH5jsjkMxa
O47TdJTTIM9F5Kl8BiPiEhuDtfhVOI24gzdykX/2OetYcVcBM1sMSFqOrTwpR+8Q
n47k/YKn/gXIZZsGBNPAJ3Rv/ZuK6ZtUTK17nERyXzHsS0ll/lDRs9S5SQqAxqsn
3VXCRGbjMPmhskaJ0vrS0tej78B66g==
=Blz3
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35593@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35593
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help