NSS-3.43 fails its test suite on armhf-linux

  • Open
  • quality assurance status badge
Details
2 participants
  • Mark H Weaver
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Mark H Weaver
Severity
normal
M
R
R
Ricardo Wurmus wrote on 3 May 2019 00:02
(name . Mark H Weaver)(address . mhw@netris.org)(address . 35530@debbugs.gnu.org)
878svowm4h.fsf@elephly.net
Mark H Weaver <mhw@netris.org> writes:

Toggle quote (4 lines)
> NSS-3.43 fails its test suite on armhf-linux:
>
> https://hydra.gnu.org/build/3484222

I can reproduce this. Looks like all problems are with the tests in
ssl_drop_unittest.cc:

ssl_drop_unittest.cc:182: Failure
ssl_drop_unittest.cc:71: Failure
ssl_drop_unittest.cc:182: Failure
ssl_drop_unittest.cc:71: Failure
ssl_drop_unittest.cc:422: Failure
ssl_drop_unittest.cc:451: Failure
ssl_drop_unittest.cc:380: Failure
ssl_drop_unittest.cc:474: Failure
ssl_drop_unittest.cc:474: Failure
ssl_drop_unittest.cc:71: Failure
ssl_drop_unittest.cc:71: Failure
ssl_drop_unittest.cc:71: Failure
ssl_drop_unittest.cc:95: Failure

It’s a bit difficult to find actual test failures in the logs because it
mentions “error” and “failed” and the like a lot. This is a test that
counts ACKs after dropping parts of the messages / datagrams /
handshake. The failing tests seem to consistently come up short on ACKs
– they are not always zero but usually much lower than they are expected
to be.

--
Ricardo
R
R
Ricardo Wurmus wrote on 4 May 2019 18:45
(name . Mark H Weaver)(address . mhw@netris.org)(address . 35530@debbugs.gnu.org)
87v9yqf9s2.fsf@elephly.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (30 lines)
> Mark H Weaver <mhw@netris.org> writes:
>
>> NSS-3.43 fails its test suite on armhf-linux:
>>
>> https://hydra.gnu.org/build/3484222
>
> I can reproduce this. Looks like all problems are with the tests in
> ssl_drop_unittest.cc:
>
> ssl_drop_unittest.cc:182: Failure
> ssl_drop_unittest.cc:71: Failure
> ssl_drop_unittest.cc:182: Failure
> ssl_drop_unittest.cc:71: Failure
> ssl_drop_unittest.cc:422: Failure
> ssl_drop_unittest.cc:451: Failure
> ssl_drop_unittest.cc:380: Failure
> ssl_drop_unittest.cc:474: Failure
> ssl_drop_unittest.cc:474: Failure
> ssl_drop_unittest.cc:71: Failure
> ssl_drop_unittest.cc:71: Failure
> ssl_drop_unittest.cc:71: Failure
> ssl_drop_unittest.cc:95: Failure
>
> It’s a bit difficult to find actual test failures in the logs because it
> mentions “error” and “failed” and the like a lot. This is a test that
> counts ACKs after dropping parts of the messages / datagrams /
> handshake. The failing tests seem to consistently come up short on ACKs
> – they are not always zero but usually much lower than they are expected
> to be.

Just disabling the ssl_drop_unittest.cc was not sufficient. It was only
when I forced the build to take place on one of the Overdrive machines
that the build succeeded.

I only built it with the ssl_drop_unittest.cc disabled:

Toggle snippet (19 lines)
diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 480f64a046..57d83313eb 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -116,6 +116,12 @@ in the Mozilla clients.")
`((setenv "USE_64" "1")))
(_
'()))
+ ;; XXX Disable broken tests on armhf
+ ,@(match (%current-system)
+ ("armhf-linux"
+ '((substitute* "nss/gtests/ssl_gtest/ssl_gtest.gyp"
+ (("'ssl_drop_unittest.cc',") ""))))
+ (_ '()))
#t))
(replace 'check
(lambda _

It’s possible that this is not actually necessary.

--
Ricardo
?