(name . guix-patches gnu)(address . guix-patches@gnu.org)
I am not sure how to handle this case.
From 9f3ed8f52957c61bd05da50b02e3a43a976facc3 Mon Sep 17 00:00:00 2001
From: Amirouche <amirouche+dev@hyper.dev>
Date: Wed, 1 May 2019 02:47:10 +0200
Subject: [PATCH] gnu: guile-pfds bugfix
* gnu/packages/guile-xyz.scm (guile-pfds)[source]: Add patch.
* gnu/packages/patches/guile-pfds-typofix.patch: Add it.
---
gnu/packages/guile-xyz.scm | 6 +++--
gnu/packages/patches/guile-pfds-typofix.patch | 25 +++++++++++++++++++
2 files changed, 29 insertions(+), 2 deletions(-)
create mode 100644 gnu/packages/patches/guile-pfds-typofix.patch
Toggle diff (57 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index d7866719b4..efdcd0fc11 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -626,7 +626,7 @@ using Guile's foreign function interface.")
(define-public guile-pfds
(package
(name "guile-pfds")
- (version "0.3")
+ (version "0.3.1")
(home-page "https://github.com/ijp/pfds")
(source (origin
(method git-fetch)
@@ -636,7 +636,9 @@ using Guile's foreign function interface.")
(sha256
(base32
"19y33wg94pf0n98dkfqd1zbw93fgky4sawxsxl6s3vyqwl0yi5vh"))
- (file-name (string-append name "-" version "-checkout"))))
+ (file-name (string-append name "-" version "-checkout"))
+ (patches
+ (search-patches "guile-pfds-typofix.patch"))))
(build-system guile-build-system)
(arguments
'(#:source-directory "src"
diff --git a/gnu/packages/patches/guile-pfds-typofix.patch b/gnu/packages/patches/guile-pfds-typofix.patch
new file mode 100644
index 0000000000..05fdc46e2b
--- /dev/null
+++ b/gnu/packages/patches/guile-pfds-typofix.patch
@@ -0,0 +1,25 @@
+From 0825c9daa90e1f0517bfe98e465fb5d54ab394ac Mon Sep 17 00:00:00 2001
+From: Amirouche <amirouche+dev@hyper.dev>
+Date: Wed, 1 May 2019 01:11:51 +0200
+Subject: [PATCH] hamts: typofix s/vector/trie/
+
+---
+ hamts.sls | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/hamts.sls b/hamts.sls
+index 8746141..a5310d2 100644
+--- a/hamts.sls
++++ b/hamts.sls
+@@ -307,7 +307,7 @@
+
+ (define (fold combine initial vector)
+ (define (handle-subtrie trie accum)
+- (vector-fold dispatch accum (subtrie-vector vector)))
++ (vector-fold dispatch accum (subtrie-vector trie)))
+
+ (define (handle-leaf leaf accum)
+ (combine (leaf-key leaf) (leaf-value leaf) accum))
+--
+2.19.1
+
--
2.19.1