[PATCH] vm: Pass -smp to QEMU to allow use of multiple cores.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190427204325.12364-1-mail@cbaines.net
* gnu/build/vm.scm (load-in-linux-vm): Pass (parallel-job-count) to QEMU with
-smp to allow using multiple cores.
---
gnu/build/vm.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 372cf63c68..ac99d6b1a3 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -145,6 +145,7 @@ the #:references-graphs parameter of 'derivation'."
(_ #f))
(apply invoke qemu "-nographic" "-no-reboot"
+ "-smp" (number->string (parallel-job-count))
"-m" (number->string memory-size)
"-object" "rng-random,filename=/dev/urandom,id=guixsd-vm-rng"
"-device" "virtio-rng-pci,rng=guixsd-vm-rng"
--
2.21.0
Ludovic Courtès wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 35461@debbugs.gnu.org)
8736m1jloe.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> * gnu/build/vm.scm (load-in-linux-vm): Pass (parallel-job-count) to QEMU with
> -smp to allow using multiple cores.

Good idea, LGTM!
Christopher Baines wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35461-done@debbugs.gnu.org)
87wojcr2no.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (7 lines)
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/build/vm.scm (load-in-linux-vm): Pass (parallel-job-count) to QEMU with
>> -smp to allow using multiple cores.
>
> Good idea, LGTM!

Great, I've pushed this to master now.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlzHWstfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd4Ow/+J1ot6c0SVM5sKZPRZ8jl2Y9KqPLnJcaerwwD+SRKd6mad/NmO5em9pE9
/M6P6TIvERA0VuILANSnr22DhEemanmpfaXmV2sxJTz5mOjSUOV94oNHmXooYQAY
jGsNDIHO0a49X1MyuEBBRx0Y4nzgfCsPbKW/xUdSc/aFMFX3rO45sWOHgOylC8mV
1VqjXdPnUr/U35PdBAtQdunGvSErRSpS4Ep8/5PMJfEq5CIM3J2GgVAbPTd0ssB0
56idO7iluAFb7cpdZ7ZZzPFnCa4shtalu5VLXGfpYQ0aexDFKasKIq1R3dajJLjz
M2kBy/l1pFX2nmLLRD2MJkh0lO/RimOltwEmgdr6LKhaWpuTXeGmvmFuww/+Ju2m
i6EhmpQDyJihT9TGnd1HHSMCrmWn1l9CZESCkn4T3xGRLz9F2F3CycDyoLlOEGyu
xnt4hbmMRAesKS48kIZAbGO/HkvjLE4vcs4kN2kFgmI8emCjcwFQc2TertrBawej
OaK+qfKsSvR6B6NjjgLZB4bzg/us4Ithz8Se+C3bLav4tXyqvXRqqIrxka5OVJ7N
rMVAnFGbDLmiUTuiMng43m0UY827T6j3DnvGZHs97fJC6zUiF231bS9g0qYqt6tG
TxC6NeF+I6JQUAjqEdHV38PWRZdP+K7aRDuGo0WbbmfEhIrQgTA=
=GR10
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35461@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35461
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help