Toggle diff (489 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7d8e51b5af..7242ede3be 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -49,7 +49,7 @@
(define-module (gnu packages web)
#:use-module (ice-9 match)
- #:use-module ((guix licenses) #:prefix l:)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -158,7 +158,7 @@ freely-available source code implementation of an HTTP (Web) server. The
project is jointly managed by a group of volunteers located around the world,
using the Internet and the Web to communicate, plan, and develop the server
and its related documentation.")
- (license l:asl2.0)
+ (license license:asl2.0)
(home-page "https://httpd.apache.org/")))
(define-public mod-wsgi
@@ -189,7 +189,7 @@ and its related documentation.")
"The mod_wsgi module for the Apache HTTPD Server adds support for running
applications that support the Python @acronym{WSGI, Web Server Gateway
Interface} specification.")
- (license l:asl2.0)
+ (license license:asl2.0)
(home-page "https://modwsgi.readthedocs.io/")))
(define-public nginx
@@ -285,7 +285,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
;; * The 'nginx-http-push' module is covered by the expat license.
;; * The 'nginx-development-kit' module is mostly covered by bsd-3,
;; except for two source files which are bsd-4 licensed.
- (license (list l:bsd-2 l:expat l:bsd-3 l:bsd-4))))
+ (license (list license:bsd-2 license:expat license:bsd-3 license:bsd-4))))
(define nginx-xslscript
(let ((revision 11)
@@ -327,7 +327,7 @@ and as a proxy to reduce the load on back-end HTTP or mail servers.")
"XSLScript is a terse notation for writing complex XSLT stylesheets.
This is modified version, specifically intended for use with the NGinx
documentation.")
- (license l:bsd-2))))
+ (license license:bsd-2))))
(define-public nginx-documentation
;; This documentation should be relevant for nginx@1.15.9.
@@ -380,7 +380,7 @@ documentation.")
(synopsis "Documentation for the nginx web server")
(description
"This package provides HTML documentation for the nginx web server.")
- (license l:bsd-2))))
+ (license license:bsd-2))))
(define-public fcgi
(package
@@ -408,7 +408,7 @@ that provides high performance without the limitations of server specific
APIs.")
;; This package is released under the Open Market License, a variant of
;; the Expat license, incompatible with the GPL.
- (license (l:non-copyleft "file://LICENSE.TERMS"))))
+ (license (license:non-copyleft "file://LICENSE.TERMS"))))
(define-public fcgiwrap
(package
@@ -438,7 +438,7 @@ APIs.")
(description "Fcgiwrap is a simple server for running CGI applications
over FastCGI. It hopes to provide clean CGI support to Nginx (and other web
servers that may need it).")
- (license l:expat)))
+ (license license:expat)))
(define-public starman
(package
@@ -470,7 +470,7 @@ servers that may need it).")
(description "Starman is a PSGI perl web server that has unique features
such as high performance, preforking, signal support, superdaemon awareness,
and UNIX socket support.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public icedtea-web
(package
@@ -506,7 +506,7 @@ Protocol}, also known as Java Web Start. This package provides tools and
libraries for working with JNLP applets.")
;; The program is mainly GPL2+, with some individual files under LGPL2.1+
;; or dual licenses.
- (license l:gpl2+)))
+ (license license:gpl2+)))
(define-public jansson
(package
@@ -528,7 +528,7 @@ libraries for working with JNLP applets.")
(description
"Jansson is a C library for encoding, decoding and manipulating JSON
data.")
- (license l:expat)))
+ (license license:expat)))
(define-public json-c
(package
@@ -559,7 +559,7 @@ data.")
easily construct JSON objects in C, output them as JSON-formatted strings and
parse JSON-formatted strings back into the C representation of JSON objects.
It aims to conform to RFC 7159.")
- (license l:x11)))
+ (license license:x11)))
;; TODO: remove this old version when all dependents have been updated.
(define-public json-c-0.12
@@ -616,7 +616,7 @@ project)
@item Never recurses or allocates more memory than it needs
@item Very simple API with operator sugar for C++
@end itemize")
- (license l:bsd-2)))
+ (license license:bsd-2)))
(define-public qjson
(package
@@ -656,7 +656,7 @@ project)
@code{QVariant} objects. JSON arrays will be mapped to @code{QVariantList}
instances, while JSON's objects will be mapped to @code{QVariantMap}.")
;; Only version 2.1 of the license
- (license l:lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public krona-tools
(package
@@ -743,7 +743,7 @@ hierarchical data, such as metagenomic classifications, using a radial,
space-filling display. It is implemented using HTML5 and JavaScript, allowing
charts to be explored locally or served over the Internet, requiring only a
current version of any major web browser.")
- (license l:bsd-3)))
+ (license license:bsd-3)))
(define-public rapidjson
(package
@@ -783,7 +783,7 @@ current version of any major web browser.")
(description
"RapidJSON is a fast JSON parser/generator for C++ with both SAX/DOM
style API.")
- (license l:expat)))
+ (license license:expat)))
(define-public libyajl
(package
@@ -812,7 +812,7 @@ style API.")
(description
"Yet Another JSON Library (YAJL) is a small event-driven (SAX-style) JSON
parser written in ANSI C and a small validating JSON generator.")
- (license l:isc)))
+ (license license:isc)))
(define-public libwebsockets
(package
@@ -848,7 +848,7 @@ for efficient socket-like bidirectional reliable communication channels.")
(home-page "http://libwebsockets.org/")
;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
- (license l:lgpl2.1)))
+ (license license:lgpl2.1)))
(define-public libpsl
(package
@@ -886,7 +886,7 @@ domain verification, finds the longest public part of a given domain, finds
the shortest private part of a given domain, works with international
domains (UTF-8 and IDNA2008 Punycode), is thread-safe, and handles IDNA2008
UTS#46.")
- (license l:x11)))
+ (license license:x11)))
(define-public tidy
(package
@@ -922,7 +922,7 @@ UTS#46.")
(description "HTML Tidy is a command-line tool and C library that can be
used to validate and fix HTML data.")
(home-page "http://tidy.sourceforge.net/")
- (license (l:x11-style "file:///include/tidy.h"))))
+ (license (license:x11-style "file:///include/tidy.h"))))
(define-public tinyproxy
(package
@@ -957,7 +957,7 @@ daemon. Designed from the ground up to be fast and yet small, it is an ideal
solution for use cases such as embedded deployments where a full featured HTTP
proxy is required, but the system resources for a larger proxy are
unavailable.")
- (license l:gpl2+)))
+ (license license:gpl2+)))
(define-public polipo
(package
@@ -990,7 +990,7 @@ unavailable.")
"Polipo is a small caching web proxy (web cache, HTTP proxy, and proxy
server). It was primarily designed to be used by one person or a small group
of people.")
- (license l:expat)))
+ (license license:expat)))
(define-public websockify
(package
@@ -1020,7 +1020,7 @@ of people.")
traffic. Websockify accepts the WebSockets handshake, parses it, and then
begins forwarding traffic between the client and the target in both
directions.")
- (license l:lgpl3)))
+ (license license:lgpl3)))
(define-public wwwoffle
(package
@@ -1048,7 +1048,7 @@ intermittent internet links. It can cache HTTP, HTTPS, FTP, and finger
protocols, and supports browsing and requesting pages while offline, indexing,
modifying pages and incoming and outgoing headers, monitoring pages for
changes, and much more.")
- (license l:gpl2+)))
+ (license license:gpl2+)))
(define-public liboauth
(package
@@ -1076,7 +1076,7 @@ specifications and offers high-level functionality built on top to sign
requests or verify signatures using either NSS or OpenSSL for calculating the
hash/signatures.")
;; Source code may be distributed under either license.
- (license (list l:expat l:gpl2+))))
+ (license (list license:expat license:gpl2+))))
(define-public libyaml
(package
@@ -1096,7 +1096,7 @@ hash/signatures.")
(synopsis "YAML 1.1 parser and emitter written in C")
(description
"LibYAML is a YAML 1.1 parser and emitter written in C.")
- (license l:expat)))
+ (license license:expat)))
(define-public libquvi-scripts
(package
@@ -1115,7 +1115,7 @@ hash/signatures.")
(synopsis "Media stream URL parser")
(description "This package contains support scripts called by libquvi to
parse media stream properties.")
- (license l:lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public libquvi
(package
@@ -1149,7 +1149,7 @@ parse media stream properties.")
(synopsis "Media stream URL parser")
(description "libquvi is a library with a C API for parsing media stream
URLs and extracting their actual media files.")
- (license l:lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public quvi
(package
@@ -1172,7 +1172,7 @@ URLs and extracting their actual media files.")
(synopsis "Media stream URL parser")
(description "quvi is a command-line-tool suite to extract media files
from streaming URLs. It is a command-line wrapper for the libquvi library.")
- (license l:lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public serf
(package
@@ -1250,7 +1250,7 @@ communication asynchronously. Memory copies and transformations are kept to a
minimum to provide high performance operation.")
;; Most of the code is covered by the Apache License, Version 2.0, but the
;; bundled CuTest framework uses a different non-copyleft license.
- (license (list l:asl2.0 (l:non-copyleft "file://test/CuTest-README.txt")))))
+ (license (list license:asl2.0 (license:non-copyleft "file://test/CuTest-README.txt")))))
(define-public libsass
(package
@@ -1284,7 +1284,7 @@ minimum to provide high performance operation.")
library designed for portability and efficiency. To actually compile SASS
stylesheets, you'll need to use another program that uses this library,
@var{sassc} for example.")
- (license l:expat)))
+ (license license:expat)))
(define-public sassc
(package
@@ -1333,7 +1333,7 @@ stylesheets, you'll need to use another program that uses this library,
(description "SassC is a compiler written in C for the CSS pre-processor
language known as SASS.")
(home-page "http://sass-lang.com/libsass")
- (license l:expat)))
+ (license license:expat)))
(define-public perl-apache-logformat-compiler
@@ -1361,7 +1361,7 @@ language known as SASS.")
(synopsis "Compile a log format string to perl-code")
(description "This module provides methods to compile a log format string
to perl-code, for faster generation of access_log lines.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-authen-sasl
(package
@@ -1389,7 +1389,7 @@ to perl-code, for faster generation of access_log lines.")
(home-page "https://metacpan.org/release/Authen-SASL")
(synopsis "SASL authentication framework")
(description "Authen::SASL provides an SASL authentication framework.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-action-renderview
(package
@@ -1416,7 +1416,7 @@ to perl-code, for faster generation of access_log lines.")
(synopsis "Sensible default Catalyst action")
(description "This Catalyst action implements a sensible default end
action, which will forward to the first available view.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-action-rest
(package
@@ -1452,7 +1452,7 @@ REST requests. It takes a normal Catalyst action, and changes the dispatch to
append an underscore and method name. First it will try dispatching to an
action with the generated name, and failing that it will try to dispatch to a
regular method.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-authentication-store-dbix-class
(package
@@ -1488,7 +1488,7 @@ regular method.")
(description "The Catalyst::Authentication::Store::DBIx::Class class
provides access to authentication information stored in a database via
DBIx::Class.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-component-instancepercontext
(package
@@ -1514,7 +1514,7 @@ DBIx::Class.")
(synopsis "Create only one instance of Moose component per context")
(description "Catalyst::Component::InstancePerContext returns a new
instance of a component on each request.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-devel
(package
@@ -1556,7 +1556,7 @@ to run them. Catalyst-Devel includes the Catalyst::Helper system, which
autogenerates scripts and tests; Module::Install::Catalyst, a Module::Install
extension for Catalyst; and requirements for a variety of development-related
modules.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-dispatchtype-regex
(package
@@ -1586,7 +1586,7 @@ core. It is recommend that you use Chained methods or other techniques
instead. As part of the refactoring, the dispatch priority of Regex vs Regexp
vs LocalRegex vs LocalRegexp may have changed. Priority is now influenced by
when the dispatch type is first seen in your application.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-model-dbic-schema
(package
@@ -1632,7 +1632,7 @@ when the dispatch type is first seen in your application.")
(synopsis "DBIx::Class::Schema Model Class")
(description "This is a Catalyst Model for DBIx::Class::Schema-based
Models.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-accesslog
(package
@@ -1657,7 +1657,7 @@ Models.")
(description "This Catalyst plugin enables you to create \"access logs\"
from within a Catalyst application instead of requiring a webserver to do it
for you. It will work even with Catalyst debug logging turned off.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-authentication
(package
@@ -1693,7 +1693,7 @@ for you. It will work even with Catalyst debug logging turned off.")
Catalyst apps. It is the basis for both authentication (checking the user is
who they claim to be), and authorization (allowing the user to do what the
system authorises them to do).")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-authorization-roles
(package
@@ -1723,7 +1723,7 @@ system authorises them to do).")
(synopsis "Role-based authorization for Catalyst")
(description "Catalyst::Plugin::Authorization::Roles provides role-based
authorization for Catalyst based on Catalyst::Plugin::Authentication.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-captcha
(package
@@ -1747,7 +1747,7 @@ authorization for Catalyst based on Catalyst::Plugin::Authentication.")
(synopsis "Captchas for Catalyst")
(description "This plugin creates and validates Captcha images for
Catalyst.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-configloader
(package
@@ -1776,7 +1776,7 @@ Catalyst.")
(description "This module will attempt to load find and load configuration
files of various types. Currently it supports YAML, JSON, XML, INI and Perl
formats.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-session
(package
@@ -1807,7 +1807,7 @@ formats.")
(synopsis "Catalyst generic session plugin")
(description "This plugin links the two pieces required for session
management in web applications together: the state, and the store.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-session-state-cookie
(package
@@ -1838,7 +1838,7 @@ management in web applications together: the state, and the store.")
ID needs to be stored on the client, and the session data needs to be stored
on the server. This plugin stores the session ID on the client using the
cookie mechanism.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-session-store-fastmmap
(package
@@ -1868,7 +1868,7 @@ cookie mechanism.")
(description "Catalyst::Plugin::Session::Store::FastMmap is a fast session
storage plugin for Catalyst that uses an mmap'ed file to act as a shared
memory interprocess cache. It is based on Cache::FastMmap.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-stacktrace
(package
@@ -1895,7 +1895,7 @@ memory interprocess cache. It is based on Cache::FastMmap.")
including a stack trace of your application up to the point where the error
occurred. Each stack frame is displayed along with the package name, line
number, file name, and code context surrounding the line number.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-plugin-static-simple
(package
@@ -1927,7 +1927,7 @@ looking at the file extension in the URL (such as .css or .png or .js). The
plugin uses the lightweight MIME::Types module to map file extensions to
IANA-registered MIME types, and will serve your static files with the correct
MIME type directly to the browser, without being processed through Catalyst.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-runtime
(package
@@ -1987,7 +1987,7 @@ MIME type directly to the browser, without being processed through Catalyst.")
It is designed to make it easy to manage the various tasks you need to do to
run an application on the web, either by doing them itself, or by letting you
\"plug in\" existing Perl modules that do what you need.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-traitfor-request-proxybase
(package
@@ -2019,7 +2019,7 @@ run an application on the web, either by doing them itself, or by letting you
flexibility in your application's deployment configurations when deployed
behind a proxy. Using this module, the request base ($c->req->base) is
replaced with the contents of the X-Request-Base header.")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public perl-catalyst-view-download
(package
@@ -2046,7 +2046,7 @@ replaced with the contents of the X-Request-Base header.")
(description "The purpose of this module is to provide a method for
downloading data into many supportable formats. For example, downloading a
table based report in a variety of formats (CSV, HTML, etc.).")
- (license l:perl-license)))
+ (license license:perl-license)))
(define-public p