[PATCH 1/2] gnu: rpm: Use python3 instead of python2.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Jonathan Brielmaier
Owner
unassigned
Submitted by
Jonathan Brielmaier
Severity
normal

Debbugs page

Jonathan Brielmaier wrote 6 years ago
(address . guix-patches@gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20190424100321.19312-1-jonathan.brielmaier@web.de
osc depends on python-rpm and requires python3 now.

* gnu/packages/package-management.scm (rpm)[inputs]: Use python instead
of python-2.
---
gnu/packages/package-management.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (13 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 6708a761eb..f3b592b9e9 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -518,7 +518,7 @@ symlinks to the files in a common directory such as /usr/local.")
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
- `(("python" ,python-2)
+ `(("python" ,python)
("xz" ,xz)
("bdb" ,bdb)
("popt" ,popt)
--
2.21.0
Jonathan Brielmaier wrote 6 years ago
[PATCH 2/2] gnu: osc: Update to 0.165.0.
(address . 35412@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
20190424102516.19876-1-jonathan.brielmaier@web.de
osc is now python3 compatible.

* gnu/packages/build-tools.scm (osc): Update to 0.165.0.
[arguments]: Module is now python3 only. "osc_hotshot.py" is gone.
[inputs]: Add rpm for python-rpm. Remove python2-urlgrabber. Change
m2crypto and pyurl to python3.
---
gnu/packages/build-tools.scm | 19 +++++++++----------
1 file changed, 9 insertions(+), 10 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index daf55d84df..a572a05a49 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
+;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages compression)
#:use-module (gnu packages lua)
+ #:use-module (gnu packages package-management)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-web)
@@ -240,7 +242,7 @@ other lower-level build files.")
(define-public osc
(package
(name "osc")
- (version "0.162.1")
+ (version "0.165.0")
(source
(origin
(method url-fetch)
@@ -248,12 +250,11 @@ other lower-level build files.")
"/archive/" version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0b4kpm96ns4smqyfjysbk2p78d36x44xprpna8zz85q1y5xn57aj"))))
+ (base32 "0w8z69fhjnlb7fm4fdvbi99kxndk63308f4mjzaljrcp4v9yr5am"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; Module is python2 only.
- #:phases
- (modify-phases %standard-phases
+ `(#:phases
+ (modify-phases %standard-phases
(add-after 'install 'fix-filename-and-remove-unused
(lambda* (#:key outputs #:allow-other-keys)
(let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
@@ -262,13 +263,11 @@ other lower-level build files.")
(rename-file
(string-append bin "osc-wrapper.py")
(string-append bin "osc"))
- ;; Remove unused and broken script.
- (delete-file (string-append bin "osc_hotshot.py"))
#t))))))
(inputs
- `(("python2-m2crypto" ,python2-m2crypto)
- ("python2-pycurl" ,python2-pycurl)
- ("python2-urlgrabber" ,python2-urlgrabber)))
+ `(("python-m2crypto" ,python-m2crypto)
+ ("python-pycurl" ,python-pycurl)
+ ("rpm" ,rpm))) ; for python-rpm
(home-page "https://github.com/openSUSE/osc")
(synopsis "Open Build Service command line tool")
(description "@command{osc} is a command line interface to the Open Build
--
2.21.0
Jonathan Brielmaier wrote 6 years ago
(address . 35412@debbugs.gnu.org)(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)
92f0395b-ba4a-bd51-c2e3-1844caa2f41a@web.de
ping
Arun Isaac wrote 6 years ago
Re: [bug#35412] [PATCH 1/2] gnu: rpm: Use python3 instead of python2.
(name . Jonathan Brielmaier)(address . jonathan.brielmaier@web.de)(address . 35412-done@debbugs.gnu.org)
cu7lfzd9y72.fsf@systemreboot.net
Thanks! I pushed your patches with a few modifications, of which the two
most notable are:

- I updated rpm to 4.14.2.1.
- GitHub autogenerated source tarballs are unstable (their hashes
change). So, I made osc use git-fetch instead of url-fetch.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAlzWi6EACgkQLiXui2GA
K7NHiAgAu90Ghkg7uqX3r24hz6j/n5SVJ8pjotbPfF9cCEDKIJUy4e4JoDGX97y9
4dePwcGu8Rlmx1ip9UcISjr+NiBTJk2lqHRx3Tq4i64vOIF8v9/8gxT7rVa401RW
5KEf6hx4M9brbGAkdlswaYYuHaCbc7vLiZbDGgogzY2lsLj4L+uu1YQvszcG0RcH
BdfTYAeId7Cn2klWNIh+6cdIPQLx9LWForcMbuBqctzqYoxOVJldMW+ui6m8C7wm
rMrGmZOf5zIxWsGJrawzjat1HkLX6TL+ZpRIktcgY89shv2r2UGWiGBxwzqBo0HB
cUzfCP1RUmUpJdOQiDNXgChEKvrAQw==
=jfKr
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35412@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35412
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help