Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
This improves the readability of the boot process, especially when using full
disk encryption where you're required to enter the passphrase at a particular
point.
* gnu/system.scm (<operating-system>)[kernel-arguments]: Change the default to
'("quiet").
* doc/guix.texi (operating-system Reference): Document this change.
---
doc/guix.texi | 2 +-
gnu/system.scm | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
Toggle diff (28 lines)
diff --git a/doc/guix.texi b/doc/guix.texi
index 8c7522f286..bfde085ac4 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -10453,7 +10453,7 @@ The package object of the operating system kernel to use@footnote{Currently
only the Linux-libre kernel is supported. In the future, it will be
possible to use the GNU@tie{}Hurd.}.
-@item @code{kernel-arguments} (default: @code{'()})
+@item @code{kernel-arguments} (default: @code{'("quiet")})
List of strings or gexps representing additional arguments to pass on
the command-line of the kernel---e.g., @code{("console=ttyS0")}.
diff --git a/gnu/system.scm b/gnu/system.scm
index 24243eb707..c4f5740df2 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -160,7 +160,7 @@
(kernel operating-system-kernel ; package
(default linux-libre))
(kernel-arguments operating-system-user-kernel-arguments
- (default '())) ; list of gexps/strings
+ (default '("quiet"))) ; list of gexps/strings
(bootloader operating-system-bootloader) ; <bootloader-configuration>
(label operating-system-label ; string
(thunked)
--
2.21.0