[PATCH] gnu: Add cloud-utils.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190420214841.26758-1-mail@cbaines.net
* gnu/packages/admin.scm (cloud-utils): New variable.
---
gnu/packages/admin.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 52 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 3a250eeaa8..84668b849f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -214,6 +214,58 @@ interface and is based on GNU Guile.")
(home-page "https://www.gnu.org/software/shepherd/")
(properties '((ftp-server . "alpha.gnu.org")))))
+(define-public cloud-utils
+ (package
+ (name "cloud-utils")
+ (version "0.31")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://launchpad.net/cloud-utils/trunk/"
+ version "/+download/cloud-utils-" version ".tar.gz"))
+ (sha256
+ (base32
+ "07fl3dlqwdzw4xx7mcxhpkks6dnmaxha80zgs9f6wmibgzni8z0r"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ (let ((out (assoc-ref %outputs "out")))
+ (list (string-append "BINDIR=" out "/bin")
+ (string-append "MANDIR=" out "/share/man/man1")
+ (string-append "DOCDIR=" out "/share/doc/getmail")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check))))
+ (inputs
+ `(("python" ,python)))
+ (home-page "https://launchpad.net/cloud-utils")
+ (synopsis "Set of utilities for cloud computing environments")
+ (description
+ "This package contains a set of utilities for cloud computing
+environments:
+
+@itemize @bullet
+@item @command{cloud-localds} Create a disk for cloud-init to utilize nocloud
+@item @command{cloud-publish-image} Wrapper for cloud image publishing
+@item @command{cloud-publish-tarball} Wrapper for publishing cloud tarballs
+@item @command{cloud-publish-ubuntu} Import a Ubuntu cloud image
+@item @command{ec2metadata} Query and display @acronym{EC2,Amazon Elastic
+ Compute Cloud} metadata
+@item @command{growpart} Grow a partition to fill the device
+@item @command{mount-image-callback} Mount a file and run a command
+@item @command{resize-part-image} Resize a partition image to a new size
+@item @command{ubuntu-cloudimg-query} Get the latest Ubuntu
+ @acronym{AMI,Amazon Machine Image}
+@item @command{ubuntu-ec2-run} Run a @acronym{EC2,Amazon Elastic Compute
+ Cloud} instance using Ubuntu
+@item @command{vcs-run} Obtain a repository, and run a command
+@item @command{write-mime-multipart} Handle multipart
+ @acronym{MIME,Multipurpose Internet Mail Extensions} messages
+@end itemize")
+ (license license:gpl3)))
+
(define-public daemontools
(package
(name "daemontools")
--
2.21.0
Christopher Baines wrote 6 years ago
(address . 35349-done@debbugs.gnu.org)
87tvegqzqb.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (5 lines)
> * gnu/packages/admin.scm (cloud-utils): New variable.
> ---
> gnu/packages/admin.scm | 52 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 52 insertions(+)

I've now pushed this, with some improvements, to master.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlzHaZxfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XefiA/9GiRjCoB1XHr/qWvfGGSPTuYTxgepoW5+fpr4BusG7whec3hM918k3/QZ
rtZ6Cv11hJcxC6Zm0EcSieV8wFWOiOorZOUJnSyZJSMAHPITXYpB4a0Rl3bMQR4Y
pHy/xS2ND8lpid7UeRJlNURtIRxKAhCBZ0v5B9u6fVdvj8VKk7RYsswW/yk6U56E
J8RBDbbfROWySme/nitl3GFmAYhkhGulqGuOht/enf3Cz0j8arexn3rtffnECAon
AP1BHPvjA8PY6LPPh0BOtTpUbI26Bfw1erci0Ix8gfi7vSV1ylWob5qizvKBqUpJ
QcmhcQ8NytUAlxKQma/8nyDW1E/SndH7BdHN8j+2C8ptbL6UqsgfJrwqHRl3BYTm
0ElAWaqLUfVJnjFu8cikhQ7SoMpp4rrMGZKX2GvmibkIOOTUFWDNEG+LodCcHd2e
62d4R+6nDjzRlHNw6klmVXstvWJCXwoBP2m/ZxOBZ+Rc1U6B09zfHg4EBBJ4HKvf
m7rmpjADBJvCs6NsUAhnxtmwWaV8VC3fwGBNdCKkH/aORXDXE64l+iVhAhaKDnhR
0eaVRcUSV/gHxBkAg/L2gG+2+nh6qH6U42GId7e1EeTmj/oKEtEKN6v92gjhunpY
Yx0YeqDy1BIHhpFHQ/GwaH87IzIUyz0I98p48CrS85bbXoPfbdI=
=phYe
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35349@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35349
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help