[PATCH 1/3] gnu: Add dumb.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190415135134.31839-1-kkebreau@posteo.net
* gnu/packages/music.scm (dumb): New variable.
---
gnu/packages/music.scm | 65 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 64 insertions(+), 1 deletion(-)

Toggle diff (99 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 10a23c919f..522bad2528 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
@@ -81,6 +81,7 @@
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages game-development)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gettext)
@@ -446,6 +447,34 @@ background while you work.")
(home-page "http://www.denemo.org")
(license license:gpl3+)))
+(define-public dumb
+ (package
+ (name "dumb")
+ (version "2.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kode54/dumb.git")
+ (commit version)))
+ (sha256
+ (base32 "1cnq6rb14d4yllr0yi32p9jmcig8avs3f43bvdjrx4r1mpawspi6"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:configure-flags
+ (list "-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_EXAMPLES=OFF")))
+ (home-page "https://github.com/kode54/dumb")
+ (synopsis "Module audio renderer library")
+ (description
+ "DUMB is a tracker library with support for IT, XM, S3M and MOD files. It
+targets maximum accuracy to the original formats, with low-pass resonant filters
+for the IT files, accurate timing and pitching, and three resampling quality
+settings (aliasing, linear interpolation and cubic interpolation).")
+ (license (license:fsf-free "file://LICENSE"))))
+
(define-public hydrogen
(package
(name "hydrogen")
@@ -1061,6 +1090,40 @@ be used alone or in concert with Non Mixer and Non Sequencer to form a
complete studio.")
(license license:gpl2+)))
+(define-public vcvrack
+ (package
+ (name "vcvrack")
+ (version "0.6.2b")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VCVRack/Rack.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mn33aiafvqvds4hf9hywsr6f6y8y25g9vnjksf3cavxvnszy47y"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure phase
+ (inputs
+ `(("curl" ,curl)
+ ("glew" ,glew)
+ ("jansson" ,jansson)
+ ("libzip" ,libzip)
+ ("rtmidi" ,rtmidi)
+ ("speexdsp" ,speexdsp)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://vcvrack.com/")
+ (synopsis "Virtual modular synthesizer")
+ (description
+ "VCV Rack is a virtual modular synthesizer.")
+ (license license:bsd-3)))
+
(define-public solfege
(package
(name "solfege")
--
2.21.0
Kei Kebreau wrote 6 years ago
[PATCH 2/3] gnu: Add dumb-allegro4.
(address . 35288@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190415135348.31901-1-kkebreau@posteo.net
* gnu/packages/music.scm (dumb-allegro4): New variable.
---
gnu/packages/music.scm | 11 +++++++++++
1 file changed, 11 insertions(+)

Toggle diff (24 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 522bad2528..e1bf2d2b15 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -475,6 +475,17 @@ for the IT files, accurate timing and pitching, and three resampling quality
settings (aliasing, linear interpolation and cubic interpolation).")
(license (license:fsf-free "file://LICENSE"))))
+(define-public dumb-allegro4
+ (package
+ (inherit dumb)
+ (name "dumb-allegro4")
+ (arguments
+ (substitute-keyword-arguments (package-arguments dumb)
+ ((#:configure-flags flags)
+ `(cons "-DBUILD_ALLEGRO4=ON" ,flags))))
+ (inputs
+ `(("allegro" ,allegro-4)))))
+
(define-public hydrogen
(package
(name "hydrogen")
--
2.21.0
Kei Kebreau wrote 6 years ago
[PATCH 3/3] gnu: Add alex4.
(address . 35288@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190415135348.31901-2-kkebreau@posteo.net
* gnu/packages/games.scm (alex4): New variable.
---
gnu/packages/games.scm | 50 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 50 insertions(+)

Toggle diff (63 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0b93409c76..ee8be07efe 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -237,6 +237,56 @@ enemy, ally, weapon and mission types. Features include simulated 4D texturing,
mouse and joystick control, and original music.")
(license license:gpl2)))
+(define-public alex4
+ (package
+ (name "alex4")
+ (version "1.2-alpha")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/carstene1ns/alex4/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0jj1g3v1a6lyfwp5g2ly0n9z65ryqck8jxvzr01kaqjj3lsfkrhg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list "-Csrc"
+ "CC=gcc"
+ "CFLAGS=-D_FILE_OFFSET_BITS=64"
+ (string-append "DATADIR=" (assoc-ref %outputs "out")
+ "/share/" ,name)
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (substitute* '("src/main.c"
+ "src/shooter.c")
+ (("fcos") "fixcos")
+ (("fmul") "fixmul")
+ (("fsin") "fixsin"))
+ #t))
+ (add-after 'install 'install-data
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((share (string-append (assoc-ref outputs "out")
+ "/share/" ,name)))
+ (install-file "alex4.ini" share)
+ #t))))))
+ (inputs
+ `(("allegro" ,allegro-4)
+ ("dumb" ,dumb-allegro4)))
+ (home-page "http://allegator.sourceforge.net/")
+ (synopsis "Retro platform game")
+ (description
+ "Guide Alex the Allegator through the jungle in order to save his
+girlfriend Lola from evil humans who want to make a pair of shoes out of her.
+Plenty of classic platforming in four nice colors guaranteed!
+
+The game includes a built-in editor so you can design and share your own maps.")
+ (license license:gpl2+)))
+
(define-public armagetron-advanced
(package
(name "armagetron-advanced")
--
2.21.0
Ludovic Courtès wrote 6 years ago
Re: [bug#35288] [PATCH 1/3] gnu: Add dumb.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 35288@debbugs.gnu.org)
87bm13qq1t.fsf@gnu.org
Hello,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/music.scm (dumb): New variable.

[...]

Toggle quote (9 lines)
> + (synopsis "Module audio renderer library")
> + (description
> + "DUMB is a tracker library with support for IT, XM, S3M and MOD files. It
> +targets maximum accuracy to the original formats, with low-pass resonant filters
> +for the IT files, accurate timing and pitching, and three resampling quality
> +settings (aliasing, linear interpolation and cubic interpolation).")
> + (license (license:fsf-free "file://LICENSE"))))

This looks good, but the license deserves close reading (which I haven’t
done). What’s your interpretation of it? It would be nice to put a
comment above to summarize our findings.

Toggle quote (5 lines)
> +(define-public vcvrack
> + (package
> + (name "vcvrack")
> + (version "0.6.2b")

What’s this doin’ here? :-)

Thanks,
Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35288@debbugs.gnu.org)
87imv8jtv1.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (24 lines)
> Hello,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/music.scm (dumb): New variable.
>
> [...]
>
>> + (home-page "https://github.com/kode54/dumb")
>> + (synopsis "Module audio renderer library")
>> + (description
>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>> files. It
>> +targets maximum accuracy to the original formats, with low-pass
>> resonant filters
>> +for the IT files, accurate timing and pitching, and three resampling quality
>> +settings (aliasing, linear interpolation and cubic interpolation).")
>> + (license (license:fsf-free "file://LICENSE"))))
>
> This looks good, but the license deserves close reading (which I haven’t
> done). What’s your interpretation of it? It would be nice to put a
> comment above to summarize our findings.
>

I've added the comment below in the patch summarizing my interpretation
of the DUMB license:

;; The DUMB license is a bit peculiar.
;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
;; the first three clauses for genuine consideration.
;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
;; license, a known free software license.
;; Therefore, the DUMB license may be considered a free software license.

What do you think?

Toggle quote (8 lines)
>> +(define-public vcvrack
>> + (package
>> + (name "vcvrack")
>> + (version "0.6.2b")
>
> What’s this doin’ here? :-)
>

Very basic packaging work on some other software, whoops!

Toggle quote (2 lines)
> Thanks,
> Ludo’.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAly7gxIACgkQ5qXuPBlG
eg3dxBAAjoCZ8VDWXouZubTnZh3ijufQDuCnXdZcymEjQsqfYgxr9PPduBqxvI5O
7ZneH26Wr88h8ayVp7TR/z/ReedXDzrLakqtZ9545TFf4M5O2pXj5fck9D/cM2Yr
gR83xZVq7i6wTU3Hbs7eHJbqjagvZkxRykGOxxJm62UcHjreq9Bo5qBHBKefsIgD
wDw0VGraGXg0rzY48Hnsc/lDjqbHVSVET0MwMnE/6nMzLWpSL9hJ4j5Wb5xiAwvz
FWiaiAsESHkiSq2zu0p+TAiARhzzmgwpO2Mz4eNRuI1G9LowsEo0IneSEEfFbN7E
BS/TMXfi+fPxeLFaQ9TFrdG8DdK0n3uTZEF5ff5ecftsxidfXkAnPNV+TPgqvmCj
M4mJUhY+z9KrIRC350XzrZbLbKM7ul3WwBhwQ8ROxjKnIIoHKcWR77MePaSC9uMI
iZH6RMoAHbE/ppqz/zlOB+J4w+k6jkq6K8Wk/NXDJ9rUPOP3eBl2WFiblEjAHh4E
5TUtc03wH7Zm9r2G5cK0fJSzXX42YfyUGEt4gwql12zOF/uz6CZ2UY+IeKpvOtvi
Bi/CrGzXTkAsu59TOENE8BmGMS1FX2wukb9cfrNuqWFwOM4vhIS0BKr/2L79KYL0
/mYb8dyLNMYhAHULT21p5ZZ1NvlxWht+eKGOesTRCD4FRtSCZZ0=
=cuq7
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 35288@debbugs.gnu.org)
87d0lf8qw2.fsf@gnu.org
Hello Kei,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (38 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hello,
>>
>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>
>>> * gnu/packages/music.scm (dumb): New variable.
>>
>> [...]
>>
>>> + (home-page "https://github.com/kode54/dumb")
>>> + (synopsis "Module audio renderer library")
>>> + (description
>>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>>> files. It
>>> +targets maximum accuracy to the original formats, with low-pass
>>> resonant filters
>>> +for the IT files, accurate timing and pitching, and three resampling quality
>>> +settings (aliasing, linear interpolation and cubic interpolation).")
>>> + (license (license:fsf-free "file://LICENSE"))))
>>
>> This looks good, but the license deserves close reading (which I haven’t
>> done). What’s your interpretation of it? It would be nice to put a
>> comment above to summarize our findings.
>>
>
> I've added the comment below in the patch summarizing my interpretation
> of the DUMB license:
>
> ;; The DUMB license is a bit peculiar.
> ;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
> ;; the first three clauses for genuine consideration.
> ;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
> ;; license, a known free software license.
> ;; Therefore, the DUMB license may be considered a free software license.
>
> What do you think?

Sounds good! (It’s available in Debian too, which is a good sign:

Toggle quote (10 lines)
>>> +(define-public vcvrack
>>> + (package
>>> + (name "vcvrack")
>>> + (version "0.6.2b")
>>
>> What’s this doin’ here? :-)
>>
>
> Very basic packaging work on some other software, whoops!

Heheh. :-)

OK with these changes!

Thank you,
Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35288-done@debbugs.gnu.org)
87a7gjjtyh.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (63 lines)
> Hello Kei,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Hello,
>>>
>>> Kei Kebreau <kkebreau@posteo.net> skribis:
>>>
>>>> * gnu/packages/music.scm (dumb): New variable.
>>>
>>> [...]
>>>
>>>> + (home-page "https://github.com/kode54/dumb")
>>>> + (synopsis "Module audio renderer library")
>>>> + (description
>>>> + "DUMB is a tracker library with support for IT, XM, S3M and MOD
>>>> files. It
>>>> +targets maximum accuracy to the original formats, with low-pass
>>>> resonant filters
>>>> +for the IT files, accurate timing and pitching, and three
>>>> resampling quality
>>>> +settings (aliasing, linear interpolation and cubic interpolation).")
>>>> + (license (license:fsf-free "file://LICENSE"))))
>>>
>>> This looks good, but the license deserves close reading (which I haven’t
>>> done). What’s your interpretation of it? It would be nice to put a
>>> comment above to summarize our findings.
>>>
>>
>> I've added the comment below in the patch summarizing my interpretation
>> of the DUMB license:
>>
>> ;; The DUMB license is a bit peculiar.
>> ;; Clause 8 states that clauses 4, 5 and 6 are null and void, leaving only
>> ;; the first three clauses for genuine consideration.
>> ;; Clauses 1, 2 and 3 are analogous to clauses 1, 2 and 3 of the zlib
>> ;; license, a known free software license.
>> ;; Therefore, the DUMB license may be considered a free software license.
>>
>> What do you think?
>
> Sounds good! (It’s available in Debian too, which is a good sign:
> <https://packages.debian.org/sid/libdumb1>.)
>
>>>> +(define-public vcvrack
>>>> + (package
>>>> + (name "vcvrack")
>>>> + (version "0.6.2b")
>>>
>>> What’s this doin’ here? :-)
>>>
>>
>> Very basic packaging work on some other software, whoops!
>
> Heheh. :-)
>
> OK with these changes!
>
> Thank you,
> Ludo’.

Pushed to master, thanks again!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAly8gpYACgkQ5qXuPBlG
eg2QihAAu156I2iNhkcOEKbL8RJWMxThZhM9X9gCr1Q4BagZJ98til24OaehuRmW
4OkbZ1jYWDG+ZNfC1kkjq7RWzH0l1rOZDzvsRJSxDHlH3Z4aZgYqwUXoZWn18qhK
p6vGeF3eImHFR7cMjSLdu+MrVSTQQ92L78iyrzmVBQvZRdRWB/OezCnY3hm4+Hwl
GN6dYvc1L4MvF/5MflVbhXP9vvXwh7RmmKskAZ3vIyNb1WibY8k31BmvoiwyKqQ6
y+WSH46TdPhTK5pWLYH9+opuTeXd1U3aikF+B7j37rHFkIbB8kXUld504JlyjbpP
hYxHR5hsYPZm8ZFWvzuQXPOtILFB3ZK3Pu5L02EQgGo9BmLlIBJ42e8ClkAymj2T
n7OqBB/QVRdwt9iojvSosljPWBnIcOT4j+d9F5wI862hqIHcM0etcZEG/bfbNY67
nxSx3aVxbC3+LNfMYGh6Q8PI2Y16NGQpneswq6PHh4tGcF0mVhVZ4kBAxvg0ePop
pvGeGGg8OIqHUeESHAFG/fMIzC0vXkvocSSyyvroVEkgjVJsFgaVNg0COTTpxQN1
5P4PErC9NMKatHwoRjPb//CIoAeop1jJabf17Zmp6XWXDnLDjVhtFNVHrPlWafSu
z19RHuHiKyMu0RVatz2C3gm0qggePWkBTf0EolwgOSbKbtm/ouQ=
=x7mk
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35288@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35288
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help