Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/music.scm (dumb): New variable.
---
gnu/packages/music.scm | 65 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 64 insertions(+), 1 deletion(-)
Toggle diff (99 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 10a23c919f..522bad2528 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 ng0 <ng0@n0.is>
@@ -81,6 +81,7 @@
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages game-development)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gettext)
@@ -446,6 +447,34 @@ background while you work.")
(home-page "http://www.denemo.org")
(license license:gpl3+)))
+(define-public dumb
+ (package
+ (name "dumb")
+ (version "2.0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kode54/dumb.git")
+ (commit version)))
+ (sha256
+ (base32 "1cnq6rb14d4yllr0yi32p9jmcig8avs3f43bvdjrx4r1mpawspi6"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no check target
+ #:configure-flags
+ (list "-DBUILD_SHARED_LIBS=ON"
+ "-DBUILD_EXAMPLES=OFF")))
+ (home-page "https://github.com/kode54/dumb")
+ (synopsis "Module audio renderer library")
+ (description
+ "DUMB is a tracker library with support for IT, XM, S3M and MOD files. It
+targets maximum accuracy to the original formats, with low-pass resonant filters
+for the IT files, accurate timing and pitching, and three resampling quality
+settings (aliasing, linear interpolation and cubic interpolation).")
+ (license (license:fsf-free "file://LICENSE"))))
+
(define-public hydrogen
(package
(name "hydrogen")
@@ -1061,6 +1090,40 @@ be used alone or in concert with Non Mixer and Non Sequencer to form a
complete studio.")
(license license:gpl2+)))
+(define-public vcvrack
+ (package
+ (name "vcvrack")
+ (version "0.6.2b")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/VCVRack/Rack.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0mn33aiafvqvds4hf9hywsr6f6y8y25g9vnjksf3cavxvnszy47y"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags '("CC=gcc")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure phase
+ (inputs
+ `(("curl" ,curl)
+ ("glew" ,glew)
+ ("jansson" ,jansson)
+ ("libzip" ,libzip)
+ ("rtmidi" ,rtmidi)
+ ("speexdsp" ,speexdsp)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://vcvrack.com/")
+ (synopsis "Virtual modular synthesizer")
+ (description
+ "VCV Rack is a virtual modular synthesizer.")
+ (license license:bsd-3)))
+
(define-public solfege
(package
(name "solfege")
--
2.21.0