Strange error with short drive uuids in config

  • Open
  • quality assurance status badge
Details
2 participants
  • rendaw
  • Bob Proulx
Owner
unassigned
Submitted by
rendaw
Severity
normal
R
R
rendaw wrote on 14 Apr 2019 10:59
(address . submit@debbugs.gnu.org)
e010cd7e-7d9c-4c32-0e0c-3e4ab897b52e@s.rendaw.me
I have a vfat filesystem:

```
mkfs.vfat -F32 mydiskp1
```

with the uuid "FA34-24CA" gotten via:

```
blkid mydiskp1
```

When I specify this in my config with (uuid "FA34-24CA") the system
fails to build:

```
Backtrace:
In ice-9/eval.scm:
619:8 19 (_ #(#(#<directory (guile-user) 1db7140>)))
In guix/ui.scm:
1603:12 18 (run-guix-command _ . _)
In ice-9/boot-9.scm:
829:9 17 (catch _ _ #<procedure 7facf5a5b498 at guix/ui.scm:615?> ?)
829:9 16 (catch _ _ #<procedure 7facf5a5b4b0 at guix/ui.scm:733?> ?)
In guix/scripts/system.scm:
1268:8 15 (_)
In guix/status.scm:
615:4 14 (call-with-status-report _ _)
In guix/scripts/system.scm:
1138:6 13 (process-action _ _ _)
In guix/store.scm:
1659:24 12 (run-with-store _ _ #:guile-for-build _ #:system _ # _)
In guix/scripts/system.scm:
1151:13 11 (_ _)
869:18 10 (perform-action init #<<operating-system> kernel: #<pa?> ?)
In gnu/system.scm:
841:19 9 (operating-system-derivation _ #:container? _)
In gnu/services.scm:
778:26 8 (loop #<<service> type: #<service-type system 2280fa0> ?>)
In srfi/srfi-1.scm:
592:29 7 (map1 (#<<service> type: #<service-type profile 2280?> ?))
592:17 6 (map1 (#<<service> type: #<service-type etc 2280dc0>?> ?))
In gnu/services.scm:
779:26 5 (loop #<<service> type: #<service-type etc 2280dc0> val?>)
In srfi/srfi-1.scm:
592:29 4 (map1 (#<<service> type: #<service-type session-envi?> ?))
592:17 3 (map1 (#<<service> type: #<service-type fstab 2280a0?> ?))
In gnu/services/base.scm:
332:40 2 (file-systems->fstab (#<<file-system> device: #f mou?> ?))
In srfi/srfi-1.scm:
592:17 1 (map1 (#<<file-system> device: #f mount-point: "/boo?> ?))
In gnu/services/base.scm:
307:17 0 (file-system->fstab-entry #<<file-system> device: #f mo?>)

gnu/services/base.scm:307:17: In procedure file-system->fstab-entry:
Throw to key `match-error' with args `("match" "no matching pattern" #f)'.
```

I was able to identify the issue by doing a binary search by removal
through my config and I worked around the issue by using a "UUID="
string instead of (uuid) for that filesystem's device.

I think there are two issues here:
1. The uuid isn't matching for some reason
2. The expected error message (about an invalid uuid) isn't being displayed
B
B
Bob Proulx wrote on 15 Apr 2019 01:49
(name . rendaw)(address . 7e9wc56emjakcm@s.rendaw.me)(address . 35269@debbugs.gnu.org)
20190414174534440344259@bob.proulx.com
Hello rendaw,

rendaw wrote:
Toggle quote (3 lines)
> When I specify this in my config with (uuid "FA34-24CA") the system
> fails to build:

You have filed this generically against "debbugs" but I assume you
wanted to file this against one of the projects using debbugs from
this list. Please look and let us know.


To what package should this ticket be reassigned to? I can't quite guess.

Thanks,
Bob
R
R
rendaw wrote on 15 Apr 2019 08:46
(address . 35269@debbugs.gnu.org)
f65a8e3f-6279-5bf0-20b4-76b05fd321f6@s.rendaw.me
Ah, this should be for guix, version 0.16.0.

On 4/15/19 8:49 AM, Bob Proulx wrote:
Toggle quote (15 lines)
> Hello rendaw,
>
> rendaw wrote:
>> When I specify this in my config with (uuid "FA34-24CA") the system
>> fails to build:
> You have filed this generically against "debbugs" but I assume you
> wanted to file this against one of the projects using debbugs from
> this list. Please look and let us know.
>
> https://debbugs.gnu.org/Packages.html
>
> To what package should this ticket be reassigned to? I can't quite guess.
>
> Thanks,
> Bob
B
B
Bob Proulx wrote on 15 Apr 2019 18:57
(name . rendaw)(address . 7e9wc56emjakcm@s.rendaw.me)(address . 35269@debbugs.gnu.org)
20190415105149284931665@bob.proulx.com
reassign 35269 guix
thanks

rendaw wrote:
Toggle quote (2 lines)
> Ah, this should be for guix, version 0.16.0.

Very good. Reassigning.


Bob
?