[PATCH] gnu: Add go-github-com-gokyle-twofactor.

  • Open
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Pkill -9
Owner
unassigned
Submitted by
Pkill -9
Severity
normal
P
P
Pkill -9 wrote on 13 Apr 2019 12:07
(address . guix-patches@gnu.org)(name . Pkill -9)(address . pkill9@runbox.com)
20190413100731.4720-1-pkill9@runbox.com
* gnu/packages/golang.scm (go-github-com-gokyle-twofactor): New variable.
---
This patch adds the first of four Golang packages required for building the browserpass binary (Used by the browserpass chromium extension to communicate with 'pass').


gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3..e1ae77d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3274,3 +3275,25 @@ test.
All locks are implemented with read-write mutexes. To use them like a regular
mutex, simply ignore the RLock/RUnlock functions.")
(license license:unlicense))))
+
+(define-public go-github-com-gokyle-twofactor
+ (package
+ (name "go-github-com-gokyle-twofactor")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokyle/twofactor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fhbw6cyq054w4frfvbgmffijg0bd1shvawm3ddl4cf1l12x1qxh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gokyle/twofactor"))
+ (home-page "https://github.com/gokyle/twofactor")
+ (synopsis "Two-factor authentication")
+ (description "Golang package for providing two-factor authentication.")
+ (license license:expat)))
--
2.21.0
L
L
Leo Famulari wrote on 13 Apr 2019 19:46
(name . Pkill -9)(address . pkill9@runbox.com)(address . 35255@debbugs.gnu.org)
20190413174641.GA20283@jasmine.lan
On Sat, Apr 13, 2019 at 11:07:31AM +0100, Pkill -9 wrote:
Toggle quote (2 lines)
> +(define-public go-github-com-gokyle-twofactor

Thank you!

Toggle quote (3 lines)
> + (synopsis "Two-factor authentication")
> + (description "Golang package for providing two-factor authentication.")

Can you make the description a complete sentence, and possibly adding
some more details about the package?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlyyIH4ACgkQJkb6MLrK
fwguhBAAw/trAOjmuZP1WN5zvAIjuYeVGXcd1me66WbHrSfcvxzcA3vgu5MXOnVd
XIxl4lZ9Pa5Udqr9YRPZP/tvl8rZC7k65QRI1Z48n/2kqd00AyB7xD/yQqTzCV3c
xSiydSTfVdcGRrnnhEUFMhpFSTiS5OaW8CHpk9/b7MBMGWl2jqszQdOpf7eIQPfz
mashyPHvdwXW7TurbSI9P5f9ieMyHSzJp7Ix5lRCfAec1AnlYBvkrDfzMQQz2wsb
UsdpVZok6Bs+lzdOcEY8ZNxsZqunqW+2ON7/8dH+xOCw4645tLi6pqlg5K282u6R
SYlIvpRcF8Tlo/4sYyNtCsv2SMjVAVeR9MiinqkfB8QCVKGCLi/iegMusmXv+qKv
TZ6+KQRTSmY0WCsHi6mGrtgy+m4/E9RJbgZ8wHFxRtsC1MfD2Ya7r9/5kKNJ95CU
DsGVulwtV7jhJOAQY12KSk/N7uoDJCgk9LL9O7SfPnDQAHVoYzWKMgQauccOayTk
rKH10i6K8qoqH0sxclvdwddpCte7C4IfdvErxt2I9KoAXwzNeL5nOqj4JLRaXIk+
Wa+CZsFJn9ibSzhP1qaVzVkQCd/aTX+ph0AAixlSCGkJT8DLr4HuLIX/CelPWGlM
QTZ8Je6UMUX4vj7Advaan5UYZuj+E2MpgPyI+F9dgpwAP/HnzEA=
=iKP7
-----END PGP SIGNATURE-----


?