Pkill -9 wrote 6 years ago
(address . guix-patches@gnu.org)(name . Pkill -9)(address . pkill9@runbox.com)
* gnu/packages/golang.scm (go-github-com-gokyle-twofactor): New variable.
---
This patch adds the first of four Golang packages required for building the browserpass binary (Used by the browserpass chromium extension to communicate with 'pass').
The license is declared MIT here: https://raw.githubusercontent.com/gokyle/twofactor/master/LICENSE
gnu/packages/golang.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 0b44bd3..e1ae77d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3274,3 +3275,25 @@ test.
All locks are implemented with read-write mutexes. To use them like a regular
mutex, simply ignore the RLock/RUnlock functions.")
(license license:unlicense))))
+
+(define-public go-github-com-gokyle-twofactor
+ (package
+ (name "go-github-com-gokyle-twofactor")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokyle/twofactor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fhbw6cyq054w4frfvbgmffijg0bd1shvawm3ddl4cf1l12x1qxh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gokyle/twofactor"))
+ (home-page "https://github.com/gokyle/twofactor")
+ (synopsis "Two-factor authentication")
+ (description "Golang package for providing two-factor authentication.")
+ (license license:expat)))
--
2.21.0