gnu: arm-trusted-firmware: Update to 2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87k1g2ia66.fsf@ponder
* gnu/packages/firmware (arm-trusted-firmware): Update to 2.1.
(arm-trusted-firmware-sun50i-a64)[source]: Inherit from
arm-trusted-firmware.
---
gnu/packages/firmware.scm | 23 ++++-------------------
1 file changed, 4 insertions(+), 19 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 0f3e1009ac..4df4b22843 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -377,7 +377,7 @@ Virtual Machines. OVMF contains a sample UEFI firmware for QEMU and KVM.")
(define* (make-arm-trusted-firmware platform #:optional (arch "aarch64"))
(package
(name (string-append "arm-trusted-firmware-" platform))
- (version "1.5")
+ (version "2.1")
(source
(origin
(method git-fetch)
@@ -388,7 +388,7 @@ Virtual Machines. OVMF contains a sample UEFI firmware for QEMU and KVM.")
(file-name (git-file-name "arm-trusted-firmware" version))
(sha256
(base32
- "1gm0bn2llzfzz9bfsz11fhwxj5lxvyrq7bc13fjj033nljzxn7k8"))))
+ "1gy5qskrjy8n3kxdcm1dx8b45l5b75n0pm8pq80wl6xic1ycy24r"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -448,25 +448,10 @@ such as:
license:bsd-2)))) ; libfdt
(define-public arm-trusted-firmware-sun50i-a64
- (let ((base (make-arm-trusted-firmware "sun50i_a64"))
- ;; Use unreleased version which enables additional features needed for
- ;; LCD support
- (commit "98aab97484b27e40aa74a93e5d1c1ac037a7e0b8")
- (revision "2"))
+ (let ((base (make-arm-trusted-firmware "sun50i_a64")))
(package
(inherit base)
- (name "arm-trusted-firmware-sun50i-a64")
- (version (git-version "2.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ARM-software/arm-trusted-firmware.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0z5si034vcn4m68zaixc5v8fs1c7vxbh7n4hggxs55p0jg01dan5")))))))
+ (name "arm-trusted-firmware-sun50i-a64"))))
(define-public arm-trusted-firmware-puma-rk3399
(let ((base (make-arm-trusted-firmware "rk3399"))
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXK2dAgAKCRDcUY/If5cW
qhDYAP9ug9wwAQOrAeD66PFolCMRM1TS0qS8/QmRzT8DBKgw8AD8DAJKXbJinXGg
XvcENyIl6p8fRAt9hLSRWJBFp3kX0QA=
=aRyK
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 35216-done@debbugs.gnu.org)
87lg0g22w2.fsf@gnu.org
Vagrant Cascadian <vagrant@debian.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/firmware (arm-trusted-firmware): Update to 2.1.
> (arm-trusted-firmware-sun50i-a64)[source]: Inherit from
> arm-trusted-firmware.

Applied, thanks!

Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35216@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35216
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help