[PATCH] gnu: Add git-lfs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190406143533.7979-1-kkebreau@posteo.net
* gnu/packages/version-control.scm (git-lfs): New variable.
---
gnu/packages/version-control.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 50284182c9..091bc988cf 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Jovany Leandro G.C <bit4bit@riseup.net>
+;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -47,6 +48,7 @@
#:use-module (guix git-download)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system go)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages apr)
@@ -2137,3 +2139,27 @@ design goals are to reduce the pain of resolving merge conflicts by finding
the smallest possible conflicts and to allow a merge to be saved, tested,
interrupted, published, and collaborated on while in progress.")
(license license:gpl2+)))
+
+(define-public git-lfs
+ (package
+ (name "git-lfs")
+ (version "2.7.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/git-lfs/git-lfs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "10v38w8qfz0x8750kv31n8gg2dimvq4wz40m374pd1xaypfs9670"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/git-lfs/git-lfs"))
+ (home-page "https://git-lfs.github.com/")
+ (synopsis "Git extension for versioning large files")
+ (description
+ "Git Large File Storage (LFS) replaces large files such as audio samples,
+videos, datasets, and graphics with text pointers inside Git, while storing the
+file contents on a remote server like GitHub.com or GitHub Enterprise.")
+ (license license:expat)))
--
2.21.0
Kei Kebreau wrote 6 years ago
(address . 35172@debbugs.gnu.org)
87o95jtc8p.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (23 lines)
> +(define-public git-lfs
> + (package
> + (name "git-lfs")
> + (version "2.7.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/git-lfs/git-lfs")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "10v38w8qfz0x8750kv31n8gg2dimvq4wz40m374pd1xaypfs9670"))))
> + (build-system go-build-system)
> + (arguments
> + '(#:import-path "github.com/git-lfs/git-lfs"))
> + (home-page "https://git-lfs.github.com/")
> + (synopsis "Git extension for versioning large files")
> + (description
> + "Git Large File Storage (LFS) replaces large files such as audio samples,
> +videos, datasets, and graphics with text pointers inside Git, while storing the
> +file contents on a remote server like GitHub.com or GitHub Enterprise.")

I realize that I can remove the GitHub promotion from the description
without any loss of understanding.

Toggle quote (2 lines)
> + (license license:expat)))

This is my first Go package, so any corrections or tips are especially
appreciated!
Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 35172@debbugs.gnu.org)
877ebrqpyq.fsf@gnu.org
Hello,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (28 lines)
> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> +(define-public git-lfs
>> + (package
>> + (name "git-lfs")
>> + (version "2.7.1")
>> + (source (origin
>> + (method git-fetch)
>> + (uri (git-reference
>> + (url "https://github.com/git-lfs/git-lfs")
>> + (commit (string-append "v" version))))
>> + (file-name (git-file-name name version))
>> + (sha256
>> + (base32
>> + "10v38w8qfz0x8750kv31n8gg2dimvq4wz40m374pd1xaypfs9670"))))
>> + (build-system go-build-system)
>> + (arguments
>> + '(#:import-path "github.com/git-lfs/git-lfs"))
>> + (home-page "https://git-lfs.github.com/")
>> + (synopsis "Git extension for versioning large files")
>> + (description
>> + "Git Large File Storage (LFS) replaces large files such as audio samples,
>> +videos, datasets, and graphics with text pointers inside Git, while storing the
>> +file contents on a remote server like GitHub.com or GitHub Enterprise.")
>
> I realize that I can remove the GitHub promotion from the description
> without any loss of understanding.

Agreed.

Toggle quote (5 lines)
>> + (license license:expat)))
>
> This is my first Go package, so any corrections or tips are especially
> appreciated!

I’m no nothing about Go, but it LGTM! If something is broken, don’t
worry, people will tell you. ;-)

Thank you,
Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 35172-done@debbugs.gnu.org)
87ef5wjtnr.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (45 lines)
> Hello,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> Kei Kebreau <kkebreau@posteo.net> writes:
>>
>>> +(define-public git-lfs
>>> + (package
>>> + (name "git-lfs")
>>> + (version "2.7.1")
>>> + (source (origin
>>> + (method git-fetch)
>>> + (uri (git-reference
>>> + (url "https://github.com/git-lfs/git-lfs")
>>> + (commit (string-append "v" version))))
>>> + (file-name (git-file-name name version))
>>> + (sha256
>>> + (base32
>>> + "10v38w8qfz0x8750kv31n8gg2dimvq4wz40m374pd1xaypfs9670"))))
>>> + (build-system go-build-system)
>>> + (arguments
>>> + '(#:import-path "github.com/git-lfs/git-lfs"))
>>> + (home-page "https://git-lfs.github.com/")
>>> + (synopsis "Git extension for versioning large files")
>>> + (description
>>> + "Git Large File Storage (LFS) replaces large files such as audio
>>> samples,
>>> +videos, datasets, and graphics with text pointers inside Git,
>>> while storing the
>>> +file contents on a remote server like GitHub.com or GitHub Enterprise.")
>>
>> I realize that I can remove the GitHub promotion from the description
>> without any loss of understanding.
>
> Agreed.
>
>>> + (license license:expat)))
>>
>> This is my first Go package, so any corrections or tips are especially
>> appreciated!
>
> I’m no nothing about Go, but it LGTM! If something is broken, don’t
> worry, people will tell you. ;-)
>

:-)

Toggle quote (3 lines)
> Thank you,
> Ludo’.

Pushed to master, thank you for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAly7hBgACgkQ5qXuPBlG
eg0IIw//fUl3+JicgXWloCm6pm4gNfrWFgBVtBFlIT7HKCIJYF//NnGTvWrq/3QN
I92XjZx8oRVtHRt8DKWRqZ1y/cDQf2a4HEvdtKdRioPFJFLYH8hRhyfONQUNNazM
R4trVjfDitsPmi2eRt3kbLcqg/MQ5evpHRDjJYCq5CuJba5Lrhv1IFPOr8VF/rZo
CahoD+oxJ/uC4HgBgj2l8c1qEvoWXNQTj1vaGrvqPMCGo5xNgg+NZwh75FtjFHzB
pSzYRpLrSTKzkWbaWObMp1XY+H/THapjsT9BT6b/H4ylxap+hR8RySuc6UCBEVpK
dwuVVJLRZBYn3vt+ATKIdByGVm9922SHEmTFqs0Kc/MaHmyfakm8Mw9r0bSJAQHo
IL86u9Bw6D6XBeJsnjHxgLOXd3iK85Nvny/WYr+OgRd8L/hweHeMAE5az/gizCps
AIeRLdLwIb/elxoVdabJgIRkDBXSEPe/F3lIL+zKz/dUxmOreq2L/AoS1A2krbeo
2F0pn1GBkKFFtRaMdsdaAoVZKhBBLnI0yINNXBidhynl/IGylj50cYKSwX8qBgrH
cm+oIn0+8XvQKD5o//ykash+HKTqpbQBI+iUqsHPiypm7UiPi/8YZiCNPp3rl9Ec
B/y2MKxQRjJ4OT+QvPFuIHyNMzcT0C8bo7p/2RAOjNw7XxVT5oM=
=V2BH
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 35172-done@debbugs.gnu.org)
878sw38qu2.fsf@gnu.org
Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> Ludovic Courtès <ludo@gnu.org> writes:

[...]

Toggle quote (1 lines)
>> I’m no nothing about Go, but it LGTM! If something is broken, don’t
^^^^^

Ouch, what have I written here?! Anyway, thanks for git-lfs!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35172@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35172
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help