[PATCH] gnu: make-linux-libre: Install "Module.symvers".

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20190403001349.11373-1-dannym@scratchpost.org
* gnu/packages/linux.scm (make-linux-libre): Install "Module.symvers".
---
gnu/packages/linux.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (13 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a2adb9b13d..bd7afccc52 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -392,7 +392,7 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(kmod (assoc-ref (or native-inputs inputs) "kmod")))
;; Install kernel image, kernel configuration and link map.
(for-each (lambda (file) (install-file file out))
- (find-files "." "^(\\.config|bzImage|zImage|Image|vmlinuz|System\\.map)$"))
+ (find-files "." "^(\\.config|bzImage|zImage|Image|vmlinuz|System\\.map|Module\\.symvers)$"))
;; Install device tree files
(unless (null? (find-files "." "\\.dtb$"))
(mkdir-p dtbdir)
Ludovic Courtès wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 35111@debbugs.gnu.org)
877ec03jd4.fsf@gnu.org
Danny Milosavljevic <dannym@scratchpost.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (make-linux-libre): Install "Module.symvers".

LGTM!
Danny Milosavljevic wrote 6 years ago
(no subject)
(address . control@debbugs.gnu.org)
20190411175517.596f3cd6@scratchpost.org
close 35111
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlyvY2UACgkQ5xo1VCww
uqUrowf/eLqyWuijC/No00HH//lA6b9NX8cND5AE70+CgmyuGgoUbGgCL6Cogw1u
CuXjnyrHJLwEAnlvKlbAyIo7y3OOxMkFQvL2YkvrHd01k69rF8O0goMdd5wgCuYN
9dz+Kzktbip3ccR/IljBHHNN1A5FIKTBEPlfuGpn8ltMpAf3+m7lQsZVHkhsMflD
/b1HGKhCbEKi566YNyecuQfQSagOaJCq9Kw+jxo4UMaMRaC16C8oA26a86tUOFqF
iaAY/2KH00DfNHUWrwYve7XlI2BAmMsixutzaTibDDIcJmQxQUXzaaNCFw1EF0KQ
hrItGW6ALlZ5fZ6J/X+Slg6c1glq3A==
=FK2q
-----END PGP SIGNATURE-----


?
Your comment

This issue is archived.

To comment on this conversation send an email to 35111@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35111
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help