[PATCH] gnu: Add emacs-ace-link.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • mikadoZero
Owner
unassigned
Submitted by
mikadoZero
Severity
normal

Debbugs page

mikadoZero wrote 6 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)
cucd0me5t0f.fsf@yandex.com
This is my first patch that adds a package to Guix. Feedback is
appreciated.

`guix lint emacs-ace-link` completes without warnings.

These build commands are successful:

`guix build --rounds=4 emacs-ace-link`
`guix build --system=armhf-linux --rounds=4 emacs-ace-link`
`guix build --system=aarch64-linux --rounds=4 emacs-ace-link`

These build commands were not successful for me:

`guix build --system=powerpc-linux --rounds=4 emacs-ace-link`
`guix build --system=mips64el-linux --rounds=4 emacs-ace-link`


-----------

From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
From: mikadoZero <mikadozero@yandex.com>
Date: Mon, 25 Mar 2019 19:39:09 -0400
Subject: [PATCH] gnu: Add emacs-ace-link.

* gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9969c7968c..f4c068db7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1090,6 +1091,34 @@ within a specified width. It is useful for displaying long track titles.")
;;; Miscellaneous.
;;;
+(define-public emacs-ace-link
+ (package
+ (name "emacs-ace-link")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/ace-link.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "147dz79vg4ym5wg3d544bw2khdb2j3hr73rw4qfm64wf0q2dj0vk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/abo-abo/ace-link")
+ (synopsis "Quickly follow links in Emacs")
+ (description
+ "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
+ @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
+ @file{goto-address-mode} buffer, you can tab through the links to select the
+ one you want. This is an O(N) operation, where the N is the amount of links.
+ This package turns this into an O(1) operation. It does so by assigning a
+ letter to each link using avy.")
+ (license license:gpl3+)))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")
--
2.21.0
Ludovic Courtès wrote 6 years ago
(name . mikadoZero)(address . mikadozero@yandex.com)(address . 34994-done@debbugs.gnu.org)
87sguhevad.fsf@gnu.org
mikadoZero <mikadozero@yandex.com> skribis:

Toggle quote (7 lines)
>>From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
> From: mikadoZero <mikadozero@yandex.com>
> Date: Mon, 25 Mar 2019 19:39:09 -0400
> Subject: [PATCH] gnu: Add emacs-ace-link.
>
> * gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.

Applied with the tiny changes below, thanks!

Ludo’.
Toggle diff (17 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1161630b52..7aec695205 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1161,9 +1161,9 @@ within a specified width. It is useful for displaying long track titles.")
(home-page "https://github.com/abo-abo/ace-link")
(synopsis "Quickly follow links in Emacs")
(description
- "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
- @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
- @file{goto-address-mode} buffer, you can tab through the links to select the
+ "Currently, to jump to a link in a @code{Info-mode}, @code{help-mode},
+@code{woman-mode}, @code{org-mode}, @code{eww-mode}, @code{compilation-mode},
+@code{goto-address-mode} buffer, you can tab through the links to select the
one you want. This is an O(N) operation, where the N is the amount of links.
This package turns this into an O(1) operation. It does so by assigning a
letter to each link using avy.")
Closed
mikadoZero wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 34994-done@debbugs.gnu.org)
cucd0lk2st4.fsf@yandex.com
Thank you

Ludovic Courtès writes:

Toggle quote (30 lines)
> mikadoZero <mikadozero@yandex.com> skribis:
>
>>>From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
>> From: mikadoZero <mikadozero@yandex.com>
>> Date: Mon, 25 Mar 2019 19:39:09 -0400
>> Subject: [PATCH] gnu: Add emacs-ace-link.
>>
>> * gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.
>
> Applied with the tiny changes below, thanks!
>
> Ludo’.
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 1161630b52..7aec695205 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -1161,9 +1161,9 @@ within a specified width. It is useful for displaying long track titles.")
> (home-page "https://github.com/abo-abo/ace-link")
> (synopsis "Quickly follow links in Emacs")
> (description
> - "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
> - @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
> - @file{goto-address-mode} buffer, you can tab through the links to select the
> + "Currently, to jump to a link in a @code{Info-mode}, @code{help-mode},
> +@code{woman-mode}, @code{org-mode}, @code{eww-mode}, @code{compilation-mode},
> +@code{goto-address-mode} buffer, you can tab through the links to select the
> one you want. This is an O(N) operation, where the N is the amount of links.
> This package turns this into an O(1) operation. It does so by assigning a
> letter to each link using avy.")
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34994@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34994
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help