mikadoZero wrote 6 years ago
(name . Guix-patches)(address . guix-patches@gnu.org)
This is my first patch that adds a package to Guix. Feedback is
appreciated.
`guix lint emacs-ace-link` completes without warnings.
These build commands are successful:
`guix build --rounds=4 emacs-ace-link`
`guix build --system=armhf-linux --rounds=4 emacs-ace-link`
`guix build --system=aarch64-linux --rounds=4 emacs-ace-link`
These build commands were not successful for me:
`guix build --system=powerpc-linux --rounds=4 emacs-ace-link`
`guix build --system=mips64el-linux --rounds=4 emacs-ace-link`
-----------
From 88fa9952ab4ce2e8b9d77ca55fd93c9e70936d02 Mon Sep 17 00:00:00 2001
From: mikadoZero <mikadozero@yandex.com>
Date: Mon, 25 Mar 2019 19:39:09 -0400
Subject: [PATCH] gnu: Add emacs-ace-link.
* gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable.
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9969c7968c..f4c068db7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1090,6 +1091,34 @@ within a specified width. It is useful for displaying long track titles.")
;;; Miscellaneous.
;;;
+(define-public emacs-ace-link
+ (package
+ (name "emacs-ace-link")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/ace-link.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "147dz79vg4ym5wg3d544bw2khdb2j3hr73rw4qfm64wf0q2dj0vk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/abo-abo/ace-link")
+ (synopsis "Quickly follow links in Emacs")
+ (description
+ "Currently, to jump to a link in a @file{Info-mode}, @file{help-mode},
+ @file{woman-mode}, @file{org-mode}, @file{eww-mode}, @file{compilation-mode},
+ @file{goto-address-mode} buffer, you can tab through the links to select the
+ one you want. This is an O(N) operation, where the N is the amount of links.
+ This package turns this into an O(1) operation. It does so by assigning a
+ letter to each link using avy.")
+ (license license:gpl3+)))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")
--
2.21.0