[PATCH] gnu: Add brightnessctl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal

Debbugs page

Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
87ef6vhim8.fsf@ponder
* gnu/packages/linux.scm (brightnessctl): New variable.
---
gnu/packages/linux.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d52e12f9cd..8e07d6a67e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4304,6 +4304,43 @@ set the screen to be pitch black at a vaĺue of 0 (or higher).
Light is the successor of lightscript.")
(license license:gpl3+)))
+(define-public brightnessctl
+ (let ((commit "6a791e7694aeeb5d027f71c6098e5182cf03371c"))
+ (package
+ (name "brightnessctl")
+ (version (git-version "0.4" "0" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hummer12007/brightnessctl/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1n1gb8ldgqv3vs565yhk1w4jfvrviczp94r8wqlkv5q6ab43c8w9"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX=" %output)
+ (string-append "UDEVDIR=" %output "/lib/udev/rules.d/"))
+ #:phases (modify-phases %standard-phases (delete 'configure)
+ (add-after 'unpack 'adjust-udev-rules
+ (lambda _
+ (substitute* "90-brightnessctl.rules"
+ (("/bin/") "/run/current-system/profile/bin/"))
+ #t)))))
+ (home-page "https://github.com/Hummer12007/brightnessctl")
+ (synopsis "Backlight and LED brightness control")
+ (description
+ "This program allows you read and control device brightness. Devices
+include backlight and LEDs. It can also preserve current brightness before
+applying the operation, such as on lid close.
+
+The appropriate permissions must be set on the backlight or LED control
+interface in sysfs, which can be accomplished with the included udev rules.")
+ (license license:expat))))
+
(define-public tlp
(package
(name "tlp")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXJgogAAKCRDcUY/If5cW
qi0ZAQC5aRzOAGTBnVDuaz/CZ8Yp59UC1HxQmtrPbdrmvfJLVQD8CrLMX725k2Ym
yxhu5kZv3NplAOe5PFyxsOY4BiyqWgY=
=7A6E
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 6 years ago
(name . Vagrant Cascadian)(address . vagrant@debian.org)(address . 34985-done@debbugs.gnu.org)
87k1gn58yl.fsf@elephly.net
Vagrant Cascadian <vagrant@debian.org> writes:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (brightnessctl): New variable.

Thanks. Pushed to the master branch with commit ab7f1eb97a.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34985@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34985
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help