[PATCH 00/17] Add sqitch, a database change management tool, and dependencies

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
875zs8c8xg.fsf@cbaines.net
Christopher Baines (17):
gnu: Add perl-http-tinyish.
gnu: Add perl-config-gitlike.
gnu: Add perl-cpan-distnameinfo.
gnu: Add perl-tie-handle-offset.
gnu: Add perl-io-pager.
gnu: Add perl-string-formatter.
gnu: Add perl-template-tiny.
gnu: Add perl-uri-nested.
gnu: Add perl-uri-db.
gnu: Add perl-test-checkdeps.
gnu: Add perl-test-dir.
gnu: Add perl-test-file.
gnu: Add perl-test-file-contents.
gnu: Add perl-test-version.
gnu: Add perl-mysql-config.
gnu: Add perl-string-shellquote.
gnu: Add sqitch.

gnu/packages/databases.scm | 110 ++++++++++++++++++++++
gnu/packages/perl-check.scm | 126 +++++++++++++++++++++++++
gnu/packages/perl-web.scm | 57 +++++++++++-
gnu/packages/perl.scm | 181 ++++++++++++++++++++++++++++++++++++
gnu/packages/web.scm | 27 ++++++
5 files changed, 500 insertions(+), 1 deletion(-)

--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlyX6MtfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdpCw/+IV0/oM6K0d4LQNz3eSb08rLlD3yQ01/ioN4tvYtugP/0PW+q8XgPQ2Dg
uZ+/7yGnQzGuxeTZlZiDBoPr7L5FRxR/8LYbKSvo/RHdblJUFn4uj1Kx6S8bPadM
b+jYt3XvPoMHSr+GPXxYEaFIgfysWYYoE7m9lMBwl5nh7ISyb8oScRhzFyUhKwZ8
9gzXR1ZX6l0TZHqlFnWQ9+8nPWE8rqb6618P8eCHpsrcATK/y4Jhcpe4ofBf6dCv
dUJHZtNx1b8+SKt0bb3URia9+WD5iIQVtxhy9nszQtTHt7k8VE6/Js5yHdSTY27y
V3awJN/mrERb1xHsHpVHUJuyjYKVZZiYpglAv8WSDDilyQTYqeFKrfVtSZOTFGA3
KwWJfN91bBBjD+8GUMGm6to4lTAOfEa76Nn3yGr+ELQEtOKeXbRafZUxFomg049v
PRJTyScRprDuHkw9ihruplfGTaaBzW97A94d0YocbcuH5qtAiT4/FFwsd1/8VCak
B5jGtryvx/PWDbUalMGpPl2bdsqovF22fJKq0OpIJaefcTnXjNxNIAEQMBd2MifP
fkJj1lpsU182/jnakvlKO4xH4ncbafrYV/EEIhoO6cKIvpzQ1iAtH/w2mV+Ot+EB
yoi5m4INxzYQxXCkMf6hQGXqCNlUyecbW3gPh8Do8gb5zGSo0NM=
=4rWS
-----END PGP SIGNATURE-----

Christopher Baines wrote 6 years ago
[PATCH 02/17] gnu: Add perl-config-gitlike.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-2-mail@cbaines.net
* gnu/packages/perl.scm (perl-config-gitlike): New variable.
---
gnu/packages/perl.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8c28c94ed9..187e419b6a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1435,6 +1435,33 @@ some enhancements such as here-documents, C-style comments, and multiline
options.")
(license (package-license perl))))
+(define-public perl-config-gitlike
+ (package
+ (name "perl-config-gitlike")
+ (version "1.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AL/ALEXMV/Config-GitLike-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0kp57na9mk6yni693h2fwap6l1ndbcj97l4860r9vkzx2jw0fjk7"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (propagated-inputs
+ `(("perl-moo" ,perl-moo)
+ ("perl-moox-types-mooselike" ,perl-moox-types-mooselike)))
+ (home-page "https://metacpan.org/release/Config-GitLike")
+ (synopsis "Parse Git style configuration files")
+ (description
+ "This module handles parsing, modifying and creating configuration files
+of the style used by the Git version control system.")
+ (license perl-license)))
+
(define-public perl-config-ini
(package
(name "perl-config-ini")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 03/17] gnu: Add perl-cpan-distnameinfo.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-3-mail@cbaines.net
* gnu/packages/perl.scm (perl-cpan-distnameinfo): New variable.
---
gnu/packages/perl.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 187e419b6a..8e9c4d1d3a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1557,6 +1557,28 @@ data.")
@file{Changes} files that conform to a common specification.")
(license perl-license)))
+(define-public perl-cpan-distnameinfo
+ (package
+ (name "perl-cpan-distnameinfo")
+ (version "0.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GB/GBARR/CPAN-DistnameInfo-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0d94kx596w7k328cvq4y96z1gz12hdhn3z1mklkbrb7fyzlzn91g"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/CPAN-DistnameInfo")
+ (synopsis "Extract the name and version from a distribution filename")
+ (description
+ "@code{CPAN::DistnameInfo} uses heuristics to extract the distribution
+name and version from filenames.")
+ (license perl-license)))
+
(define-public perl-cpan-meta-check
(package
(name "perl-cpan-meta-check")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 04/17] gnu: Add perl-tie-handle-offset.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-4-mail@cbaines.net
* gnu/packages/perl.scm (perl-tie-handle-offset): New variable.
---
gnu/packages/perl.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8e9c4d1d3a..ddb7576e7d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8587,6 +8587,28 @@ can also be set to any arbitrary supplied order. The familiar perl array
operations can also be performed on the IxHash.")
(license (package-license perl))))
+(define-public perl-tie-handle-offset
+ (package
+ (name "perl-tie-handle-offset")
+ (version "0.004")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/Tie-Handle-Offset-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "17m8s8314wi4g0wasdxk15rf12vzsgzmcbr598jam5f6bl2kk7zf"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Tie-Handle-Offset")
+ (synopsis "Special file handle that hides the beginning of a file")
+ (description
+ "This modules provides a file handle that hides the beginning of a file,
+by modifying the @code{seek()} and @code{tell()} calls.")
+ (license asl2.0)))
+
(define-public perl-tie-toobject
(package
(name "perl-tie-toobject")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 07/17] gnu: Add perl-template-tiny.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-7-mail@cbaines.net
* gnu/packages/perl.scm (perl-template-tiny): New variable.
---
gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 2856b4634d..78bbf73420 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8082,6 +8082,32 @@ documents: HTML, XML, POD, PostScript, LaTeX, and so on.")
processing in Perl code.")
(license (list gpl3 artistic2.0))))
+(define-public perl-template-tiny
+ (package
+ (name "perl-template-tiny")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/A/AD/ADAMK/Template-Tiny-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0jhadxbc8rzbk2v8qvjrbhnvfp0m56iqar6d4nvxyl8bccn0cgh7"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/Template-Tiny")
+ (synopsis "Template Toolkit reimplemented in as little code as possible")
+ (description
+ "@code{Template::Tiny} is a reimplementation of a subset of the
+functionality from Template Toolkit in as few lines of code as possible.
+
+It is intended for use in light-usage, low-memory, or low-cpu templating
+situations, where you may need to upgrade to the full feature set in the
+future, or if you want the retain the familiarity of TT-style templates.")
+ (license perl-license)))
+
(define-public perl-term-encoding
(package
(name "perl-term-encoding")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 01/17] gnu: Add perl-http-tinyish.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-1-mail@cbaines.net
* gnu/packages/web.scm (perl-http-tinyish): New variable.
---
gnu/packages/web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f6701dca30..0cdf287ae6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3009,6 +3009,33 @@ simple requests without the overhead of a large framework like LWP::UserAgent.
It supports proxies and redirection. It also correctly resumes after EINTR.")
(license l:perl-license)))
+(define-public perl-http-tinyish
+ (package
+ (name "perl-http-tinyish")
+ (version "0.15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MI/MIYAGAWA/HTTP-Tinyish-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "199sa722amvwhq0czjfb7psj3hbqmvni5vxkrm579r5943pg0rax"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-file-which" ,perl-file-which)
+ ("perl-ipc-run3" ,perl-ipc-run3)))
+ (home-page "https://metacpan.org/release/HTTP-Tinyish")
+ (synopsis "@code{HTTP::Tiny} compatible HTTP client wrappers")
+ (description
+ "@code{HTTP::Tinyish} is a wrapper module for @acronym{LWP,libwww-perl},
+@code{HTTP::Tiny}, curl and wget.
+
+It provides an API compatible to HTTP::Tiny.")
+ (license l:perl-license)))
+
(define-public perl-io-html
(package
(name "perl-io-html")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 06/17] gnu: Add perl-string-formatter.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-6-mail@cbaines.net
* gnu/packages/perl.scm (perl-string-formatter): New variable.
---
gnu/packages/perl.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 094ef7269c..2856b4634d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7624,6 +7624,32 @@ expanding standard C/Unix-style backslash escapes like \n and \t, wrapping and
removing double-quotes, and truncating to fit within a desired length.")
(license (package-license perl))))
+(define-public perl-string-formatter
+ (package
+ (name "perl-string-formatter")
+ (version "0.102084")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RJ/RJBS/String-Formatter-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0mlwm0rirv46gj4h072q8gdync5zxxsxy8p028gdyrhczl942dc3"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-params-util" ,perl-params-util)
+ ("perl-sub-exporter" ,perl-sub-exporter)))
+ (home-page "https://metacpan.org/release/String-Formatter")
+ (synopsis "Build your own sprintf-like functions")
+ (description
+ "@code{String::Formatter} is a tool for building sprintf-like formatting
+routines. It supports named or positional formatting, custom conversions,
+fixed string interpolation, and simple width-matching.")
+ (license gpl2)))
+
(define-public perl-string-rewriteprefix
(package
(name "perl-string-rewriteprefix")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 05/17] gnu: Add perl-io-pager.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-5-mail@cbaines.net
* gnu/packages/perl.scm (perl-io-pager): New variable.
---
gnu/packages/perl.scm | 36 ++++++++++++++++++++++++++++++++++++
1 file changed, 36 insertions(+)

Toggle diff (56 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ddb7576e7d..094ef7269c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -49,6 +49,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages less)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages perl-compression)
#:use-module (gnu packages perl-web)
@@ -4261,6 +4262,41 @@ easier to develop interactive applications: is_interactive(), interactive(),
and busy().")
(license (package-license perl))))
+(define-public perl-io-pager
+ (package
+ (name "perl-io-pager")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JP/JPIERCE/IO-Pager-"
+ version
+ "0.tgz"))
+ (sha256
+ (base32
+ "1vzdypsr7vkj8nnda9ccrksci6pqj5awwmi89l7x3mbpq36gad87"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-less
+ (lambda _
+ (substitute* "lib/IO/Pager.pm"
+ (("/usr/local/bin/less', '/usr/bin/less")
+ (which "less")))
+ #t)))))
+ (propagated-inputs
+ `(("perl-file-which" ,perl-file-which)))
+ (inputs
+ `(("less" ,less)))
+ (home-page "https://metacpan.org/release/IO-Pager")
+ (synopsis "Select a pager and pipe text to it")
+ (description
+ "@code{IO::Pager} can be used to locate an available pager and use it to
+display output if a TTY is in use.")
+ (license (package-license perl))))
+
(define-public perl-io-string
(package
(name "perl-io-string")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 10/17] gnu: Add perl-test-checkdeps.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-10-mail@cbaines.net
* gnu/packages/perl-check.scm (perl-test-checkdeps): New variable.
---
gnu/packages/perl-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index aae83e5771..116651ec05 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -142,6 +142,30 @@ framework base class. It concentrates on offering reusable data driven
patterns, so that you can write tests with a minimum of code.")
(license perl-license)))
+(define-public perl-test-checkdeps
+ (package
+ (name "perl-test-checkdeps")
+ (version "0.010")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/L/LE/LEONT/Test-CheckDeps-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1vjinlixxdx6gfcw8y1dw2rla8bfhi8nmgcqr3nffc7kqskcrz36"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-cpan-meta-check" ,perl-cpan-meta-check)))
+ (home-page "https://metacpan.org/release/Test-CheckDeps")
+ (synopsis "Check for presence of dependencies")
+ (description
+ "This module provides a test that checks all dependencies have been
+installed properly.")
+ (license perl-license)))
+
(define-public perl-test-class
(package
(name "perl-test-class")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 11/17] gnu: Add perl-test-dir.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-11-mail@cbaines.net
* gnu/packages/perl-check.scm (perl-test-dir): New variable.
---
gnu/packages/perl-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 116651ec05..22e31ef40a 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -385,6 +385,30 @@ functions.")
;; license, any version, ..."
(license gpl3+)))
+(define-public perl-test-dir
+ (package
+ (name "perl-test-dir")
+ (version "1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MT/MTHURN/"
+ "Test-Dir-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hpafgr93jjl6s8spskhdxhgich4cccmaiq99mla5diyj4iv6ckk"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-pod-coverage" ,perl-pod-coverage)
+ ("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+ (home-page "https://metacpan.org/release/Test-Dir")
+ (synopsis "Utilities for testing directory attributes")
+ (description
+ "This modules provides a collection of test utilities for directory
+attributes.")
+ (license perl-license)))
+
(define-public perl-test-directory
(package
(name "perl-test-directory")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 08/17] gnu: Add perl-uri-nested.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-8-mail@cbaines.net
* gnu/packages/perl-web.scm (perl-uri-nested): New variable.
---
gnu/packages/perl-web.scm | 30 +++++++++++++++++++++++++++++-
1 file changed, 29 insertions(+), 1 deletion(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index c1af1d2caf..785a47c82c 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -21,9 +21,11 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (guix packages)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (guix download)
- #:use-module (guix build-system perl))
+ #:use-module (guix build-system perl)
+ #:use-module (gnu packages web))
(define-public perl-mojolicious
(package
@@ -70,3 +72,29 @@ percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
informally called URI escaping. This is the terminology used by this module,
which predates the formalization of the terms by the RFC by several years.")
(license license:perl-license)))
+
+(define-public perl-uri-nested
+ (package
+ (name "perl-uri-nested")
+ (version "0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/URI-Nested-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1bzg6f11m8wfnmycflvp858rs99xknsx8hkip0xcdfjzlqwi75z1"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-uri" ,perl-uri)))
+ (home-page "https://metacpan.org/release/URI-Nested")
+ (synopsis "Nested URIs")
+ (description
+ "@code{URI::Nested} provides support for nested URIs, where the scheme is
+a prefix, and the remainder of the URI is another URI.")
+ (license license:perl-license)))
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 09/17] gnu: Add perl-uri-db.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-9-mail@cbaines.net
* gnu/packages/perl-web.scm (perl-uri-db): New variable.
---
gnu/packages/perl-web.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/perl-web.scm b/gnu/packages/perl-web.scm
index 785a47c82c..db3ccdf6ec 100644
--- a/gnu/packages/perl-web.scm
+++ b/gnu/packages/perl-web.scm
@@ -50,6 +50,33 @@ used are outdated now, the idea behind it is not. Mojolicious is a new
endeavor to implement this idea using modern technologies.")
(license license:artistic2.0)))
+(define-public perl-uri-db
+ (package
+ (name "perl-uri-db")
+ (version "0.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/URI-db-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0n56xxlw7c39pfar0dxckr9mbmp6yrzk53ic0cb24raiykm9v6f4"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-uri" ,perl-uri)
+ ("perl-uri-nested" ,perl-uri-nested)))
+ (home-page "https://metacpan.org/release/URI-db")
+ (synopsis "Handle database URIs")
+ (description
+ "This module defines a format for database URIs, and provides a @{URI}
+class to handle these.")
+ (license license:perl-license)))
+
(define-public perl-uri-escape
(package
(name "perl-uri-escape")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 13/17] gnu: Add perl-test-file-contents.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-13-mail@cbaines.net
* gnu/packages/perl-check.scm (perl-test-file-contents): New variable.
---
gnu/packages/perl-check.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 43c9a09154..a1fb175596 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -572,6 +572,34 @@ testing exception-throwing code with about the same amount of typing.")
attributes.")
(license perl-license)))
+(define-public perl-test-file-contents
+ (package
+ (name "perl-test-file-contents")
+ (version "0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/Test-File-Contents-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0g8zgfyw84181snw7ghahnl9r4lrmlfj7zwi76sv8d0bj7xssvyd"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)
+ ("perl-text-diff" ,perl-text-diff)))
+ (home-page "https://metacpan.org/release/Test-File-Contents")
+ (synopsis "Test routines for examining the contents of files")
+ (description
+ "@{Test::File::Contents} provides functions for testing the contents of
+files.")
+ (license perl-license)))
+
(define-public perl-test-file-sharedir-dist
(package
(name "perl-test-file-sharedir-dist")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 12/17] gnu: Add perl-test-file.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-12-mail@cbaines.net
* gnu/packages/perl-check.scm (perl-test-file): New variable.
---
gnu/packages/perl-check.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 22e31ef40a..43c9a09154 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -548,6 +548,30 @@ Test::Exception. It does much less, but should allow greater flexibility in
testing exception-throwing code with about the same amount of typing.")
(license perl-license)))
+(define-public perl-test-file
+ (package
+ (name "perl-test-file")
+ (version "1.443")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/B/BD/BDFOY/Test-File-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1mdwb3x8d4l24wsymamsnq2c73a637v4q5kmb5xqqz31iymsdd31"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-utf8" ,perl-test-utf8)))
+ (home-page "https://metacpan.org/release/Test-File")
+ (synopsis "Utilities for testing file attributes")
+ (description
+ "@code{Test::File} provides a collection of test utilities for file
+attributes.")
+ (license perl-license)))
+
(define-public perl-test-file-sharedir-dist
(package
(name "perl-test-file-sharedir-dist")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 14/17] gnu: Add perl-test-version.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-14-mail@cbaines.net
* gnu/packages/perl-check.scm (perl-test-version): New variable.
---
gnu/packages/perl-check.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index a1fb175596..1c61297985 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1374,6 +1374,32 @@ check if a string is valid and not corrupt, whereas the characteristics tests
will check that string has a given set of characteristics.")
(license perl-license)))
+(define-public perl-test-version
+ (package
+ (name "perl-test-version")
+ (version "2.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PL/PLICEASE/Test-Version-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1q1qradaf7r2rb3jhpv01wl8z3bxymkfqrl9gwdhxwx5jwldvqcw"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)))
+ (propagated-inputs
+ `(("perl-file-find-rule-perl" ,perl-file-find-rule-perl)))
+ (home-page "https://metacpan.org/release/Test-Version")
+ (synopsis "Check versions in modules")
+ (description
+ "@code{Test::Version} checks to ensure that all modules have a version
+defined, and that the version is valid.")
+ (license artistic2.0)))
+
(define-public perl-test-warn
(package
(name "perl-test-warn")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 16/17] gnu: Add perl-string-shellquote.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-16-mail@cbaines.net
* gnu/packages/perl.scm (perl-string-shellquote): New variable.
---
gnu/packages/perl.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 78bbf73420..30bf0735f4 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7671,6 +7671,28 @@ fixed string interpolation, and simple width-matching.")
known prefixes.")
(license (package-license perl))))
+(define-public perl-string-shellquote
+ (package
+ (name "perl-string-shellquote")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RO/ROSCH/String-ShellQuote-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0dfxhr6hxc2majkkrm0qbx3qcbykzpphbj2ms93dc86f7183c1p6"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/String-ShellQuote")
+ (synopsis "Quote strings for passing through a shell")
+ (description
+ "@code{shell-quote} lets you pass arbitrary strings through the shell so
+that they won't be changed.")
+ (license (package-license perl))))
+
(define-public perl-string-print
(package
(name "perl-string-print")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 15/17] gnu: Add perl-mysql-config.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-15-mail@cbaines.net
* gnu/packages/databases.scm (perl-mysql-config): New variable.
---
gnu/packages/databases.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 301c4986c5..0f0d835eea 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1331,6 +1331,29 @@ module, and nothing else.")
(license license:perl-license)
(home-page "https://metacpan.org/release/DBD-SQLite")))
+(define-public perl-mysql-config
+ (package
+ (name "perl-mysql-config")
+ (version "1.04")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DARREN/MySQL-Config-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1svn7ccw2gc4cazvc58j84rxhnc9vs01zpird0l8460598j475qr"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/MySQL-Config")
+ (synopsis "Parse and utilize MySQL's /etc/my.cnf and ~/.my.cnf files")
+ (description
+ "@code{MySQL::Config} emulates the @code{load_defaults} function from
+libmysqlclient. It will fill an aray with long options, ready to be parsed by
+@code{Getopt::Long}.")
+ (license license:perl-license)))
+
(define-public perl-sql-abstract
(package
(name "perl-sql-abstract")
--
2.20.1
Christopher Baines wrote 6 years ago
[PATCH 17/17] gnu: Add sqitch.
(address . 34980@debbugs.gnu.org)
20190324204632.17055-17-mail@cbaines.net
* gnu/packages/databases.scm (sqitch): New variable.
---
gnu/packages/databases.scm | 87 ++++++++++++++++++++++++++++++++++++++
1 file changed, 87 insertions(+)

Toggle diff (107 lines)
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0f0d835eea..d256f0b895 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -82,6 +82,7 @@
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
+ #:use-module (gnu packages perl-web)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
@@ -996,6 +997,92 @@ for example from a shell script.")
;; others (like sparql-query.c) contain a GPLv2+ license header.
(license (list license:gpl3+))))
+(define-public sqitch
+ (package
+ (name "sqitch")
+ (version "0.9999")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/App-Sqitch-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1cvj8grs3bzc4g7dw1zc26g4biv1frav18sq0fkvi2kk0q1aigzm"))))
+ (build-system perl-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-check-environment
+ (lambda _
+ (setenv "TZ" "UTC")
+ (setenv "HOME" "/tmp")
+ #t))
+ (add-after 'install 'wrap-program
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (path (getenv "PERL5LIB")))
+ (wrap-program (string-append out "/bin/sqitch")
+ `("PERL5LIB" ":" prefix
+ (,(string-append out "/lib/perl5/site_perl"
+ ":"
+ path)))))
+ #t)))))
+ (native-inputs
+ `(("perl-capture-tiny" ,perl-capture-tiny)
+ ("perl-io-pager" ,perl-io-pager)
+ ("perl-module-build" ,perl-module-build)
+ ("perl-module-runtime" ,perl-module-runtime)
+ ("perl-path-class" ,perl-path-class)
+ ("perl-test-deep" ,perl-test-deep)
+ ("perl-test-dir" ,perl-test-dir)
+ ("perl-test-exception" ,perl-test-exception)
+ ("perl-test-file" ,perl-test-file)
+ ("perl-test-file-contents" ,perl-test-file-contents)
+ ("perl-test-mockmodule" ,perl-test-mockmodule)
+ ("perl-test-nowarnings" ,perl-test-nowarnings)
+ ("perl-test-warn" ,perl-test-warn)))
+ (propagated-inputs
+ `(("perl-class-xsaccessor" ,perl-class-xsaccessor)
+ ("perl-clone" ,perl-clone)
+ ("perl-config-gitlike" ,perl-config-gitlike)
+ ("perl-datetime" ,perl-datetime)
+ ("perl-datetime-timezone" ,perl-datetime-timezone)
+ ("perl-dbd-pg" ,perl-dbd-pg)
+ ("perl-dbi" ,perl-dbi)
+ ("perl-devel-stacktrace" ,perl-devel-stacktrace)
+ ("perl-encode-locale" ,perl-encode-locale)
+ ("perl-file-homedir" ,perl-file-homedir)
+ ("perl-hash-merge" ,perl-hash-merge)
+ ("perl-ipc-run3" ,perl-ipc-run3)
+ ("perl-ipc-system-simple" ,perl-ipc-system-simple)
+ ("perl-libintl-perl" ,perl-libintl-perl)
+ ("perl-list-moreutils" ,perl-list-moreutils)
+ ("perl-moo" ,perl-moo)
+ ("perl-mysql-config" ,perl-mysql-config)
+ ("perl-namespace-autoclean" ,perl-namespace-autoclean)
+ ("perl-path-class" ,perl-path-class)
+ ("perl-perlio-utf8_strict" ,perl-perlio-utf8_strict)
+ ("perl-string-formatter" ,perl-string-formatter)
+ ("perl-string-shellquote" ,perl-string-shellquote)
+ ("perl-sub-exporter" ,perl-sub-exporter)
+ ("perl-template-tiny" ,perl-template-tiny)
+ ("perl-template-toolkit" ,perl-template-toolkit)
+ ("perl-throwable" ,perl-throwable)
+ ("perl-try-tiny" ,perl-try-tiny)
+ ("perl-type-tiny" ,perl-type-tiny)
+ ("perl-type-tiny-xs" ,perl-type-tiny-xs)
+ ("perl-uri" ,perl-uri)
+ ("perl-uri-db" ,perl-uri-db)))
+ (home-page "https://metacpan.org/release/App-Sqitch")
+ (synopsis "Database change management tool")
+ (description
+ "Sqitch is a standalone change management system for database schemas,
+which uses SQL to describe changes.")
+ (license license:x11)))
+
(define-public sqlcrush
;; Unfortunately, there is no proper upstream release and may never be.
(let ((commit "b5f6868f189566a26eecc78d0f0659813c1aa98a")
--
2.20.1
Christopher Baines wrote 6 years ago
Re: [PATCH 00/17] Add sqitch, a database change management tool, and dependencies
(address . 34980-done@debbugs.gnu.org)
87wojqtoax.fsf@cbaines.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (26 lines)
> Christopher Baines (17):
> gnu: Add perl-http-tinyish.
> gnu: Add perl-config-gitlike.
> gnu: Add perl-cpan-distnameinfo.
> gnu: Add perl-tie-handle-offset.
> gnu: Add perl-io-pager.
> gnu: Add perl-string-formatter.
> gnu: Add perl-template-tiny.
> gnu: Add perl-uri-nested.
> gnu: Add perl-uri-db.
> gnu: Add perl-test-checkdeps.
> gnu: Add perl-test-dir.
> gnu: Add perl-test-file.
> gnu: Add perl-test-file-contents.
> gnu: Add perl-test-version.
> gnu: Add perl-mysql-config.
> gnu: Add perl-string-shellquote.
> gnu: Add sqitch.
>
> gnu/packages/databases.scm | 110 ++++++++++++++++++++++
> gnu/packages/perl-check.scm | 126 +++++++++++++++++++++++++
> gnu/packages/perl-web.scm | 57 +++++++++++-
> gnu/packages/perl.scm | 181 ++++++++++++++++++++++++++++++++++++
> gnu/packages/web.scm | 27 ++++++
> 5 files changed, 500 insertions(+), 1 deletion(-)

I've pushed these patches now, actually a little while ago, but I forgot
to close the bug.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAly5gLZfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9Xd/KBAAkl0ZOijfjVowMh5rxnGJPovspEB18TesA2jfLhFIFJpkm+V9SiFQdFx2
xzYm+hMGnXteOD27BwiR49fIxoxsxHgXvpwzqaknMotTezGitBp75WHKRItVtl1B
W5OTsxZfsIWQ1LbdNC8ZZkWf4rdjpzwG2G0hc4+psn7gJGhJWAPlmOZhkY+X3XtZ
tWzvjKl5s36ABgtXlf4xuVTet7uw3iSuepB/jnIUzuAj3yGVoxyhwigZOf+ihb53
qd6dvAXctlXMaqKEJ/Huq4y5RE2Z3VErlBy+WUmi2eBXFUWMGbaVq/xpsTHyZTvV
+9B1WmYB7o7SVUoIRbsneUWNsN8Xg5j/Xi4npG/JFPI5sXDt+H6BK4hGJHmfO1J7
TFhUWGk/1DGSMN+HCTL8acw2nrq32gEY4HiuydzWmMQ1xs9tcw0izx8lZUfK+q75
pU+9OgqFVF7YX7nFaFPkufMnrSqvi2imjmsBnF0SMj57HhdBuAXa2nhoWLlUy0zI
jDvK7E3DfGLcDF4sQZ4VQatR2Tm+qsDro0i+vAjrEp3X/P3oS8qWGr0JUr3BayMQ
C0KshhaIHb+Y6x5n3wwGt5UYLudlzFXmVITu7GSxmRZQ9nwiRLNDFg+OtEaTcyfR
odAfT0E/aB2PrqyNVl/G9P4OtVcaDHs59R7rPpk1JPz8WSdIKcg=
=DqfA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34980@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34980
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help