Add xfce4-whiskermenu-plugin

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • pkill9
Owner
unassigned
Submitted by
pkill9
Severity
normal

Debbugs page

pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
E1h7fG8-0008FZ-Ln@rmmprod06.runbox
Attached is a patch that adds the Whiskermenu panel plugin for Xfce: https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin

I originally had GTK+ added as an input, and the configure phase searches for it, but since it builds fine without GTK+ I've removed it. If Garcon is removed then it errors on not finding GTK+, but I don't know, if it works then *shrug*.
From e7a99c0c1fea1549b08cd2e4a1c540a3a0091675 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Sat, 23 Mar 2019 11:49:52 +0000
Subject: [PATCH] gnu: Add xfce4-whiskermenu-plugin.

* gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): New variable.
---
gnu/packages/xfce.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 6c253849f6..f716bd01eb 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -406,6 +408,38 @@ to an auto mixer tool like pavucontrol. It can optionally handle multimedia
keys for controlling the audio volume.")
(license gpl2+)))
+(define-public xfce4-whiskermenu-plugin
+ (package
+ (name "xfce4-whiskermenu-plugin")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1cnas2x7xi53v6ylq44040narhzd828dc0ysz8yk3qn2mmvp5yr2"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("xfce4-panel" ,xfce4-panel)
+ ("garcon" ,garcon)
+ ("exo" ,exo)))
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin")
+ (synopsis "Application menu panel plugin for Xfce")
+ (description
+ "An alternative to the default application menu panel plugin for Xfce4.
+It uses separate sections to display categories and applications, and
+includes a search bar to search for applications.")
+ ;;The main plugin code is covered by gpl2, but files in panel-plugin directory
+ ;;are covered by gpl2+. The SVG icon is covered by gpl2.
+ (license (list gpl2 gpl2+))))
+
(define-public xfce4-xkb-plugin
(package
(name "xfce4-xkb-plugin")
--
2.21.0
Ludovic Courtès wrote 6 years ago
(address . pkill9@runbox.com)(address . 34953-done@debbugs.gnu.org)
8736ncszcp.fsf@gnu.org
Hello,

<pkill9@runbox.com> skribis:

Toggle quote (4 lines)
> Attached is a patch that adds the Whiskermenu panel plugin for Xfce: https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin
>
> I originally had GTK+ added as an input, and the configure phase searches for it, but since it builds fine without GTK+ I've removed it. If Garcon is removed then it errors on not finding GTK+, but I don't know, if it works then *shrug*.

What happens is that GTK+ gets propagated via Garcon, which is why it
works even if you don’t add it as an input. However, since this package
clearly has a direct dependency on GTK+, we should add it to ‘inputs’.

Toggle quote (7 lines)
> From e7a99c0c1fea1549b08cd2e4a1c540a3a0091675 Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Sat, 23 Mar 2019 11:49:52 +0000
> Subject: [PATCH] gnu: Add xfce4-whiskermenu-plugin.
>
> * gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): New variable.

Applied with the changes below.

Thank you!

Ludo’.
Toggle diff (29 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index f716bd01eb..8543dcffed 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -427,17 +427,18 @@ keys for controlling the audio volume.")
(inputs
`(("xfce4-panel" ,xfce4-panel)
("garcon" ,garcon)
- ("exo" ,exo)))
+ ("exo" ,exo)
+ ("gtk+" ,gtk+-2)))
(arguments
`(#:tests? #f)) ; no tests
(home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin")
(synopsis "Application menu panel plugin for Xfce")
(description
- "An alternative to the default application menu panel plugin for Xfce4.
-It uses separate sections to display categories and applications, and
-includes a search bar to search for applications.")
- ;;The main plugin code is covered by gpl2, but files in panel-plugin directory
- ;;are covered by gpl2+. The SVG icon is covered by gpl2.
+ "This package provides an alternative to the default application menu
+panel plugin for Xfce4. It uses separate sections to display categories and
+applications, and includes a search bar to search for applications.")
+ ;; The main plugin code is covered by gpl2, but files in panel-plugin directory
+ ;; are covered by gpl2+. The SVG icon is covered by gpl2.
(license (list gpl2 gpl2+))))
(define-public xfce4-xkb-plugin
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34953@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34953
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help