Guix repository `make check` failing tests

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • mikadoZero
  • Ricardo Wurmus
Owner
unassigned
Submitted by
mikadoZero
Severity
normal

Debbugs page

mikadoZero wrote 6 years ago
(address . bug-guix@gnu.org)
cuch8bvjadb.fsf@yandex.com
Running `make check` in the Guix repository results it three failing
tests.

`git describe` in the Guix repository outputs:
v0.16.0-3655-g549332027

These are the steps actions that lead to this result.

Clone the Guix repository
`cd guix`
`guix environment guix`
`./bootstrap`
`./configure --localstatedir=/var`
`make`
`make check`

Attached is the "test-suite.log" with three failing tests.
Attachment: test-suite.log
Ludovic Courtès wrote 6 years ago
(name . mikadoZero)(address . mikadozero@yandex.com)(address . 34945-done@debbugs.gnu.org)
87h8bqhroo.fsf@gnu.org
Hello,

mikadoZero <mikadozero@yandex.com> skribis:

Toggle quote (36 lines)
> FAIL: tests/scripts
> ===================
>
> test-name: parse-command-line
> location: /home/guix/u/guix/guix/tests/scripts.scm:31
> source:
> + (test-equal
> + "parse-command-line"
> + '((argument . "bar")
> + (argument . "foo")
> + (cores . 10)
> + (substitutes? . #f)
> + (keep-failed? . #t)
> + (max-jobs . 77)
> + (cores . 42))
> + (with-environment-variable
> + "GUIX_BUILD_OPTIONS"
> + "-c 42 -M 77"
> + (parse-command-line
> + '("--keep-failed"
> + "--no-substitutes"
> + "--cores=10"
> + "foo"
> + "bar")
> + %standard-build-options
> + (list '()))))
> expected-value: ((argument . "bar") (argument . "foo") (cores . 10) (substitutes? . #f) (keep-failed? . #t) (max-jobs . 77) (cores . 42))
> actual-value: #f
> actual-error:
> + (unbound-variable
> + #f
> + "Unbound variable: ~S"
> + (with-environment-variable)
> + #f)
> result: FAIL

Fixed in 7b7e4e89c8a1a34e166a2755493e48035e8a78ab.

Toggle quote (9 lines)
> FAIL: tests/pack
> ================
>
> test-name: self-contained-tarball
> location: /home/guix/u/guix/guix/tests/pack.scm:58
> source:
> + (test-assert
> + "self-contained-tarball"

[...]

Toggle quote (10 lines)
> ;;; (binlink "/gnu/store/h3jhm791rbhni78wcfx43mpi0k3ddy9j-guile-bootstrap-2.0/bin")
>
> ;;; (guilelink "gnu/store/hjnd6yskqkyxb4np3hm0x2q2sakgqkzm-profile/bin")
> builder for `/gnu/store/0snjjbp96yrgrx0vqyhibkab02iqhzrb-check-tarball.drv' failed to produce output path `/gnu/store/id4yn32jlzpzi60n0szf5ajdi49ha6af-check-tarball'
> actual-value: #f
> actual-error:
> + (srfi-34
> + #<condition &store-protocol-error [message: "build of `/gnu/store/0snjjbp96yrgrx0vqyhibkab02iqhzrb-check-tarball.drv' failed" status: 1] 48526c0>)
> result: FAIL

Fixed in 9c2e58564f3c8b53ce86d5791e3ea5818e1a4fd6.

Thanks,
Ludo’.
Closed
mikadoZero wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 34945-done@debbugs.gnu.org)
cucbm1w5zn6.fsf@yandex.com
`git show 9c2e58564f3c8b53ce86d5791e3ea5818e1a4fd6` shows that I have
that commit.

When I run `make check -j3 TESTS="tests/scripts.scm tests/pack.scm"`
test/pack is still failing.

Attached is the "test-suite.log".
Attachment: test-suite.log
Ludovic Courtès writes:

Toggle quote (67 lines)
> Hello,
>
> mikadoZero <mikadozero@yandex.com> skribis:
>
>> FAIL: tests/scripts
>> ===================
>>
>> test-name: parse-command-line
>> location: /home/guix/u/guix/guix/tests/scripts.scm:31
>> source:
>> + (test-equal
>> + "parse-command-line"
>> + '((argument . "bar")
>> + (argument . "foo")
>> + (cores . 10)
>> + (substitutes? . #f)
>> + (keep-failed? . #t)
>> + (max-jobs . 77)
>> + (cores . 42))
>> + (with-environment-variable
>> + "GUIX_BUILD_OPTIONS"
>> + "-c 42 -M 77"
>> + (parse-command-line
>> + '("--keep-failed"
>> + "--no-substitutes"
>> + "--cores=10"
>> + "foo"
>> + "bar")
>> + %standard-build-options
>> + (list '()))))
>> expected-value: ((argument . "bar") (argument . "foo") (cores . 10) (substitutes? . #f) (keep-failed? . #t) (max-jobs . 77) (cores . 42))
>> actual-value: #f
>> actual-error:
>> + (unbound-variable
>> + #f
>> + "Unbound variable: ~S"
>> + (with-environment-variable)
>> + #f)
>> result: FAIL
>
> Fixed in 7b7e4e89c8a1a34e166a2755493e48035e8a78ab.
>
>> FAIL: tests/pack
>> ================
>>
>> test-name: self-contained-tarball
>> location: /home/guix/u/guix/guix/tests/pack.scm:58
>> source:
>> + (test-assert
>> + "self-contained-tarball"
>
> [...]
>
>> ;;; (binlink "/gnu/store/h3jhm791rbhni78wcfx43mpi0k3ddy9j-guile-bootstrap-2.0/bin")
>>
>> ;;; (guilelink "gnu/store/hjnd6yskqkyxb4np3hm0x2q2sakgqkzm-profile/bin")
>> builder for `/gnu/store/0snjjbp96yrgrx0vqyhibkab02iqhzrb-check-tarball.drv' failed to produce output path `/gnu/store/id4yn32jlzpzi60n0szf5ajdi49ha6af-check-tarball'
>> actual-value: #f
>> actual-error:
>> + (srfi-34
>> + #<condition &store-protocol-error [message: "build of `/gnu/store/0snjjbp96yrgrx0vqyhibkab02iqhzrb-check-tarball.drv' failed" status: 1] 48526c0>)
>> result: FAIL
>
> Fixed in 9c2e58564f3c8b53ce86d5791e3ea5818e1a4fd6.
>
> Thanks,
> Ludo’.
Closed
Ricardo Wurmus wrote 6 years ago
(name . mikadoZero)(address . mikadozero@yandex.com)(address . 34945-done@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludo@gnu.org)
87a7hg2hci.fsf@elephly.net
mikadoZero <mikadozero@yandex.com> writes:

Toggle quote (3 lines)
> @ build-started /home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv - x86_64-linux /home/guix/u/guix/failedTests/guix/test-tmp/var/log/guix/drvs/mp//s9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv.bz2 16915
> guix perform-download: error: refusing to run with elevated privileges (UID 0)

Are you running “make check” as root?

--
Ricardo
Closed
Ludovic Courtès wrote 6 years ago
(name . mikadoZero)(address . mikadozero@yandex.com)(address . 34945-done@debbugs.gnu.org)
87o95vb071.fsf@gnu.org
Hi,

mikadoZero <mikadozero@yandex.com> skribis:

Toggle quote (4 lines)
> @ build-started /home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv - x86_64-linux /home/guix/u/guix/failedTests/guix/test-tmp/var/log/guix/drvs/mp//s9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv.bz2 16915
> guix perform-download: error: refusing to run with elevated privileges (UID 0)
> builder for `/home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv' failed with exit code 1

I think the failure stems from the fact that you’re running “make check”
as root. You’re running it as root, right? Can you try as non-root?

Thanks,
Ludo’.
Closed
mikadoZero wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34945-done@debbugs.gnu.org)
cuc8swz57wi.fsf@yandex.com
Ludovic Courtès writes:

Toggle quote (14 lines)
> Hi,
>
> mikadoZero <mikadozero@yandex.com> skribis:
>
>> @ build-started /home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv - x86_64-linux /home/guix/u/guix/failedTests/guix/test-tmp/var/log/guix/drvs/mp//s9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv.bz2 16915
>> guix perform-download: error: refusing to run with elevated privileges (UID 0)
>> builder for `/home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv' failed with exit code 1
>
> I think the failure stems from the fact that you’re running “make check”
> as root. You’re running it as root, right? Can you try as non-root?
>
> Thanks,
> Ludo’.

I will try it with a non root user and share the results.
Closed
mikadoZero wrote 6 years ago
(address . 34945-done@debbugs.gnu.org)(name . Ricardo Wurmus)(address . rekado@elephly.net)(name . Ludovic Courtès)(address . ludo@gnu.org)
cuc7ecg5zy9.fsf@yandex.com
When I run the test that failed as a non root user it passes.

PASS: tests/pack.scm
============================================================================
Testsuite summary for GNU Guix 0.16.0.4215-1aa66
============================================================================
# TOTAL: 4
# PASS: 4
# SKIP: 0
# XFAIL: 0
# FAIL: 0
# XPASS: 0
# ERROR: 0
============================================================================

mikadoZero writes:

Toggle quote (17 lines)
> Ludovic Courtès writes:
>
>> Hi,
>>
>> mikadoZero <mikadozero@yandex.com> skribis:
>>
>>> @ build-started /home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv - x86_64-linux /home/guix/u/guix/failedTests/guix/test-tmp/var/log/guix/drvs/mp//s9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv.bz2 16915
>>> guix perform-download: error: refusing to run with elevated privileges (UID 0)
>>> builder for `/home/guix/u/guix/failedTests/guix/test-tmp/store/mps9fhh4frs84izvwl1pyl8hvyq593is-guile-2.0.9.tar.xz.drv' failed with exit code 1
>>
>> I think the failure stems from the fact that you’re running “make check”
>> as root. You’re running it as root, right? Can you try as non-root?
>>
>> Thanks,
>> Ludo’.
>
> I will try it with a non root user and share the results.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34945@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34945
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help