[PATCH] gnu: Add adanaxis-mush and adanaxisgpl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190319195734.2680-1-kkebreau@posteo.net
* gnu/packages/games.scm (adanaxis-mush, adanaxisgpl): New variables.
---
gnu/packages/games.scm | 74 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 74 insertions(+)

Toggle diff (87 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 56dc96de8f..67be6b9472 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -165,6 +165,80 @@
#:use-module ((srfi srfi-1) #:hide (zip))
#:use-module (srfi srfi-26))
+;; Data package for adanaxisgpl.
+(define adanaxis-mush
+ (let ((name "adanaxis-mush")
+ (version "1.1.0"))
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mushware.com/files/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0mk9ibis5nkdcalcg1lkgnsdxxbw4g5w2i3icjzy667hqirsng03")))))
+
+(define-public adanaxisgpl
+ (package
+ (name "adanaxisgpl")
+ (version "1.2.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.mushware.com/files/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0jkn637jaabvlhd6hpvzb57vvjph94l6fbf7qxbjlw9zpr19dw1f"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Necessary for building with gcc >=4.7.
+ (substitute* "src/Mushcore/MushcoreSingleton.h"
+ (("SingletonPtrSet\\(new SingletonType\\);")
+ "MushcoreSingleton::SingletonPtrSet(new SingletonType);"))
+ ;; Avoid an "invalid conversion from const char* to char*" error.
+ (substitute* "src/Platform/X11/PlatformMiscUtils.cpp"
+ (("char \\*end, \\*result;")
+ (string-append "const char *end;"
+ "\n"
+ "char *result;")))))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-data
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((data (assoc-ref inputs "adanaxis-mush"))
+ (share (string-append (assoc-ref outputs "out")
+ "/share/" ,name "-" ,version)))
+ (mkdir-p share)
+ (invoke "tar" "xvf" data "-C" share)))))))
+ (native-inputs
+ `(("adanaxis-mush" ,adanaxis-mush))) ; game data
+ (inputs
+ `(("expat" ,expat)
+ ("freeglut" ,freeglut)
+ ("glu" ,glu)
+ ("libjpeg" ,libjpeg)
+ ("libogg" ,libogg)
+ ("libtiff" ,libtiff)
+ ("libvorbis" ,libvorbis)
+ ("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("pcre" ,pcre)
+ ("sdl" ,sdl)
+ ("sdl-mixer" ,sdl-mixer)))
+ (home-page "https://www.mushware.com")
+ (synopsis "Action game in four spatial dimensions")
+ (description
+ "Adanaxis is a fast-moving first person shooter set in deep space, where
+the fundamentals of space itself are changed. By adding another dimension to
+space this game provides an environment with movement in four directions and
+six planes of rotation. Initially the game explains the 4D control system via
+a graphical sequence, before moving on to 30 levels of gameplay with numerous
+enemy, ally, weapon and mission types. Features include simulated 4D texturing,
+mouse and joystick control, and original music.")
+ (license license:gpl2)))
+
(define-public armagetronad
(package
(name "armagetronad")
--
2.21.0
Ludovic Courtès wrote 6 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 34921@debbugs.gnu.org)
87r2axv7li.fsf@gnu.org
Hello,

Kei Kebreau <kkebreau@posteo.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/games.scm (adanaxis-mush, adanaxisgpl): New variables.

[...]

Toggle quote (9 lines)
> +;; Data package for adanaxisgpl.
> +(define adanaxis-mush
> + (let ((name "adanaxis-mush")
> + (version "1.1.0"))
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://www.mushware.com/files/"
> + name "-" version ".tar.gz"))

There seems to be a consensus that using ‘name’ to build file names like
this isn’t great, so I’d suggest not doing it. :-)

Toggle quote (3 lines)
> + (uri (string-append "http://www.mushware.com/files/"
> + name "-" version ".tar.gz"))

Ditto.

Toggle quote (13 lines)
> + (snippet
> + '(begin
> + ;; Necessary for building with gcc >=4.7.
> + (substitute* "src/Mushcore/MushcoreSingleton.h"
> + (("SingletonPtrSet\\(new SingletonType\\);")
> + "MushcoreSingleton::SingletonPtrSet(new SingletonType);"))
> + ;; Avoid an "invalid conversion from const char* to char*" error.
> + (substitute* "src/Platform/X11/PlatformMiscUtils.cpp"
> + (("char \\*end, \\*result;")
> + (string-append "const char *end;"
> + "\n"
> + "char *result;")))))))

Please return #t.

Toggle quote (2 lines)
> + (license license:gpl2)))

If it’s v2-only, go for it!

Thank you,
Ludo’.
Kei Kebreau wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 34921-done@debbugs.gnu.org)
87bm1xw2m5.fsf@posteo.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (26 lines)
> Hello,
>
> Kei Kebreau <kkebreau@posteo.net> skribis:
>
>> * gnu/packages/games.scm (adanaxis-mush, adanaxisgpl): New variables.
>
> [...]
>
>> +;; Data package for adanaxisgpl.
>> +(define adanaxis-mush
>> + (let ((name "adanaxis-mush")
>> + (version "1.1.0"))
>> + (origin
>> + (method url-fetch)
>> + (uri (string-append "http://www.mushware.com/files/"
>> + name "-" version ".tar.gz"))
>
> There seems to be a consensus that using ‘name’ to build file names like
> this isn’t great, so I’d suggest not doing it. :-)
>
>> + (uri (string-append "http://www.mushware.com/files/"
>> + name "-" version ".tar.gz"))
>
> Ditto.
>

Noted!

Toggle quote (16 lines)
>> + (snippet
>> + '(begin
>> + ;; Necessary for building with gcc >=4.7.
>> + (substitute* "src/Mushcore/MushcoreSingleton.h"
>> + (("SingletonPtrSet\\(new SingletonType\\);")
>> + "MushcoreSingleton::SingletonPtrSet(new SingletonType);"))
>> + ;; Avoid an "invalid conversion from const char* to char*" error.
>> + (substitute* "src/Platform/X11/PlatformMiscUtils.cpp"
>> + (("char \\*end, \\*result;")
>> + (string-append "const char *end;"
>> + "\n"
>> + "char *result;")))))))
>
> Please return #t.
>

Done.

Toggle quote (7 lines)
>> + (license license:gpl2)))
>
> If it’s v2-only, go for it!
>
> Thank you,
> Ludo’.

Pushed! Thank you for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlyay8IACgkQ5qXuPBlG
eg3SHg//TmXbiio3DJpNBjdBqd31Yd01p795vIsw+izrl84UaWJuxRRT1aKTGo3t
tCrwgJfzqYNqMmdrSWxT/VOQNZ4gklFtOS+Mc26Ahy1KYw1kxT3KSdF1FzRLz1jt
87r85AlFxXUziBiLSyDbhF7rz+irZgIcn2foIaYi15IUl9VOXORTgCkaC7jOLVX9
QCILZeqaav/dxMScqq51mahaiShEMepW9M5Gs79C51I/k9qfDHSSzyLpucVyGdzJ
jQUNnJiqeUb1Rjnt15gradQHcMuJYuhPp67YJyOwo3+99CtyRuQMQc7gE3uu60tJ
jWPLQ/FayBXYUcTw0jjwgtqiaInZSbheZQvXUfzqsf4HCxNaSMUk8TJ1WYxVqt90
NP14QVLCTnX6KtL3DPpkn0VHDbu/ZX/0QayDT4TPBvLdZDfj+LcpD0dsmAokRZqN
TZzSNAifPc+GdN76oaBc617zQ2IBk6LdJu/MBjKK1opBRmiTkINCI/JQi+1xsq2c
MirtSR8yQJGxjLKAL0uPOdzMbhkziIu1uyJz/x9/HQSDJaVeacN9CwNLvk25S+zW
nHLY0v2Q+uvKzYgDRPPpsasN8YKYolIKwNwBKYyQnUcTrr/Wj5YgBfPimda/Ld99
GlAmg/WLrGJgE3IYLBBFoX9xMThHPxJcxcUwziUwbAiTIC9W+Gk=
=xyHQ
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34921@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34921
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help