[PATCH 2/2] gnu: python-language-server: [propagated-inputs] add

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Leo Famulari
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
875zslxcyq.fsf@posteo.net
From 844149bd57e7da174afb599dde2c5dca403ad8e7 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 14 Mar 2019 18:15:23 -0500
Subject: [PATCH 2/2] gnu: python-language-server: [propagated-inputs] add
python-pylint.

* gnu/packages/python-xyz.scm (python-language-server): [propagated-inputs]
add python-pylint
---
gnu/packages/python-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f55b36bbd..706524bbb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2653,7 +2653,8 @@ Server (PLS).")
("python-pycodestyle" ,python-pycodestyle)
("python-mccabe" ,python-mccabe)
("python-rope" ,python-rope)
- ("python-autopep8" ,python-autopep8)))
+ ("python-autopep8" ,python-autopep8)
+ ("python-pylint" ,python-pylint)))
(home-page "https://github.com/palantir/python-language-server")
(synopsis "Python implementation of the Language Server Protocol")
(description
--
2.21.0
Brett Gilio wrote 6 years ago
[PATCH 1/2] gnu: python-language-server: Update to 0.25.0.
(address . 34864@debbugs.gnu.org)
8736npxc6l.fsf@posteo.net
From e3eac10d90b047e958ae96cacfe39a76b1335941 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Thu, 14 Mar 2019 18:14:55 -0500
Subject: [PATCH 1/2] gnu: python-language-server: Update to 0.25.0.

* gnu/packages/python-xyz.scm (python-language-server): Update to 0.25.0.
---
gnu/packages/python-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab8e54329..f55b36bbd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2634,14 +2634,14 @@ Server (PLS).")
(define-public python-language-server
(package
(name "python-language-server")
- (version "0.24.0")
+ (version "0.25.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "python-language-server" version))
(sha256
(base32
- "05zmv6jr7qbgnkz0lqh5pr7kr4lm12i8ljm2k5h5kz3q9m8d4mm0"))))
+ "1xabnaqd4n72myrc3mxl2y33vr2p7c9c5a87n77p9k327ckvdx01"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pluggy" ,python-pluggy)
--
2.21.0
Leo Famulari wrote 6 years ago
Re: [bug#34864] [PATCH 2/2] gnu: python-language-server: [propagated-inputs] add
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34864-done@debbugs.gnu.org)
20190315014344.GA26748@jasmine.lan
On Thu, Mar 14, 2019 at 06:17:49PM -0500, Brett Gilio wrote:
Toggle quote (9 lines)
> From 844149bd57e7da174afb599dde2c5dca403ad8e7 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Thu, 14 Mar 2019 18:15:23 -0500
> Subject: [PATCH 2/2] gnu: python-language-server: [propagated-inputs] add
> python-pylint.
>
> * gnu/packages/python-xyz.scm (python-language-server): [propagated-inputs]
> add python-pylint

Thanks!

I noticed that python-language-server 0.25.0 fails to build without this
change, so I squashed the commits into one and pushed as
fe4a4bd23aa55bc6e8f5639db0dbfb358df99861.

In general, if some changes need to happen in the same commit to avoid
breakage, we make them in the same commit.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlyLA08ACgkQJkb6MLrK
fwiNLRAAu1beln0VZXm3O7MmzVvSGSO57XWWigYiwMO3E7e3POJtnJempWXUKYoY
H+LmUpzpLL9ziFW7NIZthFqjnSWF+k75VFbiQBDTu/eowZwWcy3d/KECTEK3xnXx
iywJZ4Vno8v3vftODgUrOKQ6/z9wOSUwTyx1BUP3t4ovxyxmj3DoZsQ+Ax1byaSR
FvJ+opufeAAfa5UTx7Pf+hK7knnlBU67xJQWMtoptBo5iWN9Z/WxdK6iLCRNgL4y
r5Y0mFsjqrCydkZ/Qh0ywvi9wWiy5YshO4MjYYBMZ+n/a2qF+7BZI3PDCPSCPFNQ
aRHTLtFuZXyDXdpBTOzGluOUZXhHMgdwJp+CjbGNbnJR7Dkhtuh7299NkeTPinn/
RReQgQAKvIZC0hbyD2n+0wE9rJ/1ErnTW1vl1ige72SJT1OUJkW9WEZRqhS+Qw25
Vi3AOzTafjYDKXNp7lOGoegagJ2xVXQKisrE1CY1Mt5wq/v7Hl3NUZMa73+4CPKo
fmll7talIZyTSB6aMJfqLcLoW9noT2LOit/LMYTSFd8zahnJGDvqHpKqxUzkvxQS
nQs0J2zQfPNqqeyyq6jwHBcnh6C3fCdWTB3c84KvYp/Z363d5XwHFMFh87OFFZMV
r+SwvCwwlKnICryloysl20TAGl304nxMVk32W/NpK9INfKnyx+g=
=Sw1K
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34864@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34864
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help