[PATCH] Remove the last vestiges of GuixSD.

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Tobias Geerinckx-Rice
Severity
normal
T
T
Tobias Geerinckx-Rice wrote on 13 Mar 2019 20:29
(address . guix-patches@gnu.org)(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
20190313192945.30680-1-somebody@not-sent-or-endorsed-by.tobias.gr
From: Tobias Geerinckx-Rice <me@tobias.gr>

…except for GuixSD-fully-black-4-3.svg in (gnu bootloader grub), which
will need to be updated in guix-artwork.git first.

* Makefile.am (GUIXSD_SUPPORTED_SYSTEMS, GUIXSD_VM_SYSTEMS)
(GUIXSD_IMAGE_BASE, GUIXSD_VM_IMAGE_BASE): Rename to…
(GUIX_SYSTEM_SUPPORTED_SYSTEMS, GUIX_SYSTEM_VM_SYSTEMS)
(GUIX_SYSTEM_IMAGE_BASE, GUIX_SYSTEM_VM_IMAGE_BASE): …these.
Adjust all users.
* doc/guix.texi (USB Stick and DVD Installation)
(Installing Guix in a VM, Running Guix in a VM): Change ‘guixsd’ to
‘guix-system’.
* gnu/system/vm.scm (iso9660-image, system-docker-image): Likewise.
Throw in a ‘GuixSD’ → ‘Guix System’ while we're here.
(system-disk-image): Throw in another.
(common-qemu-options): Back to changing ‘guixsd’ to ‘guix-system’.
* gnu/build/vm.scm (load-in-linux-vm): Likewise.
(make-iso9660-image, initialize-hard-disk): Change ‘GuixSD’ to
‘Guix_System’.
* gnu/system/install.scm (installation-os): Likewise.
* gnu/bootloader/extlinux.scm (extlinux-configuration-file): Change
‘GuixSD’ to ‘Guix System’.
* gnu/installer/newt/welcome.scm (run-welcome-page): Likewise.
* gnu/packages/audio.scm (supercollider)[description]: Likewise.
* gnu/services/cups.scm (%cups-activation): Likewise.
* gnu/services/mail.scm (%dovecot-activation): Likewise!
* gnu/services/messaging.scm (prosody-configuration): Likewise.
* gnu/system/examples/vm-image.tmpl (vm-image-motd): Likewise.
* gnu/tests/install.scm (run-install): Likewise.
* guix/modules.scm (guix-module-name?): Likewise.
* gnu/bootloader/grub.scm (grub-configuration-file, install-grub-efi):
Likewise.
* gnu/ci.scm (%guixsd-supported-systems): Rename to…
(%guix-system-supported-systems): …this. Adjust all callers.
(system-test-jobs, tarball-jobs): Change ‘GuixSD’ to ‘Guix System’.
* gnu/packages/crypto.scm (eschalot)[arguments]: Use a different
arbitrary non-derogatory string.
* gnu/packages/linux.scm (wireless-regdb)[arguments]: Change ‘GuixSD’ to
‘Guix’.
* gnu/packages/xorg.scm (xorg-server)[arguments]: Same same.
* gnu/packages/wicd.scm (wicd)[arguments]: But different (lower case).
---

Guix,

Phew.

T G-R

Makefile.am | 38 ++++++++++++++---------------
doc/guix.texi | 26 ++++++++++----------
gnu/bootloader/extlinux.scm | 4 +--
gnu/bootloader/grub.scm | 6 ++---
gnu/build/vm.scm | 8 +++---
gnu/ci.scm | 12 ++++-----
gnu/installer/newt/welcome.scm | 4 +--
gnu/packages/audio.scm | 2 +-
gnu/packages/backup.scm | 2 +-
gnu/packages/crypto.scm | 2 +-
gnu/packages/curl.scm | 6 ++---
gnu/packages/emacs.scm | 2 +-
gnu/packages/gnome.scm | 2 +-
gnu/packages/julia.scm | 2 +-
gnu/packages/kde-frameworks.scm | 2 +-
gnu/packages/linux.scm | 10 ++++----
gnu/packages/package-management.scm | 4 +--
gnu/packages/polkit.scm | 2 +-
gnu/packages/tex.scm | 2 +-
gnu/packages/wicd.scm | 2 +-
gnu/packages/xorg.scm | 2 +-
gnu/services/base.scm | 2 +-
gnu/services/cups.scm | 2 +-
gnu/services/mail.scm | 2 +-
gnu/services/messaging.scm | 2 +-
gnu/system/examples/vm-image.tmpl | 2 +-
gnu/system/install.scm | 2 +-
gnu/system/mapped-devices.scm | 2 +-
gnu/system/vm.scm | 16 ++++++------
gnu/tests/install.scm | 6 ++---
guix/modules.scm | 2 +-
nix/libstore/optimise-store.cc | 4 +--
32 files changed, 91 insertions(+), 91 deletions(-)

Toggle diff (359 lines)
diff --git a/Makefile.am b/Makefile.am
index cf35770ba7..d250fef228 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -661,17 +661,17 @@ SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux armhf-linux aarch64-linux
BINARY_TARBALLS = \
$(foreach system,$(SUPPORTED_SYSTEMS),guix-binary.$(system).tar.xz)
-# Systems supported by GuixSD.
-GUIXSD_SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux
+# Systems supported by Guix System.
+GUIX_SYSTEM_SUPPORTED_SYSTEMS ?= x86_64-linux i686-linux
-# Systems for which we build GuixSD VMs.
-GUIXSD_VM_SYSTEMS ?= x86_64-linux
+# Systems for which we build Guix System VMs.
+GUIX_SYSTEM_VM_SYSTEMS ?= x86_64-linux
-# Prefix of the GuixSD installation image file name.
-GUIXSD_IMAGE_BASE = guixsd-install-$(PACKAGE_VERSION)
+# Prefix of the Guix System installation image file name.
+GUIX_SYSTEM_IMAGE_BASE = guix-system-install-$(PACKAGE_VERSION)
-# Prefix of the GuixSD VM image file name.
-GUIXSD_VM_IMAGE_BASE = guixsd-vm-image-$(PACKAGE_VERSION)
+# Prefix of the Guix System VM image file name.
+GUIX_SYSTEM_VM_IMAGE_BASE = guix-system-vm-image-$(PACKAGE_VERSION)
# The release process works in several phases:
#
@@ -680,7 +680,7 @@ GUIXSD_VM_IMAGE_BASE = guixsd-vm-image-$(PACKAGE_VERSION)
# 2. Update the 'guix' package so that it corresponds to the 'vX.Y' tag.
# 3. Build the binary tarballs for that 'guix' package.
# 4. Update the 'guix' package again.
-# 5. Build the GuixSD installation images. The images will run 'guix'
+# 5. Build the Guix System installation images. The images will run 'guix'
# corresponding to 'vX.Y' + 1 commit, and they will install 'vX.Y'.
#
# This 'release' target takes care of everything and copies the resulting
@@ -713,32 +713,32 @@ release: dist
"`git rev-parse HEAD`"
git add $(top_srcdir)/gnu/packages/package-management.scm
git commit -m "gnu: guix: Update to `git rev-parse HEAD | cut -c1-7`."
- for system in $(GUIXSD_SUPPORTED_SYSTEMS) ; do \
+ for system in $(GUIX_SYSTEM_SUPPORTED_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
guix system disk-image \
--file-system-type=iso9660 \
--system=$$system \
gnu/system/install.scm` ; \
if [ ! -f "$$image" ] ; then \
- echo "failed to produced GuixSD installation image for $$system" >&2 ; \
+ echo "failed to produced Guix System installation image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" ; \
- mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" \
- "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz" ; \
+ xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz.tmp" ; \
+ mv "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz.tmp" \
+ "$(releasedir)/$(GUIX_SYSTEM_IMAGE_BASE).$$system.iso.xz" ; \
done
- for system in $(GUIXSD_VM_SYSTEMS) ; do \
+ for system in $(GUIX_SYSTEM_VM_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
guix system vm-image \
--system=$$system \
gnu/system/examples/vm-image.tmpl` ; \
if [ ! -f "$$image" ] ; then \
- echo "failed to produced GuixSD VM image for $$system" >&2 ; \
+ echo "failed to produced Guix System VM image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIXSD_VM_IMAGE_BASE).$$system.xz.tmp" ; \
- mv "$(releasedir)/$(GUIXSD_VM_IMAGE_BASE).$$system.xz.tmp" \
- "$(releasedir)/$(GUIXSD_VM_IMAGE_BASE).$$system.xz" ; \
+ xz < "$$image" > "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz.tmp" ; \
+ mv "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz.tmp" \
+ "$(releasedir)/$(GUIX_SYSTEM_VM_IMAGE_BASE).$$system.xz" ; \
done
@echo
@echo "Congratulations! All the release files are now in $(releasedir)."
diff --git a/doc/guix.texi b/doc/guix.texi
index b0837b36fa..1831f9e5bb 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1866,7 +1866,7 @@ about their support in GNU/Linux.
An ISO-9660 installation image that can be written to a USB stick or
burnt to a DVD can be downloaded from
-@indicateurl{https://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.iso.xz},
+@indicateurl{https://alpha.gnu.org/gnu/guix/guix-system-install-@value{VERSION}.@var{system}.iso.xz},
where @var{system} is one of:
@table @code
@@ -1882,8 +1882,8 @@ Make sure to download the associated @file{.sig} file and to verify the
authenticity of the image against it, along these lines:
@example
-$ wget https://alpha.gnu.org/gnu/guix/guixsd-install-@value{VERSION}.@var{system}.iso.xz.sig
-$ gpg --verify guixsd-install-@value{VERSION}.@var{system}.iso.xz.sig
+$ wget https://alpha.gnu.org/gnu/guix/guix-system-install-@value{VERSION}.@var{system}.iso.xz.sig
+$ gpg --verify guix-system-install-@value{VERSION}.@var{system}.iso.xz.sig
@end example
If that command fails because you do not have the required public key,
@@ -1910,7 +1910,7 @@ To copy the image to a USB stick, follow these steps:
Decompress the image using the @command{xz} command:
@example
-xz -d guixsd-install-@value{VERSION}.@var{system}.iso.xz
+xz -d guix-system-install-@value{VERSION}.@var{system}.iso.xz
@end example
@item
@@ -1919,7 +1919,7 @@ its device name. Assuming that the USB stick is known as @file{/dev/sdX},
copy the image with:
@example
-dd if=guixsd-install-@value{VERSION}.@var{system}.iso of=/dev/sdX
+dd if=guix-system-install-@value{VERSION}.@var{system}.iso of=/dev/sdX
sync
@end example
@@ -1935,7 +1935,7 @@ To copy the image to a DVD, follow these steps:
Decompress the image using the @command{xz} command:
@example
-xz -d guixsd-install-@value{VERSION}.@var{system}.iso.xz
+xz -d guix-system-install-@value{VERSION}.@var{system}.iso.xz
@end example
@item
@@ -1944,7 +1944,7 @@ its device name. Assuming that the DVD drive is known as @file{/dev/srX},
copy the image with:
@example
-growisofs -dvd-compat -Z /dev/srX=guixsd-install-@value{VERSION}.@var{system}.iso
+growisofs -dvd-compat -Z /dev/srX=guix-system-install-@value{VERSION}.@var{system}.iso
@end example
Access to @file{/dev/srX} usually requires root privileges.
@@ -2352,7 +2352,7 @@ Create a disk image that will hold the installed system. To make a
qcow2-formatted disk image, use the @command{qemu-img} command:
@example
-qemu-img create -f qcow2 guixsd.img 50G
+qemu-img create -f qcow2 guix-system.img 50G
@end example
The resulting file will be much smaller than 50 GB (typically less than
@@ -2364,8 +2364,8 @@ Boot the USB installation image in an VM:
@example
qemu-system-x86_64 -m 1024 -smp 1 \
-net user -net nic,model=virtio -boot menu=on \
- -drive file=guixsd-install-@value{VERSION}.@var{system}.iso \
- -drive file=guixsd.img
+ -drive file=guix-system-install-@value{VERSION}.@var{system}.iso \
+ -drive file=guix-system.img
@end example
The ordering of the drives matters.
@@ -2380,7 +2380,7 @@ You're now root in the VM, proceed with the installation process.
@end enumerate
Once installation is complete, you can boot the system that's on your
-@file{guixsd.img} image. @xref{Running Guix in a VM}, for how to do
+@file{guix-system.img} image. @xref{Running Guix in a VM}, for how to do
that.
@node Building the Installation Image
@@ -23387,7 +23387,7 @@ system configuration file. You can then load the image and launch a
Docker container using commands like the following:
@example
-image_id="$(docker load < guixsd-docker-image.tar.gz)"
+image_id="$(docker load < guix-system-docker-image.tar.gz)"
docker run -e GUIX_NEW_SYSTEM=/var/guix/profiles/system \\
--entrypoint /var/guix/profiles/system/profile/bin/guile \\
$image_id /var/guix/profiles/system/boot
@@ -23573,7 +23573,7 @@ example graph.
@cindex virtual machine
To run Guix in a virtual machine (VM), one can either use the
pre-built Guix VM image distributed at
-@indicateurl{https://alpha.gnu.org/gnu/guix/guixsd-vm-image-@value{VERSION}.@var{system}.xz}
+@indicateurl{https://alpha.gnu.org/gnu/guix/guix-system-vm-image-@value{VERSION}.@var{system}.xz}
, or build their own virtual machine image using @command{guix system
vm-image} (@pxref{Invoking guix system}). The returned image is in
qcow2 format, which the @uref{http://qemu.org/, QEMU emulator} can
diff --git a/gnu/bootloader/extlinux.scm b/gnu/bootloader/extlinux.scm
index b48596c496..ebd99a2207 100644
--- a/gnu/bootloader/extlinux.scm
+++ b/gnu/bootloader/extlinux.scm
@@ -57,10 +57,10 @@ corresponding to old generations of the system."
#~(call-with-output-file #$output
(lambda (port)
(let ((timeout #$(bootloader-configuration-timeout config)))
- (format port "# This file was generated from your GuixSD configuration. Any changes
+ (format port "# This file was generated from your Guix System configuration. Any changes
# will be lost upon reconfiguration.
UI menu.c32
-MENU TITLE GuixSD Boot Options
+MENU TITLE Guix System Boot Options
PROMPT ~a
TIMEOUT ~a~%"
(if (> timeout 0) 1 0)
diff --git a/gnu/bootloader/grub.scm b/gnu/bootloader/grub.scm
index 161e8b3d02..0750800304 100644
--- a/gnu/bootloader/grub.scm
+++ b/gnu/bootloader/grub.scm
@@ -334,7 +334,7 @@ entries corresponding to old generations of the system."
#~(call-with-output-file #$output
(lambda (port)
(format port
- "# This file was generated from your GuixSD configuration. Any changes
+ "# This file was generated from your Guix System configuration. Any changes
# will be lost upon reconfiguration.
")
#$sugar
@@ -380,7 +380,7 @@ submenu \"GNU system, old configurations...\" {~%")
;; system whose root is mounted at MOUNT-POINT.
(let ((grub-install (string-append bootloader "/sbin/grub-install"))
(install-dir (string-append mount-point "/boot"))
- ;; When installing GuixSD, it's common to mount EFI-DIR below
+ ;; When installing Guix System, it's common to mount EFI-DIR below
;; MOUNT-POINT rather than /boot/efi on the live image.
(target-esp (if (file-exists? (string-append mount-point efi-dir))
(string-append mount-point efi-dir)
@@ -389,7 +389,7 @@ submenu \"GNU system, old configurations...\" {~%")
;; root partition.
(setenv "GRUB_ENABLE_CRYPTODISK" "y")
(unless (zero? (system* grub-install "--boot-directory" install-dir
- "--bootloader-id=GuixSD"
+ "--bootloader-id=Guix System"
"--efi-directory" target-esp))
(error "failed to install GRUB (EFI)")))))
diff --git a/gnu/build/vm.scm b/gnu/build/vm.scm
index 0aef73d26d..3f41771ecb 100644
--- a/gnu/build/vm.scm
+++ b/gnu/build/vm.scm
@@ -145,8 +145,8 @@ the #:references-graphs parameter of 'derivation'."
(apply invoke qemu "-nographic" "-no-reboot"
"-m" (number->string memory-size)
- "-object" "rng-random,filename=/dev/urandom,id=guixsd-vm-rng"
- "-device" "virtio-rng-pci,rng=guixsd-vm-rng"
+ "-object" "rng-random,filename=/dev/urandom,id=guix-system-vm-rng"
+ "-device" "virtio-rng-pci,rng=guix-system-vm-rng"
"-virtfs"
(string-append "local,id=store_dev,path="
(%store-directory)
@@ -422,7 +422,7 @@ SYSTEM-DIRECTORY is the name of the directory of the 'system' derivation."
(string-append "boot/grub/grub.cfg=" config-file))))
(define* (make-iso9660-image grub config-file os-drv target
- #:key (volume-id "GuixSD_image") (volume-uuid #f)
+ #:key (volume-id "Guix_System_image") (volume-uuid #f)
register-closures? (closures '()))
"Given a GRUB package, creates an iso image as TARGET, using CONFIG-FILE as
GRUB configuration and OS-DRV as the stuff in it."
@@ -550,7 +550,7 @@ passing it a directory name where it is mounted."
(lambda (port)
(format port
"insmod part_msdos~@
- search --set=root --label GuixSD_image~@
+ search --set=root --label Guix_System_image~@
configfile /boot/grub/grub.cfg~%")))
(display "creating EFI firmware image...")
diff --git a/gnu/ci.scm b/gnu/ci.scm
index 2c04b7189d..05e24655ad 100644
--- a/gnu/ci.scm
+++ b/gnu/ci.scm
@@ -132,7 +132,7 @@ SYSTEM."
"i586-pc-gnu" ;aka. GNU/Hurd
"i686-w64-mingw32"))
-(define %guixsd-supported-systems
+(define %guix-system-supported-systems
'("x86_64-linux" "i686-linux" "armhf-linux"))
(define %u-boot-systems
@@ -161,7 +161,7 @@ system.")
(define MiB
(expt 2 20))
- (if (member system %guixsd-supported-systems)
+ (if (member system %guix-system-supported-systems)
(if (member system %u-boot-systems)
(list (->job 'flash-image
(run-with-store store
@@ -235,7 +235,7 @@ system.")
(system-test-value test))))
`((derivation . ,(derivation-file-name drv))
- (description . ,(format #f "GuixSD '~a' system test"
+ (description . ,(format #f "Guix System '~a' system test"
(system-test-name test)))
(long-description . ,(system-test-description test))
(license . ,(license-name gpl3+))
@@ -250,7 +250,7 @@ system.")
"." system))))
(cons name (test->thunk test))))
- (if (and (member system %guixsd-supported-systems)
+ (if (and (member system %guix-system-supported-systems)
;; XXX: Our build farm has too few ARMv7 machines and they are very
;; slow, so skip system tests there.
@@ -269,8 +269,8 @@ system.")
(define (->alist drv)
`((derivation . ,(derivation-file-name drv))
(description . "Stand-alone binary Guix tarball")
- (long-description . "This is a tarball containing binaries of Guix and
-all its dependencies, and ready to be installed on non-GuixSD distributions.")
+ (long-description . "This is a tarball containing binaries of Guix and all
+its dependencies, and ready to be installed on non-Guix System distributions.")
(license . ,(license-name gpl3+))
(home-page . ,%guix-home-page-url)
(maintainers . ("bug-guix@gnu.org"))))
diff --git a/gnu/installer/newt/welcome.scm b/gnu/installer/newt/welcome.scm
index eec98e291a..317234cbb5 100644
--- a/gnu/installer/newt/welcome.scm
+++ b/gnu/installer/newt/welcome.scm
@@ -92,8 +92,8 @@ we want this page to occupy all the screen space available."
the page. Ask the user to choose between manual installation, graphical
installation and reboot."
(run-menu-page
- (G_ "GNU GuixSD install")
- (G_ "Welcome to GNU GuixSD installer!
+ (G_ "GNU Guix System install")
+ (G_ "Welcome to GNU Guix System installer!
Please note that the present graphical installer is still under heavy \
development, so you might want to prefer using the shell based process. \
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d77ad3d1c4..e59fae4f32 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -2270,7 +2270,7 @@ for experimenting with sound synthesis and algorithmic composition.
SuperCollider requires jackd to be installed in your user profile and your
user must be allowed to access the realtime features of the kernel. Search
for \"realtime\" in the index of the Guix manual to learn how to achieve this
-using GuixSD.")
+using Guix System.")
(license license:gpl2+)))
(define-public raul
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index f70b67bb7f..6e705d8a71 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -809,7 +809,7 @@ used, does not require any special software, on top of SSH.")
(output-dir
(assoc-ref outputs "out"))
- ;; Just a default... not so useful on guixsd though
+
This message was truncated. Download the full message here.
T
T
Tobias Geerinckx-Rice wrote on 13 Mar 2019 20:46
(address . 34848@debbugs.gnu.org)
87wol24kwu.fsf@nckx
Guix,

Tobias Geerinckx-Rice wrote:
Toggle quote (2 lines)
> [PATCH] Remove the last vestiges of GuixSD.

I'm running the test suite now, which on my laptop that means that
I won't find that one stupid typo until tomorrow.

Meanwhile: thoughts?

The longer ISO image volume names shouldn't pose a problem; the
limit's 32.

Kind regards,

T G-R
T
T
Tobias Geerinckx-Rice wrote on 13 Mar 2019 23:35
Re: bug#34848: Acknowledgement ([PATCH] Remove the last vestiges of GuixSD.)
(address . 34848-done@debbugs.gnu.org)
87va0m4d2y.fsf@nckx
Never mind.

T G-R
Closed
?