emacs-json-mode check phase failing

  • Done
  • quality assurance status badge
Details
2 participants
  • Oleg Pykhalov
  • mikadoZero
Owner
unassigned
Submitted by
mikadoZero
Severity
normal

Debbugs page

mikadoZero wrote 6 years ago
(address . bug-guix@gnu.org)
20190303024433.GA4885@z.z
When I add `emacs-json-mode` to my Guix SD configuration and run `guix system reconfigure` I get this error:

building /gnu/store/3m18s0yhkyikgb2z1ivr321h4vrhi9nl-emacs-json-reformat-0.0.6.drv..
.
\ 'check' phasebuilder for `/gnu/store/3m18s0yhkyikgb2z1ivr321h4vrhi9nl-emacs-json-r
eformat-0.0.6.drv' failed with exit code 1
build of /gnu/store/3m18s0yhkyikgb2z1ivr321h4vrhi9nl-emacs-json-reformat-0.0.6.drv f
ailed
View build log at '/var/log/guix/drvs/3m/18s0yhkyikgb2z1ivr321h4vrhi9nl-emacs-json-r
eformat-0.0.6.drv.bz2'.
cannot build derivation `/gnu/store/snlxnxmjdibdis1vvbbxgmpi9r4anb3x-emacs-json-mode
-1.7.0.drv': 1 dependencies couldn't be built
guix system: error: build of `/gnu/store/snlxnxmjdibdis1vvbbxgmpi9r4anb3x-emacs-json
-mode-1.7.0.drv' failed

The log ends with:

starting phase `check'
.Test json-reformat-test:json-reformat-region backtrace:

signal(ert-test-failed (((should (string= "{\n \"name\": \"John S
ert-fail(((should (string= "{\n \"name\": \"John Smith\",\n \"
(if (unwind-protect (setq value-132 (apply fn-130 args-131)) (setq f
(let (form-description-134) (if (unwind-protect (setq value-132 (app
(let ((value-132 'ert-form-evaluation-aborted-133)) (let (form-descr
(let* ((fn-130 (function string=)) (args-131 (condition-case err (le
(lambda nil (let* ((fn-130 (function string=)) (args-131 (condition-
ert--run-test-internal(#s(ert--test-execution-info :test #s(ert-test
ert-run-test(#s(ert-test :name json-reformat-test:json-reformat-regi
ert-run-or-rerun-test(#s(ert--stats :selector (and t) :tests [#s(ert
ert-run-tests((and t) (lambda (event-type &rest event-args) (cond ((
ert-runner/run-tests-batch((and t))
(let ((stats (ert-runner/run-tests-batch selector))) (kill-emacs (if
ert-runner/run-tests-batch-and-exit((and t))
(if ert-runner-verbose (ert-runner/run-tests-batch-and-exit ert-runn
(let ((test-files (ert-runner--test-files tests)) (test-helper (f-ex
ert-runner/run()
apply(ert-runner/run nil)
commander--handle-command(nil)
commander-parse(nil)
(if commander-parsing-done nil (commander-parse (or commander-args (
eval-buffer(#<buffer *load*> nil "/gnu/store/xj17vzrd65p60n9wifadzm
load-with-code-conversion("/gnu/store/xj17vzrd65p60n9wifadzmkjliknsn
load("/gnu/store/xj17vzrd65p60n9wifadzmkjliknsnv5-emacs-ert-runner-0
command-line-1(("-scriptload" "/gnu/store/xj17vzrd65p60n9wifadzmkjli
command-line()
normal-top-level()

Test json-reformat-test:json-reformat-region condition:

(ert-test-failed
((should
(string= "{
\"name\": \"John Smith\",
\"age\": 33,
\"breakfast\": [
\"milk\",
\"bread\",
\"egg\"
]
}"
(with-temp-buffer ... ... ...)))
:form
(string= "{
\"name\": \"John Smith\",
\"age\": 33,
\"breakfast\": [
\"milk\",
\"bread\",
\"egg\"
]
}" "{
\"breakfast\": [
\"milk\",
\"bread\",
\"egg\"
],
\"age\": 33,
\"name\": \"John Smith\"
}")
:value nil))

F........

Ran 10 tests in 0.555 seconds
1 unexpected results:
FAILED json-reformat-test:json-reformat-region
Backtrace:
4 (primitive-load "/gnu/store/f3q1xjz02yszgg2rq3phs57vgqd…")
In ice-9/eval.scm:
191:35 3 (_ #f)
In srfi/srfi-1.scm:
863:16 2 (every1 #<procedure 6d6bc0 at /gnu/store/djq0g2g74z8gg…> …)
In /gnu/store/djq0g2g74z8ggyv09v32z2w6izfrxlx0-module-import/guix/build/gnu-build-sy
stem.scm:
799:28 1 (_ _)
In /gnu/store/djq0g2g74z8ggyv09v32z2w6izfrxlx0-module-import/guix/build/utils.scm:
616:6 0 (invoke _ . _)

/gnu/store/djq0g2g74z8ggyv09v32z2w6izfrxlx0-module-import/guix/build/utils.scm:616:6
: In procedure invoke:
Throw to key `srfi-34' with args `(#<condition &invoke-error [program: "ert-runner"
arguments: () exit-status: 1 term-signal: #f stop-signal: #f] 774e80>)'.
mikadoZero wrote 6 years ago
`guix describe` output
(address . 34719@debbugs.gnu.org)
20190303130043.GA28957@z.z
The output of `guix describe` is:

guix 35556d7
branch: master
commit: 35556d7da01f00ffdbc9b3218ef2669dd28e3b62
Oleg Pykhalov wrote 6 years ago
[PATCH] gnu: emacs-json-reformat: Fix test.
(address . 34719@debbugs.gnu.org)(address . mikadozero@yandex.com)(name . Oleg Pykhalov)(address . go.wigust@gmail.com)
20190309211653.5265-1-go.wigust@gmail.com
This patch deletes a test which tries to compare JSON objects order.

* gnu/packages/emacs-xyz.scm (emacs-json-reformat): Delete
'json-reformat-test:json-reformat-region' test.
---
gnu/packages/emacs-xyz.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 30248f673a..b359777923 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26,7 +26,7 @@
;;; Copyright © 2017 George Clemmer <myglc2@gmail.com>
;;; Copyright © 2017, 2018 Feng Shu <tumashu@163.com>
;;; Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2017, 2018, 2019 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
;;; Copyright © 2017 Peter Mikkelsen <petermikkelsen10@gmail.com>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -7032,7 +7032,19 @@ running a customisable handler command (@code{ignore} by default). ")
("ert-runner" ,emacs-ert-runner)))
(arguments
`(#:tests? #t
- #:test-command '("ert-runner")))
+ #:test-command '("ert-runner")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'delete-json-objects-order-test
+ (lambda _
+ (emacs-batch-edit-file "test/json-reformat-test.el"
+ `(progn (progn (goto-char (point-min))
+ (re-search-forward
+ "ert-deftest json-reformat-test:json-reformat-region")
+ (beginning-of-line)
+ (kill-sexp))
+ (basic-save-buffer)))
+ #t)))))
(home-page "https://github.com/gongo/json-reformat")
(synopsis "Reformatting tool for JSON")
(description "@code{json-reformat} provides a reformatting tool for
--
2.21.0
Oleg Pykhalov wrote 6 years ago
(address . mikadozero@yandex.com)(address . 34719-done@debbugs.gnu.org)
87y35lwbwu.fsf@gmail.com
Hi mikadoZero,

Thank you for the report.

You could try ‘guix reconfigure’ after ‘guix pull’.

Oleg Pykhalov <go.wigust@gmail.com> writes:

Toggle quote (13 lines)
> This patch deletes a test which tries to compare JSON objects order.
>
> * gnu/packages/emacs-xyz.scm (emacs-json-reformat): Delete
> 'json-reformat-test:json-reformat-region' test.
> ---
> gnu/packages/emacs-xyz.scm | 16 ++++++++++++++--
> 1 file changed, 14 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 30248f673a..b359777923 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAlyGnLEACgkQFn+OpQAa
+pwyqRAAvs6P7GgMLlm1ASQAV8KimiVU4iNy2ovERJl1LfZ2Rt0ybNpxzE/NXBOn
eujhzZmgkXwBFqiVNUG+Y+w0q6GXs2ZdqYQ2ivrAOXW+/8yB5C+puK3i2L6h/9OI
G9Ntu3UlYhyTTTdyDyl9fw3n9ETcZxJtXYYUrTW7ZwPn0G6TMuix8r28qpQWbXoS
ucUBG1FNO+3NSLUUgPAcw2M4SakVCRH/kkYn/ZEK3S673bnT/bqfEigRmSSi+Ppx
O7HNBpqHHndCrYG4t46zUNmEyeQ0Lk+LSqnCE0oqe6miHmqvSKbhtydTkF3I0TPn
VMHmgcafeSDQ09F6ZIBfiw1Bs8mGKiHb9B5UIjdV3wb6gFvSlJUBF/eZnTFXuEAP
ha8DCrNScoO3U92tl1NpRV+i8WQ+8Wu7V7eN4Xoajae3nwGE2NHlWdOVPfPPZCqj
m5qxtDlCu0ObV42MCFtdmoTjIWbNsd6wCdmYjdpBYajbekxtAwys3EP00scDeIKr
u7ylXgAX38dHH+GPsssCA6L0ZsO6rSudU62EYwn1aq4oHReBOdVZ4MJs67zfZDDw
/jAP2w9UYVDLbb2e5UTdZOTLgqXfI/u7oLxg7K1YH+11HxQvOgKo3jePkW10fAWE
eGtMVaoQRFNzM9OQ+QtnNaR9lAUsvdB6OjIW/+5zWKGfNhCnSxY=
=PiAH
-----END PGP SIGNATURE-----

Closed
mikadoZero wrote 6 years ago
(name . Oleg Pykhalov)(address . go.wigust@gmail.com)(address . 34719-done@debbugs.gnu.org)
k1h4u948.fsf@yandex.com
Oleg Pykhalov writes:

Toggle quote (6 lines)
> Hi mikadoZero,
>
> Thank you for the report.
>
> You could try ‘guix reconfigure’ after ‘guix pull’.

Thanks that fixes the error I was getting.

Do you think this failing test should be reported to it's upstream? I
looked at it's GitHub issues page. This failing test has not been
reported yet. When I was looking I think I saw that you had submitted
an issue for another failing test. That issue is still not resolved.
Closed
Oleg Pykhalov wrote 6 years ago
(name . mikadoZero)(address . mikadozero@yandex.com)(address . 34719-done@debbugs.gnu.org)
87pnqwvspa.fsf@gmail.com
mikadoZero <mikadozero@yandex.com> writes:

[…]

Toggle quote (5 lines)
> Do you think this failing test should be reported to it's upstream? I
> looked at it's GitHub issues page. This failing test has not been
> reported yet. When I was looking I think I saw that you had submitted
> an issue for another failing test. That issue is still not resolved.

I think we could be quite until the developer has a time to work on
emacs-json-reformat (until new commits appear in master branch or
another activity) as he mentioned in #33 issue. Failing tests are bad
but overall the program works good enough for users.

Oleg.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEcjhxI46s62NFSFhXFn+OpQAa+pwFAlyH/fEACgkQFn+OpQAa
+pxR4w/9GOooI6UvXU9Ou72yjnQj39Uyfjwp18o2xYFb8B9cBFOYC3nATbXhKTxC
5b/INqqLabQaYZ3hZA+fTQyAckzgej8dNDYfhnoiaFET8NBiYuoIbRH/kPi0l3MN
QNY84x51iQSwxSoPAmitXTIZdnuDfXXoIvcNxAPCRgIEhyt3m62cQ53L7QW+eZJj
p/E9Cv9EX0rL5ct/p8qW2eYNcKAeBhLvy2Dq7BUqRpPs2yRzYgsnm28FUybIsS5b
d6yGFL0Hzifr7d/qT2ODrAOEeqoi1Veu2npfS56CvoceSYcqAzfkec6fyi4Il9la
Umg2hgJvTixchdI8iPayytTmAZavOY1LEnueRPgtglvLeiq38FxhUfgG7a3Ynmuj
9GWN8YMEXWoMYOpuhghx/He6WYiFm2hkedY1/zeUx0CGcFLD56OTefkdWa/5daLU
Rp9n5wjtgqE3m22XSwFGYYtSO3EFHVWjTIf+mo0sq59Do/JXH8jGqCRaSSgSWqfb
iGYwfFiq7PLor7N4LNKondTpz+75Mt2QWRNQbRaFsPzzw1Mg8CX9g2XLwt6caIp6
NzGGXDcOaJ8tIxvZvMD3DbNyBbSd0Nof9HQjBtIg97dpeHtqDP35qXxx+LU018ax
QltxG9I4aVkBHmoFWSQ76ukzFqzmur59HKxzL/RW8zWn/6/qF8w=
=DI4Q
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34719@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34719
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help