[PATCH] gnu: ocaml-menhir: Update to 20181113.

  • Done
  • quality assurance status badge
Details
4 participants
  • Gabriel Hondet
  • Julien Lepiller
  • Leo Famulari
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Gabriel Hondet
Severity
normal

Debbugs page

Gabriel Hondet wrote 6 years ago
(address . guix-patches@gnu.org)
87d0ni28fk.fsf@gmail.com
* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
---
gnu/packages/ocaml.scm | 32 +++++++++++++++++++-------------
1 file changed, 19 insertions(+), 13 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9a807a4cb6..31e9a697a2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -639,37 +639,43 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20161115")
+ (version "20181113")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://gallium.inria.fr/~fpottier/menhir/"
- "menhir-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/menhir.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
- (build-system gnu-build-system)
- (inputs
- `(("ocaml" ,ocaml)))
+ "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+ (build-system ocaml-build-system)
(native-inputs
`(("ocamlbuild" ,ocamlbuild)))
(arguments
- `(#:parallel-build? #f ; Parallel build causes failure
- #:tests? #f ; No check target
+ `(#:tests? #f ; No check target
#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(setenv "PREFIX" out))
+ #t))
+ (replace 'build
+ (lambda _
+ (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
+ #t))
+ (replace 'install
+ (lambda _
+ (invoke "make" "-f" "Makefile" "install")
#t)))))
(properties
`((ocaml4.02-variant . ,(delay ocaml4.02-menhir))))
- (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar
specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml. It is based on
Knuth’s LR(1) parser construction technique.")
;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
;; that have an *.ml or *.mli extension are GPL licensed. All other files
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlxxCc8ACgkQMbyBBfZZ
1CXiSw/6AnBEP/lGCdUsZJcHyW4xIaqN/seNJtoQ8KDEhNBQE8j93yFM0yjBCJA7
IeEyR1PHdLoTRBfcndOk8JDjTEAl1J2PCbk/SJNh/1wZWJLXRISb1RU2U6YLwCtA
HZzbIhYshzim8VBiENOx5H+DKjbTSRSidL4ATw/JkvJW94dyMbMFkOJgZiKgdr2/
KIOpzW3GQinNLbkwy14qIAW/c1eA2heFXRVASfUw+AECo8mkm7+ymHH5E9fmOKUU
/lClCJzfWizsp9ZCAKOjXovkkBLVooGhXdRp9iLKiuzc9ihh5rUi1i2LpyrCQlNg
aBJU96aXKk4Fi9Ta4D+/Gw57Cjyd+hPM1vegU2lkxohMVFTZ25To812NZ1ij6hIJ
wbH0oFwiFzWCo4mBbt8gtavSYNNJgPg0+UKMrrgJMJgwI5WD7bT/JxFNaJsMFykR
U71+kKXyj4fqj1Addp1y9dutceohKSywczx2GQehvDskn0ZbrbPp5uEMFbOqM4V0
ggqoL4GYVNW35JAjRZCjcP/G68gLGNrJVnuzmP76Jp2KzZz3ZaQKZXyDkb6bUsyo
d2ivFzvqaeaM0IBLSfMRzASJ17vC4VmYpnMkY8/qVznryvlOwAr92jG9AYlZh7GT
GKzupcOqzMtEu6H+48XHjp4GTr8QhkBmjOdrY5lZDlsaJ6wDWmc=
=yH1k
-----END PGP SIGNATURE-----

Leo Famulari wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34627@debbugs.gnu.org)
20190226035851.GA8289@jasmine.lan
On Sat, Feb 23, 2019 at 09:50:38AM +0100, Gabriel Hondet wrote:
Toggle quote (2 lines)
> * gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.

Thanks!

Toggle quote (9 lines)
> + (replace 'build
> + (lambda _
> + (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
> + #t))
> + (replace 'install
> + (lambda _
> + (invoke "make" "-f" "Makefile" "install")
> #t)))))

Can you add comments explaining why these phases are replaced?
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlx0uW4ACgkQJkb6MLrK
fwgiRxAAvj42oNVZqzQo0mNdjhzxjNNQuui7yFGmlT8e2OH7y/hyyKDfwqy57S7T
gSRlGJKaRm+sMeWKzapiQoN2tTVy5/2e/9G8n4e/Ci25bBaTluqxWTZhxL6d93fX
7rEPWt3bcTCRQMZm9dqA5xxtzQIU8u0A7MAwloED4v5F5Wfg432qTfvod/Q4ZzeC
7j9fmbVytJ8dobqopS7P3rSpAjos2/jJJ2W4oEUlWR7uk1fXxhVQpGYCyJ9WLLrN
BCQZs/Zb3tW0hQSf3rMu0hb9WdZfhjqTWZASX0bv8DuaMSFITkcwkEiFRder8gnM
9EZST3F9X/f0QRmCBQu2IGsWj/LN2naOk89FccIATcyQU4tb7LFShDdTZohjfzS2
/7uGjXdCrFDuTj+vhsAKTpzrOhnLrBCXUaWpMX5ZEM1mf2r4XMU9KyYnFkxX/oWD
PG/AMyKLLfT8TEWgUC8v3GA6BliXcMQ/AGqQoIbyV4kpMB+y8XbFsnYIqpR7OotX
cv2F+zkat7V6oin48SbKcDfNRHcM5PN0gXIdb4zEm8U88L2oq3VaP4enZq+XNsuu
SpqbDwMPqx/+s6ply8OSWkguQ3PpSw8A3AUmPZK5gDm6j546/798H3CQJXR3FJNo
nAHg/VpBVBqXsZU+7TbasezWQUi5c2fBX8o8Y8WFz+QMOs1KQkg=
=XMzJ
-----END PGP SIGNATURE-----


Gabriel Hondet wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 34627@debbugs.gnu.org)
87zhp31qu1.fsf@gmail.com
Hi Leo,

Toggle quote (1 lines)
> Can you add comments explaining why these phases are replaced?
From dde2129019d0490909e764181b1f332c3faefa5f Mon Sep 17 00:00:00 2001
From: gabrielhdt <gabrielhondet@gmail.com>
Date: Sat, 23 Feb 2019 09:50:38 +0100
Subject: [PATCH] gnu: ocaml-menhir: Update to 20181113.

* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
---
gnu/packages/ocaml.scm | 34 +++++++++++++++++++++-------------
1 file changed, 21 insertions(+), 13 deletions(-)

Toggle diff (65 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9a807a4cb6..0ad33f6b25 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -639,37 +639,45 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20161115")
+ (version "20181113")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://gallium.inria.fr/~fpottier/menhir/"
- "menhir-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/menhir.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
- (build-system gnu-build-system)
- (inputs
- `(("ocaml" ,ocaml)))
+ "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+ (build-system ocaml-build-system)
(native-inputs
`(("ocamlbuild" ,ocamlbuild)))
(arguments
- `(#:parallel-build? #f ; Parallel build causes failure
- #:tests? #f ; No check target
+ `(#:tests? #f ; No check target
#:phases
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(setenv "PREFIX" out))
+ #t))
+ (replace 'build
+ (lambda _
+ ;; invoke the right makefile
+ (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
+ #t))
+ (replace 'install
+ (lambda _
+ ;; invoke the right makefile
+ (invoke "make" "-f" "Makefile" "install")
#t)))))
(properties
`((ocaml4.02-variant . ,(delay ocaml4.02-menhir))))
- (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar
specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml. It is based on
Knuth’s LR(1) parser construction technique.")
;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
;; that have an *.ml or *.mli extension are GPL licensed. All other files
--
2.21.0
Sorry for taking so long!

Gabriel
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlyoYuYACgkQMbyBBfZZ
1CUOUQ//VryMow8jVQsMZBOPguO+ta4mjwgo24w+jrBv74p6FJ7Xz7OnOKBY1Llo
XuJ+v8iLY63oJiz2ip6ICoqa4JKe+uQVGha/L2me+D3bXXFJ7hGCi0ZD8D/b8d9g
4pB0/FUCTEwJt9GzldOIDGkUJbGpTBasleZww23Tg/+qJ4Xwg1YZgQmF96+u/zR9
OnK0dcPBwcCHGOGZ2zvqJNdSYDoxOugicykYWHfqhwACrTXtRU5ibEtavk2kHOJI
/C7bqKhSTWFhYEk9/5cs9lwWL1uzBeYptBGaNU24z7GUqqPhE65sDOXDnWdiej3q
pVOAlvH/Kjhw4xSCKCLIhH3bTIEIx1/GE8xN57/m6Hg6KafAA2+tdhwS/imThNcv
EyabmgDQ8YIPM56F2dc6euxW35cVF7kkZi6jEOBYiwKQ1RJeRn4dX5PytCvr9oIs
hK52tjFbr0BqR5Q5GSeJeN7d31nMW1aGwMvK9de0CTUaFHDx5OMu/wam/RZe3XJw
Ct4c4Rps6urspkA/4J0SMwSLdKWXcTULEd8JqVv0xEHlP64tTw/08fMuOh/1syk6
O/RMApup+Fw0LfTEg0EvKCGr8l+c4GuKEfStkCoEKpL7IVLXQZB1fz8rR0okjToT
9XIt1WpG5Pdmfz9ZXlaW5zhPYunsNKV+jjo8viTpeoBwP5Z2NzY=
=3Pua
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)
87ef6cfwv7.fsf@elephly.net
Hi Gabriel,

Toggle quote (62 lines)
>> Can you add comments explaining why these phases are replaced?
> From dde2129019d0490909e764181b1f332c3faefa5f Mon Sep 17 00:00:00 2001
> From: gabrielhdt <gabrielhondet@gmail.com>
> Date: Sat, 23 Feb 2019 09:50:38 +0100
> Subject: [PATCH] gnu: ocaml-menhir: Update to 20181113.
>
> * gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
> ---
> gnu/packages/ocaml.scm | 34 +++++++++++++++++++++-------------
> 1 file changed, 21 insertions(+), 13 deletions(-)
>
> diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
> index 9a807a4cb6..0ad33f6b25 100644
> --- a/gnu/packages/ocaml.scm
> +++ b/gnu/packages/ocaml.scm
> @@ -639,37 +639,45 @@ Emacs.")
> (define-public ocaml-menhir
> (package
> (name "ocaml-menhir")
> - (version "20161115")
> + (version "20181113")
> (source (origin
> - (method url-fetch)
> - (uri (string-append
> - "http://gallium.inria.fr/~fpottier/menhir/"
> - "menhir-" version ".tar.gz"))
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://gitlab.inria.fr/fpottier/menhir.git")
> + (commit version)))
> + (file-name (git-file-name name version))
> (sha256
> (base32
> - "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
> - (build-system gnu-build-system)
> - (inputs
> - `(("ocaml" ,ocaml)))
> + "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
> + (build-system ocaml-build-system)
> (native-inputs
> `(("ocamlbuild" ,ocamlbuild)))
> (arguments
> - `(#:parallel-build? #f ; Parallel build causes failure
> - #:tests? #f ; No check target
> + `(#:tests? #f ; No check target
> #:phases
> (modify-phases %standard-phases
> (replace 'configure
> (lambda* (#:key outputs #:allow-other-keys)
> (let ((out (assoc-ref outputs "out")))
> (setenv "PREFIX" out))
> + #t))
> + (replace 'build
> + (lambda _
> + ;; invoke the right makefile
> + (invoke "make" "-f" "Makefile" "USE_OCAMLFIND=true" "all")
> + #t))
> + (replace 'install
> + (lambda _
> + ;; invoke the right makefile
> + (invoke "make" "-f" "Makefile" "install")

Is the problem here that GNUmakefile exists? Could we simply remove
that file instead of replacing the phases? When replacing the phases
you should also pass the default make-flags and ensure that parallel
building is enabled.

Removing the other makefile seems to be the better option.

--
Ricardo
Gabriel Hondet wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87y34h23aa.fsf@gmail.com
Hi Ricardo,

On Mon 08 Apr 2019 at 15:30 Ricardo Wurmus wrote:

Toggle quote (10 lines)
> Hi Gabriel,
>
>
> Is the problem here that GNUmakefile exists? Could we simply remove
> that file instead of replacing the phases? When replacing the phases
> you should also pass the default make-flags and ensure that parallel
> building is enabled.
>
> Removing the other makefile seems to be the better option.

Yes it was, but after inspecting downloaded sources, I realised that
there was no GNUmakefile, so I removed all the -f business, and it
works.
From f6d25b84679aeb0705e930abad79397d739bf39c Mon Sep 17 00:00:00 2001
From: gabrielhdt <gabrielhondet@gmail.com>
Date: Sat, 23 Feb 2019 09:50:38 +0100
Subject: [PATCH] gnu: ocaml-menhir: Update to 20181113.

* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
---
gnu/packages/ocaml.scm | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9a807a4cb6..79dbe68066 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -639,23 +639,23 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20161115")
+ (version "20181113")
(source (origin
- (method url-fetch)
- (uri (string-append
- "http://gallium.inria.fr/~fpottier/menhir/"
- "menhir-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/menhir.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
- (build-system gnu-build-system)
- (inputs
- `(("ocaml" ,ocaml)))
+ "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+ (build-system ocaml-build-system)
(native-inputs
- `(("ocamlbuild" ,ocamlbuild)))
+ `(("ocamlbuild" ,ocamlbuild)
+ ("ocaml-findlib" ,ocaml-findlib)))
(arguments
- `(#:parallel-build? #f ; Parallel build causes failure
- #:tests? #f ; No check target
+ `(#:tests? #f ; No check target
+ #:make-flags (list "USE_OCAMLFIND=true")
#:phases
(modify-phases %standard-phases
(replace 'configure
@@ -665,11 +665,11 @@ Emacs.")
#t)))))
(properties
`((ocaml4.02-variant . ,(delay ocaml4.02-menhir))))
- (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar
specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml. It is based on
Knuth’s LR(1) parser construction technique.")
;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
;; that have an *.ml or *.mli extension are GPL licensed. All other files
--
2.21.0
Gabriel
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlyuI90ACgkQMbyBBfZZ
1CV0QA/+Krf9a0b1frzAninrGvPbsDi9SUOf+e3FcYlSvQrylaDpb1aQITjnO42j
vWogwEWyVNtIBSS96gVZ1EtUpKE/KLT7zF9JSiz6uGCW/tuIhkWfR7xEv6uaWXNJ
PnmR9pYMn992Ks682nXiorHUb26Ju+TsCfbHmCj7h02Rma1wT7cJ0LZWQfySF4Hk
VlCtlIyvAaNJ0wqGyH/QF4pLstWfQhCtH/zwHESkaI3LWMp7fsvGWrGaoq90jHas
Tqz/rGoULxtOFiqfpI7xvzQO25AYT/dal7TiQF01BHQyAaVEGh3kk295rusNiHxr
FwzMW8M3eGjSDw8fp7oc7qeAgycD0uQ1pMC8mb0aja/7Kc70jTCt+hldY2eEi/kK
Qy6hb3jFeRqw0LonI+JzQOJHrHED9HomaZFyr+OhrBy9J/oBVeHANs/piiAs/q3w
BR+u3dnVNlxIIUJkshpJyeEWr7OOeype3IguvW2EeZwGpobQjQoQbuq+t+34I1wk
6L7EDZN2WA/g5tQ3RU99nRTMmsIgor9L3y8PtENKKL6dDFbJ10/E4/j8VC9Q4Hse
j2jsylRTg3qTACi2Gm9ijlXSIMcqfAVEa5+osgDstI6QKLcx69S0F+QF5U+v7Vgb
+gDva1h1SAm8Zh6JdxhGeQATVZmn9fA+pD/jmZClp8AcDb9p1Xk=
=4A3M
-----END PGP SIGNATURE-----

Gabriel Hondet wrote 6 years ago
[PATCH] gnu: ocaml-menhir: Update to 20181113.
(address . 34627@debbugs.gnu.org)
87zho3xuf9.fsf@gmail.com
Hi everyone,

I submit back a patch which seems to have been forgotten. It has
been revised.

Cheers,

Gabriel
From 00f2ab14431a9e95cea9ae9e6e8dca974fbd53b7 Mon Sep 17 00:00:00 2001
From: gabrielhdt <gabrielhondet@gmail.com>
Date: Fri, 3 May 2019 20:25:04 +0200
Subject: [PATCH] gnu: ocaml-menhir: Update to 20181113.

* gnu/packages/ocaml.scm (ocaml-menhir): Update to 20181113.
---
gnu/packages/ocaml.scm | 34 ++++++++++++++++------------------
1 file changed, 16 insertions(+), 18 deletions(-)

Toggle diff (58 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 33acbbec4e..6e69be3f19 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -756,35 +756,33 @@ Emacs.")
(define-public ocaml-menhir
(package
(name "ocaml-menhir")
- (version "20161115")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://gallium.inria.fr/~fpottier/menhir/"
- "menhir-" version ".tar.gz"))
- (sha256
- (base32
- "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
- (build-system gnu-build-system)
+ (version "20181113")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/fpottier/menhir.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1iqdf64ayq4s3d9jkwhs3s8wqc2s48b292hp0kcjsskfhcvwg0kr"))))
+ (build-system ocaml-build-system)
(inputs
`(("ocaml" ,ocaml)))
(native-inputs
`(("ocamlbuild" ,ocamlbuild)))
(arguments
- `(#:parallel-build? #f ; Parallel build causes failure
+ `(#:make-flags `("USE_OCAMLFIND=true"
+ ,(string-append "PREFIX=" (assoc-ref %outputs "out")))
#:tests? #f ; No check target
#:phases
(modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (setenv "PREFIX" out))
- #t)))))
- (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (delete 'configure))))
+ (home-page "http://gallium.inria.fr/~fpottier/menhir/")
(synopsis "Parser generator")
(description "Menhir is a parser generator. It turns high-level grammar
specifications, decorated with semantic actions expressed in the OCaml
-programming language into parsers, again expressed in OCaml. It is based on
+programming language into parsers, again expressed in OCaml. It is based on
Knuth’s LR(1) parser construction technique.")
;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
;; that have an *.ml or *.mli extension are GPL licensed. All other files
--
2.21.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5ercJXBcjd3P1FcAMbyBBfZZ1CUFAlzMiLoACgkQMbyBBfZZ
1CWXGg/6A2Rx8W/1j5yd19jUOxgJZsLJa79+Ikhm7K+4yupJbCSXphpmTsYaM/9b
cUmiGK8DR9OpkqpMGiOAVW2MgZWQYRDTT/9MK3qM2X9I/YVmsc8ZmCnBjGFB+M+H
MHMobzSwKzHBGspSI87c9FSVv3vul8J7gX2KRTfY2e0t0tb8BB4PfNmUx/WH+mkA
VCMxeJePuxMRLuJwL+gvNKbzfxM7irb5Rh1gcg5D7mglMOkA/4vuBCLPYuv2cXiI
fuAaLGi4nRlOU5B4yPadNRP9jTWTU7+GT6vipIWbKkhnyYV+6XBjFVJ/6Tj8uqM/
ljMIKD/U+c9KzJF6UyvtJxawkD+F1dKoWLOVHAt8dSj1oe3MqH5WLU49B6qRTAXi
3+gtlTumMaQil2f6AByLdjEVSGbGUcbtglN1ZF0CT3ITbI39RmAE11XhqpDxIxg5
/snnHWQqs7OBsgefaelZ3Ra8LquONQQfoEhovnpGh4TIQrEPFXq/sjLkdmCBhmYG
kHvjfNAXTu6iB3uBdohrAI0cthJUsqf64SohqZbnm4UOX4/tt86HVq8BElx/s/PA
MmQOpaDi4dR7IW/PI4025KXi1qbSdHlYda31bCv0IRfgiX/CeGLdsoNrhY2YB+qg
PVH7nGAsFzFeMNHJQcyNbUv7U+a97cyQrPX8F/wCWwFdd0iPafI=
=OKM1
-----END PGP SIGNATURE-----

Julien Lepiller wrote 6 years ago
(name . Gabriel Hondet)(address . gabrielhondet@gmail.com)(address . 34627-done@debbugs.gnu.org)
20190503204859.325aa280@sybil.lepiller.eu
Le Fri, 03 May 2019 20:30:18 +0200,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

Toggle quote (9 lines)
> Hi everyone,
>
> I submit back a patch which seems to have been forgotten. It has
> been revised.
>
> Cheers,
>
> Gabriel

Hi, sorry for the delay! it's finally pushed as
187f9636f176d62bf869b787ad410e3a528aa1a0. Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34627@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34627
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help