Paul Garlick wrote 6 years ago
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
* gnu/packages/simulation.scm (python-fenics-dijitso)[arguments]: Skip
parallel tests.
---
gnu/packages/simulation.scm | 5 +++++
1 file changed, 5 insertions(+)
Toggle diff (18 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 20b62f3..3637cc3 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -268,6 +268,11 @@ problems for efficient solution on parallel systems.")
(setenv "PYTHONPATH"
(string-append (getcwd) ":" (getenv "PYTHONPATH")))
(with-directory-excursion "test"
+ ;; Disable parallel tests to avoid race condition. See
+ ;; https://github.com/pytest-dev/pytest-cov/issues/237.
+ (substitute* "runtests.sh"
+ (("for p in 1 4 8 16; do")
+ "for p in 1; do"))
(invoke "./runtests.sh"))
#t)))))
(home-page "https://bitbucket.org/fenics-project/dijitso/")
--
1.8.3.1