[PATCH] gnu: python-fenics-dijitso: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Paul Garlick
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Paul Garlick
Severity
normal

Debbugs page

Paul Garlick wrote 6 years ago
(address . guix-patches@gnu.org)(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)
1550664967-441-1-git-send-email-pgarlick@tourbillion-technology.com
* gnu/packages/simulation.scm (python-fenics-dijitso)[arguments]: Skip
parallel tests.
---
gnu/packages/simulation.scm | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 20b62f3..3637cc3 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -268,6 +268,11 @@ problems for efficient solution on parallel systems.")
(setenv "PYTHONPATH"
(string-append (getcwd) ":" (getenv "PYTHONPATH")))
(with-directory-excursion "test"
+ ;; Disable parallel tests to avoid race condition. See
+ ;; https://github.com/pytest-dev/pytest-cov/issues/237.
+ (substitute* "runtests.sh"
+ (("for p in 1 4 8 16; do")
+ "for p in 1; do"))
(invoke "./runtests.sh"))
#t)))))
(home-page "https://bitbucket.org/fenics-project/dijitso/")
--
1.8.3.1
Ricardo Wurmus wrote 6 years ago
(name . Paul Garlick)(address . pgarlick@tourbillion-technology.com)(address . 34592-done@debbugs.gnu.org)
87d0nm5h3r.fsf@elephly.net
Paul Garlick <pgarlick@tourbillion-technology.com> writes:

Toggle quote (23 lines)
> * gnu/packages/simulation.scm (python-fenics-dijitso)[arguments]: Skip
> parallel tests.
> ---
> gnu/packages/simulation.scm | 5 +++++
> 1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
> index 20b62f3..3637cc3 100644
> --- a/gnu/packages/simulation.scm
> +++ b/gnu/packages/simulation.scm
> @@ -268,6 +268,11 @@ problems for efficient solution on parallel systems.")
> (setenv "PYTHONPATH"
> (string-append (getcwd) ":" (getenv "PYTHONPATH")))
> (with-directory-excursion "test"
> + ;; Disable parallel tests to avoid race condition. See
> + ;; https://github.com/pytest-dev/pytest-cov/issues/237.
> + (substitute* "runtests.sh"
> + (("for p in 1 4 8 16; do")
> + "for p in 1; do"))
> (invoke "./runtests.sh"))
> #t)))))
> (home-page "https://bitbucket.org/fenics-project/dijitso/")

I wondered if we could use the #:parallel-tests? argument instead, but
the python-build-system does not support it. This approach looks fine
to me.

Thanks!

I pushed it to the master branch with commit 7a82074ca6.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34592@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34592
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help