[PATCH 3/3] gnu: Add emacs-lsp-ui.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
87sgwjt8e3.fsf@posteo.net
From a74523d0942cea6efb45eee3acd5e5609cb340c9 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Tue, 19 Feb 2019 22:01:22 -0600
Subject: [PATCH 3/3] gnu: Add emacs-lsp-ui.

* gnu/packages/emacs-xyz.scm (emacs-lsp-ui): New variable.
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 51a3060a7..3bd15e795 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13186,3 +13186,29 @@ experience by providing optional integration with other popular Emacs packages
like @code{company}, @code{flycheck}, and @code{projectile}.")
(license license:gpl3+)))
+(define-public emacs-lsp-ui
+ (package
+ (name "emacs-lsp-ui")
+ (version "6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/lsp-ui.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1r4327fd8cvjxfwkddp5c4bdskyncbs4sx9m3z2w4d773y2jrakc"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-lsp-mode" ,emacs-lsp-mode)
+ ("emacs-markdown-mode" ,emacs-markdown-mode)
+ ("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://github.com/emacs-lsp/lsp-ui")
+ (synopsis "User interface extensions for @code{lsp-mode}")
+ (description
+ "@code{LSP-ui} contains several enhancements and integrations for
+@code{lsp-mode}, such as visual flychecking, displaying references in-line,
+and code peeking.")
+ (license license:gpl3+)))
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34587-done@debbugs.gnu.org)
87ef793fep.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (7 lines)
> From a74523d0942cea6efb45eee3acd5e5609cb340c9 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Tue, 19 Feb 2019 22:01:22 -0600
> Subject: [PATCH 3/3] gnu: Add emacs-lsp-ui.
>
> * gnu/packages/emacs-xyz.scm (emacs-lsp-ui): New variable.

Thanks. I pushed it to the master branch with commit 209393a003.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34587@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34587
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help