[PATCH 2/3] gnu: Add emacs-lsp-mode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
87pnrnt8dm.fsf@posteo.net
From c42ae1190500facb94ca1a2ddd253fabc93ca0aa Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Tue, 19 Feb 2019 22:01:06 -0600
Subject: [PATCH 2/3] gnu: Add emacs-lsp-mode.

* gnu/packages/emacs-xyz.scm (emacs-lsp-mode): New variable.
---
gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0bea870e6..51a3060a7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13158,3 +13158,31 @@ opposed to character-based).")
view of file listings sorted by size. Directory sizes are computed
recursively. The results are cached for speed.")
(license license:gpl3+)))
+
+(define-public emacs-lsp-mode
+ (package
+ (name "emacs-lsp-mode")
+ (version "6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-lsp/lsp-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1v1mq6ixzlgiazj8fmg4xaqhsqn3l89iqy74yndhvzh2rdf0pbkl"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)
+ ("emacs-ht" ,emacs-ht)
+ ("emacs-spinner" ,emacs-spinner)))
+ (home-page "https://github.com/emacs-lsp/lsp-mode")
+ (synopsis "Emacs client and library for the Language Server Protocol")
+ (description "@code{LSP-mode} is a client and library implmentation for
+the Language Server Protocol. This mode aims to provide an IDE-like
+experience by providing optional integration with other popular Emacs packages
+like @code{company}, @code{flycheck}, and @code{projectile}.")
+ (license license:gpl3+)))
+
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34585-done@debbugs.gnu.org)
87ftrp3fih.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (7 lines)
> From c42ae1190500facb94ca1a2ddd253fabc93ca0aa Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Tue, 19 Feb 2019 22:01:06 -0600
> Subject: [PATCH 2/3] gnu: Add emacs-lsp-mode.
>
> * gnu/packages/emacs-xyz.scm (emacs-lsp-mode): New variable.

Thanks. I pushed this to the master branch with commit 60adaae0cf.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34585@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34585
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help