[PATCH] services: desktop: Fix define for the upower-service procedure.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Christopher Baines
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190219205426.29447-1-mail@cbaines.net
* gnu/services/desktop.scm (upower-service): Fill in the replacement for
upower-service.
---
gnu/services/desktop.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index ce63969dc8..7940f28a26 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -306,6 +306,7 @@ used by GNOME.")
(time-critical 300)
(time-action 120)
(critical-power-action 'hybrid-sleep))
+ upower-service-type
"Return a service that runs @uref{http://upower.freedesktop.org/,
@command{upowerd}}, a system-wide monitor for power consumption and battery
levels, with the given configuration settings. It implements the
--
2.20.1
Christopher Baines wrote 6 years ago
Re: bug#34567: Bogus 'upower-service' deprecation message
(name . Mark H Weaver)(address . mhw@netris.org)
87ftsjh4a8.fsf@cbaines.net
Mark H Weaver <mhw@netris.org> writes:

Toggle quote (12 lines)
> My OS config includes a reference to 'upower-service', which is now
> deprecated, but the deprecation message is bogus:
>
> mhw@jojen ~$ guix system build /etc/config.scm --verbosity=1
> /etc/config.scm:149:19: warning: 'slim-service' is deprecated, use 'slim-service-type' instead
> /etc/config.scm:156:19: warning: 'upower-service' is deprecated, use 'Return a service that runs @uref{http://upower.freedesktop.org/,
> @command{upowerd}}, a system-wide monitor for power consumption and battery
> levels, with the given configuration settings. It implements the
> @code{org.freedesktop.UPower} D-Bus interface, and is notably used by GNOME.' instead
> building /gnu/store/nwdjz1mkvcc4ic65mgw5i94ig3qzp8kf-libjpeg-turbo-2.0.2.tar.gz.drv...
> [...]

Haha, that is quite bogus. I didn't realise define-deprecated took two
arguments. I've sent a patch to fix this here [1].

-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxscQ9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcgEA//dkNDv91YnLPfn9W3nP42ekaH+Zb9JAEiD5I3n3AjdZHztNsi5p+qhqUv
01U9OtiMEEHAu4U4AZQZJpXXJUctNIt58AVKJ72iGbEA/vTR6/bcW8r4zu0fg4u3
yFGqY9pnmS7e3mW3LoCXJu2HJpUhDBGo3HEpycO6ofJZsrLYJz9xikXy4QVBkNSC
TZkizc6lsUsvb5jR5QLiGtgjhWcD97oEZ0Vu37cXaERWgcWxKKqC922KAcd/nrCf
ju0jj3VQHRAAJVSZEMpdGGPbIDaNqkcGJNzhvTXVkQyAWPm3TS2beDU5xkFU5tQu
7wlzDsdCY9SUaDfLshVW+ukt8K1QyWRb0u5YGf9m6YJ7jL5V276cjV5tBtJAG+as
djZD8TMeroC5thRjN+aLiMF03LxSgF3JzT4VXFic0zaZ/Hlui7vgB8oiWz4rJnKT
BKOmWA/j1WOP614MEMb9hwIvLFSGIXNJkGkE3BCe/YZ0Gv/YBM8iiFzR3TWdgRG1
Kqe3bUlvJG3T5rcXGgq25OoOndon/U+OsX+3kjDIoUM/audjq0wAPQC+0e5VFYfw
Lopd38bvGiNJC7ix7o0gvTVZCTfOdiQSzCO9sqHCeExFsah2lu21dhWnYZRqjRgp
ikh9Fnvmbtq16lJR5hqLe2vva81vJ8okXgeylt+8SRoMSb8jsvo=
=aj5h
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 6 years ago
Re: [bug#34579] [PATCH] services: desktop: Fix define for the upower-service procedure.
(name . Christopher Baines)(address . mail@cbaines.net)(address . 34579@debbugs.gnu.org)
87pnrmu0wr.fsf@elephly.net
Christopher Baines <mail@cbaines.net> writes:

Toggle quote (19 lines)
> * gnu/services/desktop.scm (upower-service): Fill in the replacement for
> upower-service.
> ---
> gnu/services/desktop.scm | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
> index ce63969dc8..7940f28a26 100644
> --- a/gnu/services/desktop.scm
> +++ b/gnu/services/desktop.scm
> @@ -306,6 +306,7 @@ used by GNOME.")
> (time-critical 300)
> (time-action 120)
> (critical-power-action 'hybrid-sleep))
> + upower-service-type
> "Return a service that runs @uref{http://upower.freedesktop.org/,
> @command{upowerd}}, a system-wide monitor for power consumption and battery
> levels, with the given configuration settings. It implements the

Looks fine to me. Thanks!

--
Ricardo
Christopher Baines wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 34579-done@debbugs.gnu.org)
871s3whn5s.fsf@cbaines.net
Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (23 lines)
> Christopher Baines <mail@cbaines.net> writes:
>
>> * gnu/services/desktop.scm (upower-service): Fill in the replacement for
>> upower-service.
>> ---
>> gnu/services/desktop.scm | 1 +
>> 1 file changed, 1 insertion(+)
>>
>> diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
>> index ce63969dc8..7940f28a26 100644
>> --- a/gnu/services/desktop.scm
>> +++ b/gnu/services/desktop.scm
>> @@ -306,6 +306,7 @@ used by GNOME.")
>> (time-critical 300)
>> (time-action 120)
>> (critical-power-action 'hybrid-sleep))
>> + upower-service-type
>> "Return a service that runs @uref{http://upower.freedesktop.org/,
>> @command{upowerd}}, a system-wide monitor for power consumption and battery
>> levels, with the given configuration settings. It implements the
>
> Looks fine to me. Thanks!

Great, I've pushed this to master now as
bb65f66ce0e5feee2d997a8526e10fc9f31e97fd.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAlxzEX9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XeyKw/+ILJYs+wx3jw7E+gd3zaxI39BCEUM5wdbCVrLt6a/D+rz/w99znlJEMal
Tr9quFYTb2x1KSpdbuGYwv7X2G9E3hCEzAQAdrwo6B1JChhxZOpJDAiaZ+tBiN4X
980aB1jXlp47IZ/j+TmX8Bt9KFiwZwEbioxKLkcNr+ZakzP7qDWK+5nJY4S0c9BW
GzEmxUwESvE5ipnFIQbnmTcdYF4h7hpMiQ34N4I3FS0KHJV1JKSTzodkYUtxiLCb
pvRfHeQKFpLTATdx7vyRe2QZ07bKDZCMPk68G6+PkaNhZnamgftHn1TY2cB9onyC
CH7RTfaOrAoPIF+aje4ut5HcjieSyQiJov4KRPYHZD8GhvzhgzB85jy3XhwIFM7A
Ryx8LWeSEYhUWWVyA1mI7JF61xCaei9YiKcUo2wESu/ICzALlIi1yfE12QiItdeq
LiFshw2n5K0nEzWLL5vLPhz+O1JOTaNDHHE3BFhUXwovYd3hLYIDjEm0Rq7ZL3dZ
O0Oa6wJSD8A8hreTwOp30enVOXE2NvQuPyRhoIwIu71sVRakPUCNzLdzvSLFeqwK
wEGSwN0yWjd24Zty3/5OI3GTXec1TogH5RV6V1LHLqpL8xxSmZ1t3+VFfY84MHWy
ybxKI9H41MHtsTljKzSJKVzXyJLwh2CARmXuUEGLg2PqJbn0q1I=
=wCv4
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 6 years ago
Re: bug#34567: Bogus 'upower-service' deprecation message
(name . Christopher Baines)(address . mail@cbaines.net)
875zsr6gwc.fsf@gnu.org
Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (19 lines)
> Mark H Weaver <mhw@netris.org> writes:
>
>> My OS config includes a reference to 'upower-service', which is now
>> deprecated, but the deprecation message is bogus:
>>
>> mhw@jojen ~$ guix system build /etc/config.scm --verbosity=1
>> /etc/config.scm:149:19: warning: 'slim-service' is deprecated, use 'slim-service-type' instead
>> /etc/config.scm:156:19: warning: 'upower-service' is deprecated, use 'Return a service that runs @uref{http://upower.freedesktop.org/,
>> @command{upowerd}}, a system-wide monitor for power consumption and battery
>> levels, with the given configuration settings. It implements the
>> @code{org.freedesktop.UPower} D-Bus interface, and is notably used by GNOME.' instead
>> building /gnu/store/nwdjz1mkvcc4ic65mgw5i94ig3qzp8kf-libjpeg-turbo-2.0.2.tar.gz.drv...
>> [...]
>
> Haha, that is quite bogus. I didn't realise define-deprecated took two
> arguments. I've sent a patch to fix this here [1].
>
> 1: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=34579

This was fixed in bb65f66ce0e5feee2d997a8526e10fc9f31e97fd, closing!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34579@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34579
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help