Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
From 6361e6261418533d1d1ec0d32b5d11470bd77a14 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 21:20:02 -0600
Subject: [PATCH 19/24] gnu: Add r-furrr.
* gnu/packages/cran.scm (r-furrr): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)
Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6709130b4..e36c1c4cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6864,6 +6864,33 @@ It also implements functions for text cleaning, such as accentuation
removal.")
(license license:expat)))
+(define-public r-furrr
+ (package
+ (name "r-furrr")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "furrr" version))
+ (sha256
+ (base32
+ "1ld9aa9hydna94hgm6p91zjbfv1dz1vsgchjlpknkg6irbvkfafx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-future" ,r-future)
+ ("r-globals" ,r-globals)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)))
+ (home-page
+ "https://github.com/DavisVaughan/furrr")
+ (synopsis
+ "Apply Mapping Functions in Parallel using Futures")
+ (description
+ "Implementations of the family of map() functions from @code{purrr} that
+can be resolved using any @code{future}-supported backend, e.g. parallel on
+the 1local machine or distributed on a compute cluster.")
+ (license license:lgpl2.1+)))
+
(define-public r-abnormality
(package
(name "r-abnormality")
--
2.20.1