[PATCH 19/24] gnu: Add r-furrr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
87bm38wih9.fsf@posteo.net
From 6361e6261418533d1d1ec0d32b5d11470bd77a14 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 21:20:02 -0600
Subject: [PATCH 19/24] gnu: Add r-furrr.

* gnu/packages/cran.scm (r-furrr): New variable.
---
gnu/packages/cran.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6709130b4..e36c1c4cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6864,6 +6864,33 @@ It also implements functions for text cleaning, such as accentuation
removal.")
(license license:expat)))
+(define-public r-furrr
+ (package
+ (name "r-furrr")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "furrr" version))
+ (sha256
+ (base32
+ "1ld9aa9hydna94hgm6p91zjbfv1dz1vsgchjlpknkg6irbvkfafx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-future" ,r-future)
+ ("r-globals" ,r-globals)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)))
+ (home-page
+ "https://github.com/DavisVaughan/furrr")
+ (synopsis
+ "Apply Mapping Functions in Parallel using Futures")
+ (description
+ "Implementations of the family of map() functions from @code{purrr} that
+can be resolved using any @code{future}-supported backend, e.g. parallel on
+the 1local machine or distributed on a compute cluster.")
+ (license license:lgpl2.1+)))
+
(define-public r-abnormality
(package
(name "r-abnormality")
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34558-done@debbugs.gnu.org)
87mulx3fsp.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (7 lines)
> From 6361e6261418533d1d1ec0d32b5d11470bd77a14 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Mon, 18 Feb 2019 21:20:02 -0600
> Subject: [PATCH 19/24] gnu: Add r-furrr.
>
> * gnu/packages/cran.scm (r-furrr): New variable.

Meanwhile this has found its way into Guix with the last big mass
upgrade of CRAN and Bioconductor packages. Closing.

Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34558@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34558
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help