[PATCH 06/24] gnu: Add r-leaflet.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brett Gilio
  • Ricardo Wurmus
  • swedebugia
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
87a7isv3u9.fsf@posteo.net
From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 19:37:02 -0600
Subject: [PATCH 06/24] gnu: Add r-leaflet.

* gnu/packages/cran.scm (r-leaflet): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 44c8b0a99..1359a565f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6655,6 +6655,40 @@ in science, technology, engineering and mathematics will need in their
professional lives, but which are usually taught in isolation, if at all.")
(license license:gpl2+)))
+(define-public r-leaflet
+ (package
+ (name "r-leaflet")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "leaflet" version))
+ (sha256
+ (base32
+ "051i5qmwa0zbk4jpjrx9kzk4g8qg9c3cavvhw19yj08fjhh8si7s"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-crosstalk" ,r-crosstalk)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-magrittr" ,r-magrittr)
+ ("r-markdown" ,r-markdown)
+ ("r-png" ,r-png)
+ ("r-raster" ,r-raster)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-scales" ,r-scales)
+ ("r-sp" ,r-sp)
+ ("r-viridis" ,r-viridis)))
+ (home-page "http://rstudio.github.io/leaflet/")
+ (synopsis
+ "Create Interactive Web Maps with the JavaScript Leaflet Library")
+ (description
+ "Create and customize interactive maps using the Leaflet JavaScript
+library and the htmlwidgets package. These maps can be used directly from
+the R console, from RStudio, in Shiny applications and R Markdown documents.")
+ (license license:gpl3)))
+
(define-public r-abd
(package
(name "r-abd")
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34548@debbugs.gnu.org)
87pnroudwk.fsf@elephly.net
Hi Brett,

Toggle quote (7 lines)
> From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Mon, 18 Feb 2019 19:37:02 -0600
> Subject: [PATCH 06/24] gnu: Add r-leaflet.
>
> * gnu/packages/cran.scm (r-leaflet): New variable.

Unfortunately, this one is not okay. It’s been on my list to add
r-leaflet, but the package bundles minified JavaScript libraries.

These sources of these libraries will need to be added as native inputs
to replace the bundled sources. We can minify them with the uglify-js
package.

--
Ricardo
Brett Gilio wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87va1faatv.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (16 lines)
> Hi Brett,
>
>> From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Mon, 18 Feb 2019 19:37:02 -0600
>> Subject: [PATCH 06/24] gnu: Add r-leaflet.
>>
>> * gnu/packages/cran.scm (r-leaflet): New variable.
>
> Unfortunately, this one is not okay. It’s been on my list to add
> r-leaflet, but the package bundles minified JavaScript libraries.
>
> These sources of these libraries will need to be added as native inputs
> to replace the bundled sources. We can minify them with the uglify-js
> package.

Understood. I will make a note to look that and see if I can revise the
patch if that option seems formidable. However, on that note, do we have
any progress on an npm importer? I know that came up awhile back.
swedebugia wrote 6 years ago
(address . 34548@debbugs.gnu.org)
5AB7CFA8-FD34-48D3-8392-9102042F3596@riseup.net
Brett Gilio <brettg@posteo.net> skrev: (19 februari 2019 19:32:12 CET)
Toggle quote (27 lines)
>
>Ricardo Wurmus writes:
>
>> Hi Brett,
>>
>>> From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00
>2001
>>> From: Brett Gilio <brettg@posteo.net>
>>> Date: Mon, 18 Feb 2019 19:37:02 -0600
>>> Subject: [PATCH 06/24] gnu: Add r-leaflet.
>>>
>>> * gnu/packages/cran.scm (r-leaflet): New variable.
>>
>> Unfortunately, this one is not okay. It’s been on my list to add
>> r-leaflet, but the package bundles minified JavaScript libraries.
>>
>> These sources of these libraries will need to be added as native
>inputs
>> to replace the bundled sources. We can minify them with the
>uglify-js
>> package.
>
>Understood. I will make a note to look that and see if I can revise the
>patch if that option seems formidable. However, on that note, do we
>have
>any progress on an npm importer? I know that came up awhile back.

Julien is sitting on the patchset right now since a few weeks.

It still has some defects still but is mostly working.

The problem of circular dependencies is still unsolved. I suggest we add to our importer the ability to parse and select versions recursively. I tried but failed to get it to work before I gave up.
--
Sent from my k-9 mail for Android.
Attachment: file
Brett Gilio wrote 6 years ago
(name . swedebugia)(address . swedebugia@riseup.net)
87d0nknbl1.fsf@posteo.net
swedebugia writes:

Toggle quote (34 lines)
> Brett Gilio <brettg@posteo.net> skrev: (19 februari 2019 19:32:12 CET)
>>
>>Ricardo Wurmus writes:
>>
>>> Hi Brett,
>>>
>>>> From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00
>>2001
>>>> From: Brett Gilio <brettg@posteo.net>
>>>> Date: Mon, 18 Feb 2019 19:37:02 -0600
>>>> Subject: [PATCH 06/24] gnu: Add r-leaflet.
>>>>
>>>> * gnu/packages/cran.scm (r-leaflet): New variable.
>>>
>>> Unfortunately, this one is not okay. It’s been on my list to add
>>> r-leaflet, but the package bundles minified JavaScript libraries.
>>>
>>> These sources of these libraries will need to be added as native
>>inputs
>>> to replace the bundled sources. We can minify them with the
>>uglify-js
>>> package.
>>
>>Understood. I will make a note to look that and see if I can revise the
>>patch if that option seems formidable. However, on that note, do we
>>have
>>any progress on an npm importer? I know that came up awhile back.
>
> Julien is sitting on the patchset right now since a few weeks.
>
> It still has some defects still but is mostly working.
>
> The problem of circular dependencies is still unsolved. I suggest we add to our importer the ability to parse and select versions recursively. I tried but failed to get it to work before I gave up.

Hey, where is the patchset located? I wouldn't mind taking a look.
swedebugia wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)
ae1837a6-e747-5204-1624-56b732dabd87@riseup.net
On 02/21/2019 09:14 PM, Brett Gilio wrote:
Toggle quote (3 lines)
> swedebugia writes:
>
>> Brett Gilio <brettg@posteo.net> skrev: (19 februari 2019 19:32:12 CET)
snip
Toggle quote (10 lines)
>>> However, on that note, do we
>>> have
>>> any progress on an npm importer? I know that came up awhile back.
>> Julien is sitting on the patchset right now since a few weeks.
>>
>> It still has some defects still but is mostly working.
>>
>> The problem of circular dependencies is still unsolved. I suggest we add to our importer the ability to parse and select versions recursively. I tried but failed to get it to work before I gave up.
> Hey, where is the patchset located? I wouldn't mind taking a look.


Julien integrated my changes (which consisted of changing to use the
npm-packages instead of github sources) on top of Jelles earlier work
and made some changes after that (fixing the recursive importer :D) and
rebased the whole thing.

Most smaller packages include everything in the npm-packages but when
reviewing we should check that we are actually building from source and
not just installing some precompiles js-files (which you can imagine
will take a long time).

Fortunately it is "only" 1500-2000 packages i a couple of different
versions that are used in most projects that I have explored with the
very nice tool npm-explorer (see

We essentially need to write our own npm dependency resolver to avoid
circular dependencies.
What in my view is currently missing to decide which version of
dependencies to import is a semver parser. I took a stab at that, see
below[1], but it is messy and buggy and should probably be implemented
with PEG[2].

Now that I recently succeded with PEG in my unpublished WIP quicklisp
importer I could give it another try with PEG.

Have fun with it!

|;; FIXME consider even the patch versions. ;; See
(define (parse-semver hashtable version) "return the newest version
within the same major or minor version" (define (split list)
(string-split list #\.)) (define (version-list hashtable) (map split
(map first (hash-table->alist (hash-ref hashtable "versions")))))
(define (major list) (first list)) (define (minor list) (second list))
(define (minor->number list) (string->number (minor (split list)))) ;;
Return latest minor with same major version. ;; e.g. ^1.1.0 -> 1.4.0
even though 2.0.0 is availiable (let* ((version (split (string-drop
version 1))) (version-list (map first (hash-table->alist (hash-ref
hashtable "versions")))) (same-major (if (equal? 3 (length version))
(fold ;; recurse through version-list (lambda (ver lst) (if
(string-prefix? (major version) ver) (cons ver lst) lst)) '()
version-list) ;; not a version triplet #f))) ;; From ;;
(fold-right (lambda (str prev) (if (> (minor->number str) (minor->number
prev)) str prev)) ;;init with 0.0.0 work with minor->number "0.0.0"
same-major))) [1]
[2]
|
Attachment: file
Ricardo Wurmus wrote 3 years ago
[PATCH 06/24] gnu: Add r-leaflet.
(address . 34548-done@debbugs.gnu.org)
87lez6odbf.fsf@elephly.net
I’m closing this as we now have r-leaflet.

It took a long time to figure out what sources correspond to the
minified JavaScript, but once all sources had been found processing the
sources to generate minified JavaScript was easy.

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34548@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34548
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help