Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
From 26fbdbeee9ec293511648dc321abb09b6989fadc Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 19:37:02 -0600
Subject: [PATCH 06/24] gnu: Add r-leaflet.
* gnu/packages/cran.scm (r-leaflet): New variable.
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 44c8b0a99..1359a565f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6655,6 +6655,40 @@ in science, technology, engineering and mathematics will need in their
professional lives, but which are usually taught in isolation, if at all.")
(license license:gpl2+)))
+(define-public r-leaflet
+ (package
+ (name "r-leaflet")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "leaflet" version))
+ (sha256
+ (base32
+ "051i5qmwa0zbk4jpjrx9kzk4g8qg9c3cavvhw19yj08fjhh8si7s"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-base64enc" ,r-base64enc)
+ ("r-crosstalk" ,r-crosstalk)
+ ("r-htmltools" ,r-htmltools)
+ ("r-htmlwidgets" ,r-htmlwidgets)
+ ("r-magrittr" ,r-magrittr)
+ ("r-markdown" ,r-markdown)
+ ("r-png" ,r-png)
+ ("r-raster" ,r-raster)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-scales" ,r-scales)
+ ("r-sp" ,r-sp)
+ ("r-viridis" ,r-viridis)))
+ (home-page "http://rstudio.github.io/leaflet/")
+ (synopsis
+ "Create Interactive Web Maps with the JavaScript Leaflet Library")
+ (description
+ "Create and customize interactive maps using the Leaflet JavaScript
+library and the htmlwidgets package. These maps can be used directly from
+the R console, from RStudio, in Shiny applications and R Markdown documents.")
+ (license license:gpl3)))
+
(define-public r-abd
(package
(name "r-abd")
--
2.20.1