[PATCH] gnu: Add r-sloop.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brett Gilio
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Brett Gilio
Severity
normal

Debbugs page

Brett Gilio wrote 6 years ago
(address . guix-patches@gnu.org)
875ztg8zas.fsf@posteo.net
From 4354879abedcb0b127c726d175900de91c4fa5cc Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Mon, 18 Feb 2019 17:13:37 -0600
Subject: [PATCH] gnu: Add r-sloop.

* gnu/packages/cran.scm (r-sloop): New variable.
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82fd465d7..75ed4f603 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10650,3 +10650,27 @@ analysis (@code{rrpca}), randomized interpolative decomposition (@code{rid}),
and the randomized CUR decomposition (@code{rcur}). In addition several plot
functions are provided.")
(license license:gpl3+)))
+
+(define-public r-sloop
+ (package
+ (name "r-sloop")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sloop" version))
+ (sha256
+ (base32
+ "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-codetools" ,r-codetools)
+ ("r-crayon" ,r-crayon)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/r-lib/sloop")
+ (synopsis "Helpers for 'OOP' in R")
+ (description
+ "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
+ (license license:gpl3)))
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34538@debbugs.gnu.org)
87ftsitnij.fsf@elephly.net
Hi Brett,

Toggle quote (1 lines)
> * gnu/packages/cran.scm (r-sloop): New variable.
[…]
Toggle quote (25 lines)
> +
> +(define-public r-sloop
> + (package
> + (name "r-sloop")
> + (version "1.0.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "sloop" version))
> + (sha256
> + (base32
> + "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
> + (build-system r-build-system)
> + (propagated-inputs
> + `(("r-codetools" ,r-codetools)
> + ("r-crayon" ,r-crayon)
> + ("r-purrr" ,r-purrr)
> + ("r-rlang" ,r-rlang)
> + ("r-tibble" ,r-tibble)))
> + (home-page "https://github.com/r-lib/sloop")
> + (synopsis "Helpers for 'OOP' in R")
> + (description
> + "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
> + (license license:gpl3)))

There are a couple of problems here:

- The indentation is wrong throughout.
- Please don’t use “'” in the synopsis and description.
- Please spell out “OOP” in the synopsis
- Please break the long description up into several lines. “guix lint”
will warn you about this, so please use it.

Could you please send a new patch to 34538@debbugs.gnu.org?

Thanks!

--
Ricardo
Brett Gilio wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)
877eduqor2.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (41 lines)
> Hi Brett,
>
>> * gnu/packages/cran.scm (r-sloop): New variable.
> […]
>> +
>> +(define-public r-sloop
>> + (package
>> + (name "r-sloop")
>> + (version "1.0.1")
>> + (source
>> + (origin
>> + (method url-fetch)
>> + (uri (cran-uri "sloop" version))
>> + (sha256
>> + (base32
>> + "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
>> + (build-system r-build-system)
>> + (propagated-inputs
>> + `(("r-codetools" ,r-codetools)
>> + ("r-crayon" ,r-crayon)
>> + ("r-purrr" ,r-purrr)
>> + ("r-rlang" ,r-rlang)
>> + ("r-tibble" ,r-tibble)))
>> + (home-page "https://github.com/r-lib/sloop")
>> + (synopsis "Helpers for 'OOP' in R")
>> + (description
>> + "This package provides a collection of helper functions designed to help you to better understand object oriented programming in R, particularly using 'S3'.")
>> + (license license:gpl3)))
>
> There are a couple of problems here:
>
> - The indentation is wrong throughout.
> - Please don’t use “'” in the synopsis and description.
> - Please spell out “OOP” in the synopsis
> - Please break the long description up into several lines. “guix lint”
> will warn you about this, so please use it.
>
> Could you please send a new patch to 34538@debbugs.gnu.org?
>
> Thanks!

Hi Ricardo,

Yes. I must have missed linting this one, my apologies. Stand-by for a
new patch.
Brett Gilio wrote 6 years ago
[PATCH] gnu: Add r-sloop.
(address . 34538@debbugs.gnu.org)
87k1hu2rq7.fsf@posteo.net
From cb238f0cfb09e1488630817023919f8129918554 Mon Sep 17 00:00:00 2001
From: Brett Gilio <brettg@posteo.net>
Date: Wed, 20 Feb 2019 13:14:07 -0600
Subject: [PATCH] gnu: Add r-sloop.

* gnu/packages/cran.scm (r-sloop): New variable.
---
gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82fd465d7..565a19527 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10650,3 +10650,29 @@ analysis (@code{rrpca}), randomized interpolative decomposition (@code{rid}),
and the randomized CUR decomposition (@code{rcur}). In addition several plot
functions are provided.")
(license license:gpl3+)))
+
+(define-public r-sloop
+ (package
+ (name "r-sloop")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "sloop" version))
+ (sha256
+ (base32
+ "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-codetools" ,r-codetools)
+ ("r-crayon" ,r-crayon)
+ ("r-purrr" ,r-purrr)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)))
+ (home-page "https://github.com/r-lib/sloop")
+ (synopsis "Helpers for object-oriented programming in R")
+ (description
+ "This package provides a collection of helper functions designed to
+help you to better understand object oriented programming in R, particularly
+using @code{S3}.")
+ (license license:gpl3)))
--
2.20.1
Brett Gilio wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34538@debbugs.gnu.org)
87imxe2rii.fsf@posteo.net
Brett Gilio writes:

Toggle quote (45 lines)
> From cb238f0cfb09e1488630817023919f8129918554 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Wed, 20 Feb 2019 13:14:07 -0600
> Subject: [PATCH] gnu: Add r-sloop.
>
> * gnu/packages/cran.scm (r-sloop): New variable.
> ---
> gnu/packages/cran.scm | 26 ++++++++++++++++++++++++++
> 1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
> index 82fd465d7..565a19527 100644
> --- a/gnu/packages/cran.scm
> +++ b/gnu/packages/cran.scm
> @@ -10650,3 +10650,29 @@ analysis (@code{rrpca}), randomized interpolative decomposition (@code{rid}),
> and the randomized CUR decomposition (@code{rcur}). In addition several plot
> functions are provided.")
> (license license:gpl3+)))
> +
> +(define-public r-sloop
> + (package
> + (name "r-sloop")
> + (version "1.0.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (cran-uri "sloop" version))
> + (sha256
> + (base32
> + "00fk5fr5zsk2qxc1kfhmshhjxgnamm3401089sx8m2l529zd6r8j"))))
> + (build-system r-build-system)
> + (propagated-inputs
> + `(("r-codetools" ,r-codetools)
> + ("r-crayon" ,r-crayon)
> + ("r-purrr" ,r-purrr)
> + ("r-rlang" ,r-rlang)
> + ("r-tibble" ,r-tibble)))
> + (home-page "https://github.com/r-lib/sloop")
> + (synopsis "Helpers for object-oriented programming in R")
> + (description
> + "This package provides a collection of helper functions designed to
> +help you to better understand object oriented programming in R, particularly
> +using @code{S3}.")
> + (license license:gpl3)))

Ricardo, the changes have been applied and it passed the linter.

WDYT?
Ricardo Wurmus wrote 6 years ago
(name . Brett Gilio)(address . brettg@posteo.net)(address . 34538-done@debbugs.gnu.org)
875ztetdlg.fsf@elephly.net
Brett Gilio <brettg@posteo.net> writes:

Toggle quote (7 lines)
> From cb238f0cfb09e1488630817023919f8129918554 Mon Sep 17 00:00:00 2001
> From: Brett Gilio <brettg@posteo.net>
> Date: Wed, 20 Feb 2019 13:14:07 -0600
> Subject: [PATCH] gnu: Add r-sloop.
>
> * gnu/packages/cran.scm (r-sloop): New variable.

Thank you for the corrected patch.

Pushed to the master branch with commit 14afee3e8b.

--
Ricardo
Closed
Brett Gilio wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87h8cy2nl8.fsf@posteo.net
Ricardo Wurmus writes:

Toggle quote (13 lines)
> Brett Gilio <brettg@posteo.net> writes:
>
>> From cb238f0cfb09e1488630817023919f8129918554 Mon Sep 17 00:00:00 2001
>> From: Brett Gilio <brettg@posteo.net>
>> Date: Wed, 20 Feb 2019 13:14:07 -0600
>> Subject: [PATCH] gnu: Add r-sloop.
>>
>> * gnu/packages/cran.scm (r-sloop): New variable.
>
> Thank you for the corrected patch.
>
> Pushed to the master branch with commit 14afee3e8b.

Thank you for the help.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34538@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34538
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help