Hi Andreas,
On Tue, 19 Feb 2019 16:35:53 +0100
Andreas Enge <andreas@enge.fr> wrote:
Toggle quote (10 lines)
> I tried to simply drop python-wrapper from inputs. Actually it is not
> referenced by the final output, so it should be in native-inputs. And
> here is what happens:
>
> -- Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE)
> CMake Error at tests/CMakeLists.txt:4 (MESSAGE):
> Could not find a python interpeter, which is needed to build the tests.
> Make sure python is available, or pass -DBUILD_CLAR=OFF to skip building
> the tests
Toggle diff (51 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index b8e967bf6..7452f17b8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -545,7 +545,8 @@ everything from small to very large projects with speed and efficiency.")
(build-system cmake-build-system)
(outputs '("out" "debug"))
(arguments
- `(#:configure-flags '("-DUSE_SHA1DC=ON") ; SHA-1 collision detection
+ `(#:configure-flags '("-DUSE_SHA1DC=ON" ; SHA-1 collision detection
+ "-DBUILD_CLAR=OFF")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'fix-hardcoded-paths
@@ -558,11 +559,13 @@ everything from small to very large projects with speed and efficiency.")
#t))
;; Run checks more verbosely.
(replace 'check
- (lambda _ (invoke "./libgit2_clar" "-v" "-Q"))))))
+ (const #t)
+ ))))
(inputs
`(("libssh2" ,libssh2)
("http-parser" ,http-parser)
- ("python" ,python-wrapper)))
+; ("python" ,python-wrapper)
+))
(native-inputs
`(("pkg-config" ,pkg-config)))
(propagated-inputs
> So we could create a separate package for internal guix use without running
> the tests, which would save us from compiling and especially testing python.
Please, let's just replace the test generator in this case. It's ridiculous
to complicate Guix that much for a 250 line test generator, most of which is
templates.
If necessary, I can do it, although a person who knows Perl or Guile better
can probably do it much faster.
> Although this is not our usual style - but on the other hand, "guix pull"
> is more or less the first command that we recommend to our users, and
> it would be nice if it ran fast without requiring (many) additional packages.
>
> Ironically, libgit2 advertises itself as needing "Zero Dependencies" on its
> web site...
>
> What do you think?
Just replace the one script and do run the tests, without depending on Python.