pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
Tetrinet is a multiplayer tetris game. There are two versions: a command line implementation and a GTK implementation - this package is the command line implementation. http://tetrinet.or.cz/
The license is written in the README as
```
Distribution/license information
--------------------------------
This program is public domain, and may be modified and distributed without
limitation.
```
So I don't know what license to put it as, so I set it as 'expat'.
From 1e36c7b0cafac68dcac43bfe301ae979ced67800 Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 18 Feb 2019 06:52:14 +0000
Subject: [PATCH] gnu: Add tetrinet.
* gnu/packages/games.scm (tetrinet): New variable.
---
gnu/packages/games.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (51 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index f82af0e8c..5a83efcc2 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2018 Madalin Ionel-Patrascu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6102,3 +6103,36 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+(define-public tetrinet
+ (package
+ (name "tetrinet")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://tetrinet.or.cz/download/tetrinet-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "0b4pddqz6is1771qmvcj8qqlr4in2djdbkk13agvp9yhfah2v8x7"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (arguments
+ `(#:tests? #f ; No tests.
+ #:make-flags '("CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'fix-install-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (mkdir-p (string-append out "/bin"))
+ (substitute* "Makefile"
+ (("/usr/games") (string-append out "/bin")))))))))
+ (home-page "http://tetrinet.or.cz")
+ (synopsis "Multiplayer tetris")
+ (description "Tetrinet is a multiplayer tetris game with powerups and
+attacks you can use on opponents.")
+ (license license:expat)))
--
2.20.1