Add qtcolorwidgets

  • Done
  • quality assurance status badge
Details
2 participants
  • pkill9
  • Ricardo Wurmus
Owner
unassigned
Submitted by
pkill9
Severity
normal

Debbugs page

pkill9 wrote 6 years ago
(name . guix-patches)(address . guix-patches@gnu.org)
E1gvJ2V-00020H-Lx@rmmprod05.runbox
This is a QT module that provides color management, e.g. a color wheel. https://gitlab.com/mattia.basaglia/Qt-Color-Widgets

I'm adding this as a dependency for drawpile which I will also submit once this package definition is merged. There is unfortunately no release available for this, however drawpile bundles it's own copy of qtcolorwidgets if it doesn't find one.
From 33d629801822ce2f3967f61a38ffe91205ea19bf Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Sun, 17 Feb 2019 09:42:28 +0000
Subject: [PATCH] gnu: Add qtcolorwidgets.

* gnu/packages/qt.scm (qtcolorwidgets): New variable.
---
gnu/packages/qt.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 664309cb5..e3296b582 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2232,3 +2232,28 @@ a binding language:
@item Creating from Singleton QML QObject defined in the binded language
@end itemize\n")
(license license:lgpl3))) ;version 3 only (+ exception)
+
+(define-public qtcolorwidgets
+ (package
+ (name "qtcolorwidgets")
+ (version "git")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (commit "a95f72e935fe9e046061a1d1c3930cbfbcb533e0")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dkiwlqh2gwhlp78c1fmchj3shl4p9inspcl96ya5aa8mn6kydy8"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;; No tests.
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (home-page "https://gitlab.com/mattia.basaglia/Qt-Color-Widgets")
+ (synopsis "Color management widgets")
+ (description "QTColorWidgets provides QT widgets for managing colors.")
+ (license license:lgpl3+)))
--
2.20.1
Ricardo Wurmus wrote 6 years ago
(address . pkill9@runbox.com)(address . 34511-done@debbugs.gnu.org)
87lg2ey878.fsf@elephly.net
<pkill9@runbox.com> writes:

Toggle quote (15 lines)
> This is a QT module that provides color management, e.g. a color wheel. https://gitlab.com/mattia.basaglia/Qt-Color-Widgets
>
> I'm adding this as a dependency for drawpile which I will also submit
> once this package definition is merged. There is unfortunately no
> release available for this, however drawpile bundles it's own copy of
> qtcolorwidgets if it doesn't find one.
>
> From 33d629801822ce2f3967f61a38ffe91205ea19bf Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Sun, 17 Feb 2019 09:42:28 +0000
> Subject: [PATCH] gnu: Add qtcolorwidgets.
>
> * gnu/packages/qt.scm (qtcolorwidgets): New variable.
> ---

Thank you. I pushed a modified version to the master branch with commit
b16640ac0.

Changes:

- added comments about the lack of a public release
- changed the version string, because “git” is not a valid version string
- wrapped the package definition in a let binding providing the commit and the
Guix revision
- changed the comment style (margin comments use only one semicolon)
- expanded the description.

~~ Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34511@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34511
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help