[PATCH staging] gnu: librsvg: Update to 2.44.12.

  • Done
  • quality assurance status badge
Details
One participant
  • Marius Bakke
Owner
unassigned
Submitted by
Marius Bakke
Severity
normal
M
M
Marius Bakke wrote on 16 Feb 2019 18:40
(address . guix-patches@gnu.org)
20190216174000.31653-1-mbakke@fastmail.com
* gnu/packages/gnome.scm (librsvg): Update to 2.44.12.
[arguments]: Replace patching phases with a custom variant. Delete five
new tests.
[native-inputs]: Add RUST-1.27 and RUST-1.27:CARGO.
---
gnu/packages/gnome.scm | 40 +++++++++++++++++++++++++++++++---------
1 file changed, 31 insertions(+), 9 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3a34356beb..466b986635 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -127,6 +128,7 @@
#:use-module (gnu packages rdesktop)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
+ #:use-module (gnu packages rust)
#:use-module (gnu packages samba)
#:use-module (gnu packages scanner)
#:use-module (gnu packages selinux)
@@ -1218,7 +1220,7 @@ dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.40.20")
+ (version "2.44.12")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1226,11 +1228,22 @@ dealing with different structured file formats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0ay9himvw1l1swcf3h1312d2iqzfl65kpbfgiyfykgvq7cydvx6g"))))
+ "1h3qnqhr0l7pd2bxg69ki6ckl4srdwgr471dpp4jq9i4784hp0v6"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags '("CC=gcc")
+ #:phases
(modify-phases %standard-phases
+ ;; Don't patch anything in vendor/ to avoid having to
+ ;; recompute Cargo checksums. TODO: Unbundle those.
+ (delete 'patch-source-shebangs)
+ (delete 'patch-generated-file-shebangs)
+ (delete 'patch-usr-bin-file)
+ (add-before 'configure 'patch-all-the-things
+ (lambda _
+ (for-each patch-shebang '("tap-driver.sh" "tap-test"))
+ (patch-/usr/bin/file "configure")
+ #t))
(add-before 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gdk-pixbuf-loader/Makefile.in"
@@ -1244,22 +1257,32 @@ dealing with different structured file formats.")
(("gdk_pixbuf_cache_file = .*$")
"gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
#t))
- (add-after 'unpack 'remove-failing-tests
+ (add-before 'check 'remove-failing-tests
(lambda _
(with-directory-excursion "tests/fixtures/reftests"
(for-each delete-file
- '(;; This test fails on i686:
+ '(;; The images produced by these tests differ
+ ;; slightly from their reference counterparts due
+ ;; to differences in the build environment (missing
+ ;; fonts, etc). See <tests/README.md> for details.
+ ;; These fail on x86_64.
+ "svg1.1/coords-viewattr-02-b.svg"
+ "svg1.1/filters-composite-04-f.svg"
+ "svg1.1/filters-image-01-b.svg"
+ "svg1.1/filters-conv-02-f.svg"
+ "svg1.1/filters-conv-04-f.svg"
+ ;; This test fails on i686:
"svg1.1/masking-path-04-b.svg"
- "svg1.1/masking-path-04-b-ref.png"
;; This test fails on armhf:
"svg1.1/masking-mask-01-b.svg"
- "svg1.1/masking-mask-01-b-ref.png"
;; This test fails on aarch64:
- "bugs/777834-empty-text-children.svg"
- "bugs/777834-empty-text-children-ref.png")))
+ "bugs/777834-empty-text-children.svg")))
#t)))))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ;; This is the minimum supported Rust version in Librsvg 2.44.
+ ("rust" ,rust-1.27)
+ ("cargo" ,rust-1.27 "cargo")
("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
--
2.20.1
M
M
Marius Bakke wrote on 20 Feb 2019 17:48
(address . 34500-done@debbugs.gnu.org)
87imxemmmw.fsf@fastmail.com
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (5 lines)
> * gnu/packages/gnome.scm (librsvg): Update to 2.44.12.
> [arguments]: Replace patching phases with a custom variant. Delete five
> new tests.
> [native-inputs]: Add RUST-1.27 and RUST-1.27:CARGO.

Pushed in ec47c07d0690653be35a75b346f3c3548a3e71d4.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAlxthOcACgkQoqBt8qM6
VPqlLgf/WNpgbusZ75Y/5idtucKQzJ6Vo8poxWMkpsAddTWqiTM94qTj3nhP+1NB
maOkHv0Z7q+onAJoyrCAHeJIswZ8oifhn0QVi+/zi/GgBJ5uNpwpiQu45XvGNtSe
08ySFfSgvQv0N3ckxsNmRuXHHutZcE/0Hg5UPPcwmjp7LOUjpTkj+IEPMhviUMhN
G/HVLhkxj7kmYohFfgDGdcl63xj2+C2xw7dPDJ51TEVgGCge1v8Ck8ffb0cnsRp8
g7XptdQEQJkJPP41UATwXBhe6zB+r5648P0eL4Y8tkjMxjXsM/LErrvivBp6QFcX
5JcypiQKIyizykwlYYKld2O7Er8JIA==
=hKri
-----END PGP SIGNATURE-----

Closed
?