Oops! Here it is
On Sun, 17 Feb 2019 12:25:41 +0200, Efraim Flashner <efraim@flashner.co.il> wrote:
Toggle quote (10 lines)
> On Sat, Feb 16, 2019 at 06:04:05AM +0000, pkill9@runbox.com wrote:
> > This patch adds Odamex, a port of Doom focused on multiplayer support. https://odamex.net/
> >
>
> Looks like you forgot to attach the patch :)
>
> --
> Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
> GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
From 8613bd3ae3f73cd45fd1b17ee5e9f3d3e23b76fd Mon Sep 17 00:00:00 2001
* gnu/packages/games.scm (odamex): New variable.
---
gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
Toggle diff (44 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d9e63c4e..9dc19bda1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5378,6 +5378,37 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
"file://dumb/licence.txt"
"Dumb license, explicitly GPL compatible.")))))
+(define-public odamex
+ (package
+ (name "odamex")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/odamex/Odamex/"
+ version
+ "/odamex-src-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1sh6lqj7vsdmnqz17hw0b6vy7xx6dp41k2sdw99ympsfa2xd1d2j"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ;; No tests
+ (inputs
+ `(("sdl" ,(@ (gnu packages sdl) sdl))
+ ("sdl-mixer" ,(@ (gnu packages sdl) sdl-mixer))
+ ("zlib" ,(@ (gnu packages compression) zlib))
+ ("libpng" ,(@ (gnu packages image) libpng))
+ ("alsa-lib" ,(@ (gnu packages linux) alsa-lib))))
+ (home-page "https://odamex.net/")
+ (synopsis "Multiplayer Doom port")
+ (description "Odamex is a free, cross-platform modification of the Doom
+engine that allows players to easily join servers dedicated to playing Doom
+online.")
+ (license license:gpl2)))
+
(define-public fortune-mod
(package
(name "fortune-mod")
--
2.20.1