[PATCH 1/3] gnu: Add sdl2-gfx.

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Kei Kebreau
  • Leo Famulari
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190215063530.31198-1-kkebreau@posteo.net
* gnu/packages/sdl.scm (sdl2-gfx): New variable.
---
gnu/packages/sdl.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index a1522792a7..30b48a5215 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -348,6 +349,21 @@ directory.")
(other other))
(package-propagated-inputs package)))
+(define-public sdl2-gfx
+ (package (inherit sdl-gfx)
+ (name "sdl2-gfx")
+ (version "1.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qk2ax7f7grlxb13ba0ll3zlm8780s7j8fmrhlpxzjgdvldf1q33"))))
+ (propagated-inputs
+ (propagated-inputs-with-sdl2 sdl-gfx))))
+
(define-public sdl2-image
(package (inherit sdl-image)
(name "sdl2-image")
--
2.20.1
Kei Kebreau wrote 6 years ago
[PATCH 2/3] gnu: Add cxxtest.
(address . 34482@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190215122624.5269-1-kkebreau@posteo.net
* gnu/packages/check.scm (cxxtest): New variable.
---
gnu/packages/check.scm | 47 +++++++++++++++++++++++++++++++++++++++++-
1 file changed, 46 insertions(+), 1 deletion(-)

Toggle diff (67 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index d689c96648..6f4ba579eb 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2017, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Marius Bakke <mbakke@fastmail.com>
@@ -324,6 +324,51 @@ normally do not detect. The goal is to detect only real errors in the code
(i.e. have zero false positives).")
(license license:gpl3+)))
+(define-public cxxtest
+ (package
+ (name "cxxtest")
+ (version "4.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/cxxtest/cxxtest/"
+ version "/cxxtest-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1n7pbj4z9ivx005hqvivj9ddhq8awynzg6jishfbypf6j7ply58w"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir-to-source
+ (lambda _
+ (chdir "python")
+ #t))
+ (add-after 'install 'install-headers
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include-dir (string-append out "/include/cxxtest")))
+ (for-each (lambda (header-file)
+ (install-file header-file include-dir))
+ (find-files "../cxxtest"))
+ #t)))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc-dir (string-append out "/share/doc/cxxtest")))
+ (install-file "../README" doc-dir)
+ (install-file "../doc/guide.txt" doc-dir)
+ (copy-recursively "../sample" (string-append doc-dir "/sample"))
+ #t))))))
+ (propagated-inputs
+ `(("python-ply" ,python-ply)))
+ (home-page "https://cxxtest.com/")
+ (synopsis "Unit testing framework for C++")
+ (description "CxxTest is a unit testing framework for C++ that is similar
+in spirit to JUnit, CppUnit, and xUnit. CxxTest does not require precompiling
+a CxxTest testing library, it employs no advanced features of C++ (e.g. RTTI)
+and it supports a very flexible form of test discovery.")
+ (license license:lgpl3+)))
+
(define-public go-gopkg.in-check.v1
(let ((commit "20d25e2804050c1cd24a7eea1e7a6447dd0e74ec")
(revision "0"))
--
2.20.1
Kei Kebreau wrote 6 years ago
[PATCH 3/3] gnu: freedink-engine: Update to 109.4.
(address . 34482@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190215122624.5269-2-kkebreau@posteo.net
* gnu/packages/games.scm (freedink-engine): Update to 109.4.
[arguments]: Add 'disable-graphical-tests' phase.
[native-inputs]: Add autoconf, automake and cxxtest. Remove check.
[inputs]: Add glm and sdl-union of sdl2, sdl2-image, sdl2-mixer, sdl2-ttf and
sdl2-gfx. Remove sdl, sdl-image, sdl-mixer, sdl-ttf and sdl-gfx.
---
gnu/packages/games.scm | 32 +++++++++++++++++++++-----------
1 file changed, 21 insertions(+), 11 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 6d9e63c4e9..980bf872e7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -112,6 +112,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
#:use-module (gnu packages haskell)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages mp3)
#:use-module (gnu packages music)
#:use-module (gnu packages multiprecision)
@@ -1401,25 +1402,34 @@ interface or via an external visual interface such as GNU XBoard.")
(define freedink-engine
(package
(name "freedink-engine")
- (version "108.4")
+ (version "109.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/freedink/freedink-" version
".tar.gz"))
(sha256
(base32
- "08c51imfjfcydm7h0va09z8qfw5nc837bi2x754ni2z737hb5kw2"))))
+ "0iaagwnyfgm3mqzkj550q60hrsjr13gykg5vfn2nz2ia520bb52g"))))
(build-system gnu-build-system)
- (arguments `(#:configure-flags '("--disable-embedded-resources")))
- (native-inputs `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
- (inputs `(("sdl" ,sdl)
- ("sdl-image" ,sdl-image)
- ("sdl-mixer" ,sdl-mixer)
- ("sdl-ttf" ,sdl-ttf)
- ("sdl-gfx" ,sdl-gfx)
+ (arguments
+ `(#:configure-flags '("--disable-embedded-resources")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'disable-graphical-tests
+ (lambda _
+ ;; These tests require a graphical interface.
+ (substitute* "src/Makefile.am"
+ (("test_gfx_fonts TestIOGfxDisplay") ""))
+ #t)))))
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)
+ ("cxxtest" ,cxxtest)))
+ (inputs `(("sdl-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer
+ sdl2-ttf sdl2-gfx)))
("fontconfig" ,fontconfig)
- ("check" ,check)))
+ ("glm" ,glm)))
(properties '((ftp-directory . "/freedink")
(upstream-name . "freedink")))
(home-page "https://www.gnu.org/software/freedink/")
--
2.20.1
Leo Famulari wrote 6 years ago
Re: [bug#34482] [PATCH 1/3] gnu: Add sdl2-gfx.
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 34482@debbugs.gnu.org)
20190215163909.GA9105@jasmine.lan
On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
Toggle quote (5 lines)
> * gnu/packages/sdl.scm (sdl2-gfx): New variable.

> + (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
> + version ".tar.gz"))

I think there is a typo in this URL.

s/frez/ferz
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxm6y0ACgkQJkb6MLrK
fwh4jw/7BfVUo8qt+7BS3Wc4u4h/1STYFWk1AfXfKrXGzWfZKAjdGSEjXRXTYHhu
aVL52v+DFyiWssSb4d8AIqQpXIfPGbpSF8UUitYPeuwFoydfzc+NeepcVw8NHG74
tMbVKTNdg7/Vn9qbLoTmvaC9QFEFafIzFEjsrt4pxq/KH6xLDdQCPaNJB9zD4Unp
Z/uWo8mwX2ujPC7/HdQ5dvjyjAMKQb+fo/0ydFpP48H3pCjMy7pHvyU6wAu57iJw
hOukupfZ65ZfYsqYtBqmcW35Yj+wmxl1cfIlW93ouIfOeTZiut/v24x7kwwr8/nv
G8a77q0YaWpW7OQ6+lOAmYRSqJvhXrwScM4uS37FoCxt+eSBimm3WmOwe5rZJZc1
Bmwc+xDWOsctQb8+KW5bmmVotlZQgbu7Ns5ZE3JCPsDNSuF/Wz6Js+dBB1Y8qIxF
mcbVzqyQyAm6nefX5K8FNMfzwo7XJXCw+f54UglWR4dcY/rFyPyjdERpZkX0f9Ff
M3nz7LR3ZMHxLsFo0Pp5YqFidDgK/msMa9QkH6ZzHmBLSgvCA8ZhyzeIH2wuG9tA
v5+CwHSR6eQG2uSaE0mbIBj7HuJS/Ww8i2SclYoVdhkDAlXhmH9/prBkRjwUesL1
SC4Y0Wko0iptXhowewi2vTiKoVpR6tNmffZQMRZctuE10K1NvG0=
=RCzt
-----END PGP SIGNATURE-----


Kei Kebreau wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)(address . 34482@debbugs.gnu.org)
87bm3cluf6.fsf@posteo.net
Leo Famulari <leo@famulari.name> writes:

Toggle quote (11 lines)
> On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
>> * gnu/packages/sdl.scm (sdl2-gfx): New variable.
>
>> + (string-append
>> "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
>> + version ".tar.gz"))
>
> I think there is a typo in this URL.
>
> s/frez/ferz

Yes, thanks. I've attached a working patch.
From fd23964fd6b563d098745d04fee0e388fb48d10a Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Tue, 12 Feb 2019 21:45:03 -0500
Subject: [PATCH 1/3] gnu: Add sdl2-gfx.

* gnu/packages/sdl.scm (sdl2-gfx): New variable.
---
gnu/packages/sdl.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/sdl.scm b/gnu/packages/sdl.scm
index a1522792a7..e3a23dae02 100644
--- a/gnu/packages/sdl.scm
+++ b/gnu/packages/sdl.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017, 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -348,6 +349,21 @@ directory.")
(other other))
(package-propagated-inputs package)))
+(define-public sdl2-gfx
+ (package (inherit sdl-gfx)
+ (name "sdl2-gfx")
+ (version "1.0.4")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "http://www.ferzkopp.net/Software/SDL2_gfx/SDL2_gfx-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qk2ax7f7grlxb13ba0ll3zlm8780s7j8fmrhlpxzjgdvldf1q33"))))
+ (propagated-inputs
+ (propagated-inputs-with-sdl2 sdl-gfx))))
+
(define-public sdl2-image
(package (inherit sdl-image)
(name "sdl2-image")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlxnE70ACgkQ5qXuPBlG
eg34aA//X1lVKlcVLpUVcujUqqD3rnVVyGKvjB0401B3ZssjcU1XAPnNdRq1/3J3
CGt2Ny7M5XNNWMFn3vgoHWVjChFg6WjgfI7Bq6S97M/0SbhN0KIZ1MfPi/DKksRe
TZj5YGYZtxZcFFGRbQN6I/kA+Vg1jK7AQZAjI6eE6NtuSOyOwreLqtVeEbCFGIjM
AnhC4TX614pntJeS0ZYK7Kok2s3EnAOEyGnHLJRkN6eE/gZgLLCRMtvX9fvK05g1
vr+jgYY4ImzXvLTuqX+TE+nmp55f71t8E9YWI6mbPEhumyPbhecLDy8sJ3WHyPb/
MmK1VZqJu10Z9DXYLamMVAwbhSbT/cLctShVPUKaHErABbwUcdENJCa+YFbbkLIO
wW6PQZ8qjstRFqL6O6bBUaO26GNTkksOohnHWLmzXc2B4/qqZVoxpTFZRaNw3HMf
pBQkMy+IOSsRRh90T5ysXrai7FZhMZPPIx/OOmk9kZXr1xrm2O9HwWWXXEWG66EU
kDa7LazcclXYopko/lhcQFCSepc5SpvI20gDCIkGZ1CRn+BEDHivkriCaE/8+ckZ
XLUsRgCP/dxl1zL93u7VLh3aoz36MDZRvneRnlNBh/kuhyzQDTjT9eZa4tsZfM8M
qcYlQM+uXaPS+naWbdytpcn0T1fsF/d4f/6m3/qCqjgRJLQRNok=
=Tdn8
-----END PGP SIGNATURE-----

Efraim Flashner wrote 6 years ago
(name . Leo Famulari)(address . leo@famulari.name)
20190217102234.GA7206@macbook41
On Fri, Feb 15, 2019 at 11:39:09AM -0500, Leo Famulari wrote:
Toggle quote (10 lines)
> On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
> > * gnu/packages/sdl.scm (sdl2-gfx): New variable.
>
> > + (string-append "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
> > + version ".tar.gz"))
>
> I think there is a typo in this URL.
>
> s/frez/ferz

Is the url even still valid? I though they got a domain squatter there
now


--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAlxpNecACgkQQarn3Mo9
g1FDYxAAsUlMXE2ry8S8HZENupY2tBcEFn4c2R70wjKH2kc/Bw8Cg/EX0Z6Erkd1
txO7muA7jRBN2OBigvCAvyk2OrkA+fN8boK8V95aIfcwf77VzWhL1j+wNrmfI+hj
uF6zEOxqmW0xYn7HIcSOxNoVVHAugz6DwzuRC8NYtIUIu5t2Le+8X+EeCJJ0KvSH
XO30y8nYLel/UQp/DX8vLsz+L2avEYrzPbyCJ82Ouh9LWJXEGJq1Ky+s33seX+J9
dH80F/6RxhGfQq12LYSyB5GND5JgingHcp4mKqcnkZjhE/7jtVTOqMjbWV0RJIlZ
YxGxHCeDKuZ0TzNbsc8NRK3f54BqEPw7R1R33ujHfz5axiWat95B9R3Pi3u6F2Tx
Gn7RQBC2tkFOUGw/tF/kPFb1WcOmxxero3oxHFUpAMDRxRYZx2Sonck6lpM5Tgak
KCufREBW673fFjUQ1Kr0E3DYFoPSz175L7+EK+MrRbGh4nT7FBnAJ2b9JsTqMUBH
PChd41cUP6DL5X/PvhUJzfbg5/t1gLhzUdQUBJPgzydISne/1UijhdaeImPur3Kk
eSL140Z5W3BfMDQlSY4Ahck90IRftGi8RxSX1QQ5hq1BgKOa8nRiEan6RRorEqgY
wZKiD3xcbi68kIWcZwicLKdOhJ/0hFJ97A553udEHnNnO/2L8QA=
=kqfJ
-----END PGP SIGNATURE-----


Kei Kebreau wrote 6 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
877edypc8i.fsf@posteo.net
Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (15 lines)
> On Fri, Feb 15, 2019 at 11:39:09AM -0500, Leo Famulari wrote:
>> On Fri, Feb 15, 2019 at 01:35:30AM -0500, Kei Kebreau wrote:
>> > * gnu/packages/sdl.scm (sdl2-gfx): New variable.
>>
>> > + (string-append
>> > "http://www.frezkopp.net/Software/SDL2_gfx/SDL2_gfx-"
>> > + version ".tar.gz"))
>>
>> I think there is a typo in this URL.
>>
>> s/frez/ferz
>
> Is the url even still valid? I though they got a domain squatter there
> now

I navigated through the website to get to the SDL2_gfx tarball which was
last updated about a year ago, so I think it's still valid. Below is the
relevant page:

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAlxpls0ACgkQ5qXuPBlG
eg3cew/9Emn5tzz0h7UNjlFutqYRYBZijtiIV3zDXmGHu97wkORKgzUh46d9NEuk
8Hnbta8PKyh5ZCIWwdDcHyTs5njnZ92ptE9FiBBq7yLRQ6bOjDzsT9jUgPPUst7x
W3PQvA4CA2449vbUzOpuOkrGmB2EX4gfcNDh5PqLMlRLcc4+otd1QbAUljluK1CR
4GJrg2CGVjrbIcppUjVu5dgeyOkufpmNCTr2WI3kSOc43j5X20h01VUDOTIM/CnM
nvW/3zw7ZO1OtzJj8ELuL8ZR2CU2YgcoNkPqxKcyKMkr+DLGm5UkFyHMzeilZv8d
LpLHT6TVLfC7oZ/lcukCzvLBaw1lf2rmuaF02bAL0qMBOq/RHJOg+XYCYauBUVcb
nL/cLyrNSaUXKpFoZEbTG/m9sK/pZktIRDJx8Kw+GadtuKWrhJo3ESx46a0F0eU8
gkHN4aEVFidiyqFAaUNFVUgkQg7tLA0O1Yj/zv7PNQh6DRMN1lFCi2A693Tv9vny
+Qc8YF7yJIY0ydtOynVQKAO0BZGABGJ6rl2mREJUggZwI0y0QQ1novqLKa1JY113
UAuetfYRqPsg3duywwk9NcBAiaUroRBeaLrHkUFRGBT1TStZWgxeTxXZSMqcZgMf
Z9gX/iJbWyVm97J205KMPBgeRMtLgq71jnZXVj89jOaK2QHu70I=
=DYti
-----END PGP SIGNATURE-----

Kei Kebreau wrote 6 years ago
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87zhqn9t7x.fsf@posteo.net
Since there have been no further corrections, I've pushed a slightly
modified version of this patch to master. Thanks to all involved for
reviewing!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34482@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34482
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help