[PATCH] gnu: Add trydiffoscope.

  • Done
  • quality assurance status badge
Details
3 participants
  • Julien Lepiller
  • Leo Famulari
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 12 Feb 2019 03:08
(address . guix-patches@gnu.org)
87wom53gij.fsf@ponder
* gnu/packages/package-management (trydiffoscope): New variable.
---
gnu/packages/package-management.scm | 44 +++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 587d028d92..49208e3191 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -606,6 +606,50 @@ various binary formats into more human readable forms to compare them. It can
compare two tarballs, ISO images, or PDFs just as easily.")
(license license:gpl3+)))
+(define-public trydiffoscope
+ (package
+ (name "trydiffoscope")
+ (version "67.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((share (string-append (assoc-ref outputs "out") "/usr/share/")))
+ (mkdir-p (string-append share "/man/man1/" ))
+ (invoke "rst2man.py"
+ "trydiffoscope.1.rst"
+ (string-append share "/man/man1/trydiffoscope.1"))
+ (mkdir-p (string-append share "/doc/" ,name "-" ,version))
+ (install-file "./README.rst"
+ (string-append share "/doc/" ,name "-" ,version))))))))
+ (native-inputs
+ `(("gzip" ,gzip)
+ ("python-docutils" ,python-docutils)))
+ (build-system python-build-system)
+ (home-page "https://try.diffoscope.org")
+ (synopsis "Compare files and archives in depth")
+ (description
+ "This is a minimal diffoscope client that connects to the service:
+
+https://try.diffoscope.org.
+
+Diffoscope tries to get to the bottom of what makes files or directories
+different. It recursively unpacks archives of many kinds and transforms
+various binary formats into more human readable forms to compare them. It can
+compare two tarballs, ISO images, or PDFs just as easily.")
+ (license license:gpl3+)))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGIqpQAKCRDcUY/If5cW
qnBTAP9EWDb8lTugNTc6YsE400IkHqNvKI4Y9dxtC2yXwIoUJgD/Qnk3yro5PqDn
FdJxJ5L2He3t+Qug0p3Kgl5j3AJO+w4=
=7PK0
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 12 Feb 2019 08:31
70476863-38DA-4DA0-BBA9-82B20B2AB197@lepiller.eu
Le 12 février 2019 03:08:36 GMT+01:00, Vagrant Cascadian <vagrant@reproducible-builds.org> a écrit :
Toggle quote (73 lines)
>
>* gnu/packages/package-management (trydiffoscope): New variable.
>---
> gnu/packages/package-management.scm | 44 +++++++++++++++++++++++++++++
> 1 file changed, 44 insertions(+)
>
>diff --git a/gnu/packages/package-management.scm
>b/gnu/packages/package-management.scm
>index 587d028d92..49208e3191 100644
>--- a/gnu/packages/package-management.scm
>+++ b/gnu/packages/package-management.scm
>@@ -606,6 +606,50 @@ various binary formats into more human readable
>forms to compare them. It can
> compare two tarballs, ISO images, or PDFs just as easily.")
> (license license:gpl3+)))
>
>+(define-public trydiffoscope
>+ (package
>+ (name "trydiffoscope")
>+ (version "67.0.1")
>+ (source
>+ (origin
>+ (method git-fetch)
>+ (uri (git-reference
>+ (url
>"https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
>+ (commit version)))
>+ (file-name (git-file-name name version))
>+ (sha256
>+ (base32
>+ "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
>+ (arguments
>+ `(#:phases
>+ (modify-phases %standard-phases
>+ (add-after 'install 'install-doc
>+ (lambda* (#:key outputs #:allow-other-keys)
>+ (let* ((share (string-append (assoc-ref outputs "out")
>"/usr/share/")))
>+ (mkdir-p (string-append share "/man/man1/" ))
>+ (invoke "rst2man.py"
>+ "trydiffoscope.1.rst"
>+ (string-append share
>"/man/man1/trydiffoscope.1"))
>+ (mkdir-p (string-append share "/doc/" ,name "-"
>,version))
>+ (install-file "./README.rst"
>+ (string-append share "/doc/" ,name "-"
>,version))))))))
>+ (native-inputs
>+ `(("gzip" ,gzip)
>+ ("python-docutils" ,python-docutils)))
>+ (build-system python-build-system)
>+ (home-page "https://try.diffoscope.org")
>+ (synopsis "Compare files and archives in depth")
>+ (description
>+ "This is a minimal diffoscope client that connects to the
>service:
>+
>+https://try.diffoscope.org.
>+
>+Diffoscope tries to get to the bottom of what makes files or
>directories
>+different. It recursively unpacks archives of many kinds and
>transforms
>+various binary formats into more human readable forms to compare them.
> It can
>+compare two tarballs, ISO images, or PDFs just as easily.")
>+ (license license:gpl3+)))
>+
> (define-public python-anaconda-client
> (package
> (name "python-anaconda-client")

Hi,

Iiuc, this is a client to connect to a service that runs diffoscope for you. But we already have diffoscope, so what's the point? Also this looks like saass to me, so I think we should refrain from adding it to guix. What do you think?
V
V
Vagrant Cascadian wrote on 12 Feb 2019 09:16
87r2cda0b9.fsf@ponder
On 2019-02-12, Julien Lepiller wrote:
Toggle quote (3 lines)
> Le 12 février 2019 03:08:36 GMT+01:00, Vagrant Cascadian <vagrant@reproducible-builds.org> a écrit :
>>
>>* gnu/packages/package-management (trydiffoscope): New variable.
...
Toggle quote (23 lines)
>>+ (synopsis "Compare files and archives in depth")
>>+ (description
>>+ "This is a minimal diffoscope client that connects to the
>>service:
>>+
>>+https://try.diffoscope.org.
>>+
>>+Diffoscope tries to get to the bottom of what makes files or
>>directories
>>+different. It recursively unpacks archives of many kinds and
>>transforms
>>+various binary formats into more human readable forms to compare them.
>> It can
>>+compare two tarballs, ISO images, or PDFs just as easily.")
>>+ (license license:gpl3+)))
>>+
>> (define-public python-anaconda-client
>> (package
>> (name "python-anaconda-client")

> Iiuc, this is a client to connect to a service that runs diffoscope
> for you. But we already have diffoscope, so what's the point?

Yes, that's the jist of it. The main advantage is that it has a much
smaller dependency chain locally.

I find it useful on some of the not-particularly-fast ARM systems I've
been running GNU Guix, where storage may be limited or slow, and
substitutes may not be available as often, and build times
are... remarkable.


Toggle quote (3 lines)
> Also this looks like saass to me, so I think we should refrain from
> adding it to guix.

It is essentially SaaSS. The server-side is at least licensed under the
AGPL, if that mitigates concerns somewhat.

I'm not sure it supports it out of the box yet, but I suspect upstream
would be amenable to patches to make it easy for people to run their own
"diffoscope" services.


Toggle quote (2 lines)
> What do you think?

I thought it was useful enough to be worth submitting, though I'd
understand if it's deemed inappropriate for GNU Guix. Still learning the
ropes. :)


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGKA7AAKCRDcUY/If5cW
qnFPAQDDH58lZsnIgd64qrSo/KKzrNni+1ASYVxImFVNT9he7QEAq1SEbx+odZT0
6lqikPJVcXA8Nx2zTerXt8mhyQd7BwM=
=RYo6
-----END PGP SIGNATURE-----

J
J
Julien Lepiller wrote on 12 Feb 2019 10:34
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)(address . 34449@debbugs.gnu.org)
8c72ca26f562e3cf74e88e600351e79e@lepiller.eu
Le 2019-02-12 09:16, Vagrant Cascadian a écrit :
Toggle quote (37 lines)
>
>> Iiuc, this is a client to connect to a service that runs diffoscope
>> for you. But we already have diffoscope, so what's the point?
>
> Yes, that's the jist of it. The main advantage is that it has a much
> smaller dependency chain locally.
>
> I find it useful on some of the not-particularly-fast ARM systems I've
> been running GNU Guix, where storage may be limited or slow, and
> substitutes may not be available as often, and build times
> are... remarkable.
>
>
>> Also this looks like saass to me, so I think we should refrain from
>> adding it to guix.
>
> It is essentially SaaSS. The server-side is at least licensed under
> the
> AGPL, if that mitigates concerns somewhat.
>
> I'm not sure it supports it out of the box yet, but I suspect upstream
> would be amenable to patches to make it easy for people to run their
> own
> "diffoscope" services.
>
>
>> What do you think?
>
> I thought it was useful enough to be worth submitting, though I'd
> understand if it's deemed inappropriate for GNU Guix. Still learning
> the
> ropes. :)
>
>
> live well,
> vagrant

I'm not completely sure either, that's why I was asking for a second
opinion ;)
L
L
Leo Famulari wrote on 12 Feb 2019 21:37
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)
20190212203742.GA31872@jasmine.lan
On Tue, Feb 12, 2019 at 12:16:42AM -0800, Vagrant Cascadian wrote:
Toggle quote (3 lines)
> On 2019-02-12, Julien Lepiller wrote:
> >>+ (synopsis "Compare files and archives in depth")

This synopsis doesn't make clear that this is a client for a remote
service. Can you rewrite it?

Toggle quote (4 lines)
> >>+ (description
> >>+ "This is a minimal diffoscope client that connects to the
> >>service:

Also, I think it's better to replace "diffoscope client" with something
like "client for the remote diffoscope service located at [...]" since
diffoscope is not inherently a client-service tool. Also it would be
great to mention the full diffoscope package :)

Can you send an updated patch?

Toggle quote (11 lines)
> > Iiuc, this is a client to connect to a service that runs diffoscope
> > for you. But we already have diffoscope, so what's the point?
>
> Yes, that's the jist of it. The main advantage is that it has a much
> smaller dependency chain locally.
>
> I find it useful on some of the not-particularly-fast ARM systems I've
> been running GNU Guix, where storage may be limited or slow, and
> substitutes may not be available as often, and build times
> are... remarkable.

Yes, and diffoscope runs can also be really expensive. It's nice to
offload them.

Also, if the service makes statements about whether submissions are
logged or made public, can you put that in the package description?

Toggle quote (13 lines)
> > Also this looks like saass to me, so I think we should refrain from
> > adding it to guix.
>
> It is essentially SaaSS. The server-side is at least licensed under the
> AGPL, if that mitigates concerns somewhat.
>
> I'm not sure it supports it out of the box yet, but I suspect upstream
> would be amenable to patches to make it easy for people to run their own
> "diffoscope" services.
>
>
> > What do you think?

We can have SaaSS in Guix. There are already some packages that are
SaaSS. So I think this package is okay.

It's "extra okay" in my opinion since the service is AGPL, part of
Debian, and we have a package for the tool in question.

Guix is developed under the Free System Distribution Guidelines, which
don't mention remote services or SaaSS at all:


And some discussion on the subject of services in the context of free
software that largely reflect how we handle SaaSS in Guix:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxjLpMACgkQJkb6MLrK
fwieQBAA7edlKyrkKSHwgm2KEh/OoOm1REsN4vGpVf2bUQY0v8KlXeWHvCetiqwL
omSf8s3gFmCZq1/dzdyLrTaK3fsx8SHvn9MCm3r3uR9/MRnB3BW0mEccgrbsNkca
euaIUo/JeVdYXhcIGFXobS/zCR8qs+/rqqE6hJ4zYh90Atjbd5zGR1u62P1BuZZY
yIA/6PFWQjRTAuvsJoKN1EVSOiv018k0BnM1dcE1R4i+uG3Qjkkn7r96bl3g2PfW
ft3OOQIpul4Bploch+IXInWSPWy0UsFvo+qlj87WIzABLSSFQTLhvo2lTqIMfAG5
pbsslDm+q6YMJEP4prCXNhx1saWHkW2i4HuakfEfIn4W3oXAO4k1aXu+/inTo17a
uaYWEcaOcG4py/Zn9JLuEdTFaNT2DZ2h7iXYsLU2ve1R7e9kLei3l4/zLL8YbPsz
mgEkBK0tr2mAomvdpu2LnvaZw7coKypAdG9emQvQ8aU6EuaxvInA7/ZUbFo2/knF
VwuJ55x+Dr58JJQJpSxjl1dwGOEq+1CNWpRBxeJPEllMeud0JRysTGnjIu6oNjIC
AqFdfbZvwpDHxAKLeueq8Fp0kA48iZTju78oQxa5GNusmXLQNhfDDcZ2IsDmXyeS
DtkSd7DRKS9rfk/Cl/pqw4q2Jvfi5b0Y6kY1hCPfHzDjJrrrqoE=
=IVwJ
-----END PGP SIGNATURE-----


J
J
Julien Lepiller wrote on 13 Feb 2019 09:05
(address . 34449@debbugs.gnu.org)
A4D0E062-62BC-4192-AA1A-A8233A1A3BED@lepiller.eu
Le 12 février 2019 21:37:42 GMT+01:00, Leo Famulari <leo@famulari.name> a écrit :
Toggle quote (68 lines)
>On Tue, Feb 12, 2019 at 12:16:42AM -0800, Vagrant Cascadian wrote:
>> On 2019-02-12, Julien Lepiller wrote:
>> >>+ (synopsis "Compare files and archives in depth")
>
>This synopsis doesn't make clear that this is a client for a remote
>service. Can you rewrite it?
>
>> >>+ (description
>> >>+ "This is a minimal diffoscope client that connects to the
>> >>service:
>
>Also, I think it's better to replace "diffoscope client" with something
>like "client for the remote diffoscope service located at [...]" since
>diffoscope is not inherently a client-service tool. Also it would be
>great to mention the full diffoscope package :)
>
>Can you send an updated patch?
>
>> > Iiuc, this is a client to connect to a service that runs diffoscope
>> > for you. But we already have diffoscope, so what's the point?
>>
>> Yes, that's the jist of it. The main advantage is that it has a much
>> smaller dependency chain locally.
>>
>> I find it useful on some of the not-particularly-fast ARM systems
>I've
>> been running GNU Guix, where storage may be limited or slow, and
>> substitutes may not be available as often, and build times
>> are... remarkable.
>
>Yes, and diffoscope runs can also be really expensive. It's nice to
>offload them.
>
>Also, if the service makes statements about whether submissions are
>logged or made public, can you put that in the package description?
>
>> > Also this looks like saass to me, so I think we should refrain from
>> > adding it to guix.
>>
>> It is essentially SaaSS. The server-side is at least licensed under
>the
>> AGPL, if that mitigates concerns somewhat.
>>
>> I'm not sure it supports it out of the box yet, but I suspect
>upstream
>> would be amenable to patches to make it easy for people to run their
>own
>> "diffoscope" services.
>>
>>
>> > What do you think?
>
>We can have SaaSS in Guix. There are already some packages that are
>SaaSS. So I think this package is okay.
>
>It's "extra okay" in my opinion since the service is AGPL, part of
>Debian, and we have a package for the tool in question.
>
>Guix is developed under the Free System Distribution Guidelines, which
>don't mention remote services or SaaSS at all:
>
>https://www.gnu.org/distros/free-system-distribution-guidelines.en.html
>
>And some discussion on the subject of services in the context of free
>software that largely reflect how we handle SaaSS in Guix:
>
>https://www.gnu.org/philosophy/network-services-arent-free-or-nonfree.en.html

Thanks for the links!
V
V
Vagrant Cascadian wrote on 13 Feb 2019 22:43
(name . Leo Famulari)(address . leo@famulari.name)
87lg2j5pqm.fsf@ponder
On 2019-02-12, Leo Famulari wrote:
Toggle quote (35 lines)
> On Tue, Feb 12, 2019 at 12:16:42AM -0800, Vagrant Cascadian wrote:
>> On 2019-02-12, Julien Lepiller wrote:
>> >>+ (synopsis "Compare files and archives in depth")
>
> This synopsis doesn't make clear that this is a client for a remote
> service. Can you rewrite it?
>
>> >>+ (description
>> >>+ "This is a minimal diffoscope client that connects to the
>> >>service:
>
> Also, I think it's better to replace "diffoscope client" with something
> like "client for the remote diffoscope service located at [...]" since
> diffoscope is not inherently a client-service tool. Also it would be
> great to mention the full diffoscope package :)
>
> Can you send an updated patch?

>> > Iiuc, this is a client to connect to a service that runs diffoscope
>> > for you. But we already have diffoscope, so what's the point?
>>
>> Yes, that's the jist of it. The main advantage is that it has a much
>> smaller dependency chain locally.
>>
>> I find it useful on some of the not-particularly-fast ARM systems I've
>> been running GNU Guix, where storage may be limited or slow, and
>> substitutes may not be available as often, and build times
>> are... remarkable.
>
> Yes, and diffoscope runs can also be really expensive. It's nice to
> offload them.
>
> Also, if the service makes statements about whether submissions are
> logged or made public, can you put that in the package description?

I couldn't really think of a straightforward way to mention the
diffoscope package, but the attached patch updates the synopsis and
description to address the other mentioned issues.


Toggle quote (18 lines)
>> > What do you think?
>
> We can have SaaSS in Guix. There are already some packages that are
> SaaSS. So I think this package is okay.
>
> It's "extra okay" in my opinion since the service is AGPL, part of
> Debian, and we have a package for the tool in question.
>
> Guix is developed under the Free System Distribution Guidelines, which
> don't mention remote services or SaaSS at all:
>
> https://www.gnu.org/distros/free-system-distribution-guidelines.en.html
>
> And some discussion on the subject of services in the context of free
> software that largely reflect how we handle SaaSS in Guix:
>
> https://www.gnu.org/philosophy/network-services-arent-free-or-nonfree.en.html

Thanks for sharing your perspective and links to further reading on
these issues! It really helps to get a feel for the norms of the
project.


live well,
vagrant
From 54b99d80b90a9f56fa95654a4b1bf254acb27f9c Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Mon, 11 Feb 2019 20:21:39 +0000
Subject: [PATCH] gnu: Add trydiffoscope.

* gnu/packages/package-management (trydiffoscope): New variable.
---
gnu/packages/package-management.scm | 48 +++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (61 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index af9667cd91..51d6698ee0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -606,6 +606,54 @@ various binary formats into more human readable forms to compare them. It can
compare two tarballs, ISO images, or PDFs just as easily.")
(license license:gpl3+)))
+(define-public trydiffoscope
+ (package
+ (name "trydiffoscope")
+ (version "67.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((share (string-append (assoc-ref outputs "out") "/usr/share/")))
+ (mkdir-p (string-append share "/man/man1/" ))
+ (invoke "rst2man.py"
+ "trydiffoscope.1.rst"
+ (string-append share "/man/man1/trydiffoscope.1"))
+ (mkdir-p (string-append share "/doc/" ,name "-" ,version))
+ (install-file "./README.rst"
+ (string-append share "/doc/" ,name "-" ,version))))))))
+ (native-inputs
+ `(("gzip" ,gzip)
+ ("python-docutils" ,python-docutils)))
+ (build-system python-build-system)
+ (home-page "https://try.diffoscope.org")
+ (synopsis "Client for remote service to compare files and archives in depth")
+ (description
+ "This is a client for the remote diffoscope service located at:
+
+https://try.diffoscope.org
+
+Diffoscope tries to get to the bottom of what makes files or directories
+different. It recursively unpacks archives of many kinds and transforms
+various binary formats into more human readable forms to compare them. It can
+compare two tarballs, ISO images, or PDFs just as easily.
+
+Results are displayed by default, stored as local text or html files, or made
+available via a URL on https://try.diffoscope.org. Results stored on the
+server are purged after 30 days.")
+ (license license:gpl3+)))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGSPcgAKCRDcUY/If5cW
quQ7AQCu602R2hTWCALz1YIY58qaZC6sFqkwcPrYt2UrWSJOIgEAhsVhFcpJrkGp
RcfzRb13Ee1Ti0/cnvj6SXSr9U2SvgE=
=aMtQ
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 14 Feb 2019 00:58
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)
20190213235805.GA24134@jasmine.lan
On Wed, Feb 13, 2019 at 01:43:13PM -0800, Vagrant Cascadian wrote:
Toggle quote (4 lines)
> I couldn't really think of a straightforward way to mention the
> diffoscope package, but the attached patch updates the synopsis and
> description to address the other mentioned issues.

Okay, sometimes these non-code parts are actually the hardest! :)

I pushed as commit 706460a35754a47bf832a40de4f22271e7088226 with the
changes below.

I found that the software didn't work without the requests module, and
that the man page was being installed to a location that is not
idiomatic for Guix.

`trydiffoscope --webbrowser foo bar` is super nice!

Toggle diff (53 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 51d6698ee0..eff8d5c3fd 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -625,24 +626,25 @@ compare two tarballs, ISO images, or PDFs just as easily.")
(modify-phases %standard-phases
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((share (string-append (assoc-ref outputs "out") "/usr/share/")))
+ (let* ((share (string-append (assoc-ref outputs "out") "/share/")))
(mkdir-p (string-append share "/man/man1/" ))
(invoke "rst2man.py"
"trydiffoscope.1.rst"
(string-append share "/man/man1/trydiffoscope.1"))
(mkdir-p (string-append share "/doc/" ,name "-" ,version))
(install-file "./README.rst"
- (string-append share "/doc/" ,name "-" ,version))))))))
+ (string-append share "/doc/" ,name "-" ,version)))
+ #t)))))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)))
(native-inputs
`(("gzip" ,gzip)
("python-docutils" ,python-docutils)))
(build-system python-build-system)
(home-page "https://try.diffoscope.org")
- (synopsis "Client for remote service to compare files and archives in depth")
- (description
- "This is a client for the remote diffoscope service located at:
-
-https://try.diffoscope.org
+ (synopsis "Client for remote diffoscope service")
+ (description "This is a client for the @url{https://try.diffoscope.org,
+remote diffoscope service}.
Diffoscope tries to get to the bottom of what makes files or directories
different. It recursively unpacks archives of many kinds and transforms
@@ -650,7 +652,7 @@ various binary formats into more human readable forms to compare them. It can
compare two tarballs, ISO images, or PDFs just as easily.
Results are displayed by default, stored as local text or html files, or made
-available via a URL on https://try.diffoscope.org. Results stored on the
+available via a URL on @url{https://try.diffoscope.org}. Results stored on the
server are purged after 30 days.")
(license license:gpl3+)))
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxkrw0ACgkQJkb6MLrK
fwhNCxAAicgeen5EEpRUMoJ8GvtpVwMCSOetxyn8CjCHzBJb8JMqmCkz/UHKicUI
95tF2NcYqzmzXr1zdSvg2NQM5/fyeIezy4719IGSWHbFHdaozH+0IltTDCBlQlhy
chJnNzNHvdgXVJ35XQigbJAHeD8YebMKKFuuiz/5ExotjuaH2opV8HvamH/yUXpc
0czND6+cwgst1blYqT6Qmug55QMPexpIG21D8bqTKe62UnnxQILKhnzjF9uSz4/F
Z6CILOsZ5Fv0lVbOXNvwekdfhHhGW0ll3Y59iuGM1+HyvECA9wfbsB7NkSpKnvO/
NGejxXirZeSK31J7l03xGiMj+T6TJt5WGxEAJDyaSiXxZBHPhx6oVkpDBNLsU+og
VREUYS62ZDITAqkm5SXRTRFQEygI5fIcdCXUZ7orf2qQG9ODwFxE1m+7LrP8+tVd
7nS7NxCSU/IT8vmggq8HNFUQDjjvK8dDtG1RgM6TYtpiAt2AsV+0Z2EmAWv8IfJW
UoaCbD4yK0UKZvGIy1gZKUiRVqT9jUsujGG/ho1u9FKBeqFQMf3WKeXXp1EU+ZwL
mkF7Wt8sR9EhtZeY5HSv1VoCvI8BLrpzUVM1wvGndB4gjHHP7Z//yszo01O+q7NA
GS14rOWvtkR111tgwe6iMvKj1rwz361Rx0Byf424d92ur6txEkU=
=ZVO1
-----END PGP SIGNATURE-----


Closed
V
V
Vagrant Cascadian wrote on 14 Feb 2019 01:26
(name . Leo Famulari)(address . leo@famulari.name)
87ftsr5i5y.fsf@ponder
On 2019-02-13, Leo Famulari wrote:
Toggle quote (7 lines)
> On Wed, Feb 13, 2019 at 01:43:13PM -0800, Vagrant Cascadian wrote:
>> I couldn't really think of a straightforward way to mention the
>> diffoscope package, but the attached patch updates the synopsis and
>> description to address the other mentioned issues.
>
> Okay, sometimes these non-code parts are actually the hardest! :)

Indeed.


Toggle quote (3 lines)
> I pushed as commit 706460a35754a47bf832a40de4f22271e7088226 with the
> changes below.

Thanks!


Toggle quote (2 lines)
> I found that the software didn't work without the requests module, and

I was surpised it worked without it for me (I had seen that it used
requests); could my user profile have somehow leaked python-requests
from some other package?


Toggle quote (3 lines)
> that the man page was being installed to a location that is not
> idiomatic for Guix.

I wondered why it wasn't showing up in MANPATH... now I know, thanks!
/usr/share is a hard habit to break. :)


live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGS1yQAKCRDcUY/If5cW
qgfjAP9LuwVhLTv8J6JwyL4tsjMdxja1qh1ClxJFaaGJusC3FgEA0/vJps1m1whW
6SdXsgTg7qpsF/zncwXanYtx/7X+iQk=
=iUMA
-----END PGP SIGNATURE-----

L
L
Leo Famulari wrote on 14 Feb 2019 01:32
(name . Vagrant Cascadian)(address . vagrant@reproducible-builds.org)
20190214003247.GA28902@jasmine.lan
On Wed, Feb 13, 2019 at 04:26:49PM -0800, Vagrant Cascadian wrote:
Toggle quote (4 lines)
> I was surpised it worked without it for me (I had seen that it used
> requests); could my user profile have somehow leaked python-requests
> from some other package?

I actually don't know how Python looks up module dependencies so... not
sure :) Depending on how you tested the package, it could be that the
requests module was propagated (installed into your profile) by another
package and that trydiffoscope found it there.

Toggle quote (3 lines)
> I wondered why it wasn't showing up in MANPATH... now I know, thanks!
> /usr/share is a hard habit to break. :)

:)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAlxktywACgkQJkb6MLrK
fwiVvg/+KJaWB1VyiOcC2XBQE7vEOZhuIo/FgVwhhK+jm66tKhtxDPyN4vMI8o9T
N4JZQ03FNHepiNo2+84/MFawd6p7qeUEEk8qKdC586aJVJ0qDxlZzGiHNq195ZeD
XJzO85q9E6gIcwnCuP02U10YBLFUnfneENVCCgqWMB1ujtR/dgFkeFvlu2BQs4Nq
FeLATPX8Ii/cyt5CXN35x77akQulO8iWus0Ti5UyQZ06daNW9Fmop6ruE+L64FqM
dwXxsMqHI7iIsfo0U3o3qUi2EeCIKLorAKWr1NK4NRs7zcwEBxHsXyU1qf8PNVML
behQVZgil2iqclQx+bjwoahibr/gGYbbA+8KyuIY2xZkO99Ub5V6H7CtABgDVU3d
dWNR3dMSqj6lscxhCvxYyuClW+R+dmblIqMU9Eww41VkmOsKsel7cM+O4dPEpaWq
+6BBvTwq3dBGiT5RzjJiJHJ4Jh77NHXiOWhZ7qBfOk8rvH3NF7jp1TX3sllNwV90
R6KC6r31zbmoCDcEfFqMD7gKWC1LE0PSddGkYlHyfrvsbxj1BrMUPQRMHBQOsaFx
A3LM6voQ8pJ58RoaJPHipQzWDhrv7CzQH0c788BIUTWmRAxLa5Ir0IZE+lyv6ozu
qA25s3qQLSixJcVTYejNkbsh//NRfF3Sb4dAe5vse7NCpEul8FQ=
=VXt8
-----END PGP SIGNATURE-----


Closed
?