Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
* gnu/packages/package-management (trydiffoscope): New variable.
---
gnu/packages/package-management.scm | 44 +++++++++++++++++++++++++++++
1 file changed, 44 insertions(+)
Toggle diff (57 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 587d028d92..49208e3191 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -606,6 +606,50 @@ various binary formats into more human readable forms to compare them. It can
compare two tarballs, ISO images, or PDFs just as easily.")
(license license:gpl3+)))
+(define-public trydiffoscope
+ (package
+ (name "trydiffoscope")
+ (version "67.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((share (string-append (assoc-ref outputs "out") "/usr/share/")))
+ (mkdir-p (string-append share "/man/man1/" ))
+ (invoke "rst2man.py"
+ "trydiffoscope.1.rst"
+ (string-append share "/man/man1/trydiffoscope.1"))
+ (mkdir-p (string-append share "/doc/" ,name "-" ,version))
+ (install-file "./README.rst"
+ (string-append share "/doc/" ,name "-" ,version))))))))
+ (native-inputs
+ `(("gzip" ,gzip)
+ ("python-docutils" ,python-docutils)))
+ (build-system python-build-system)
+ (home-page "https://try.diffoscope.org")
+ (synopsis "Compare files and archives in depth")
+ (description
+ "This is a minimal diffoscope client that connects to the service:
+
+https://try.diffoscope.org.
+
+Diffoscope tries to get to the bottom of what makes files or directories
+different. It recursively unpacks archives of many kinds and transforms
+various binary formats into more human readable forms to compare them. It can
+compare two tarballs, ISO images, or PDFs just as easily.")
+ (license license:gpl3+)))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXGIqpQAKCRDcUY/If5cW
qnBTAP9EWDb8lTugNTc6YsE400IkHqNvKI4Y9dxtC2yXwIoUJgD/Qnk3yro5PqDn
FdJxJ5L2He3t+Qug0p3Kgl5j3AJO+w4=
=7PK0
-----END PGP SIGNATURE-----