vlc build fails on guix master

  • Done
  • quality assurance status badge
Details
One participant
  • Danny Milosavljevic
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
(address . bug-guix@gnu.org)
20190211183845.363091fc@scratchpost.org
codec/vpx.c:119:23: error: ‘VPX_IMG_FMT_444A’ undeclared here (not in a function)
{ VLC_CODEC_YUVA, VPX_IMG_FMT_444A, 8, 0 },
^
codec/vpx.c:120:23: error: ‘VPX_IMG_FMT_YUY2’ undeclared here (not in a function)
{ VLC_CODEC_YUYV, VPX_IMG_FMT_YUY2, 8, 0 },
^
codec/vpx.c:121:23: error: ‘VPX_IMG_FMT_UYVY’ undeclared here (not in a function)
{ VLC_CODEC_UYVY, VPX_IMG_FMT_UYVY, 8, 0 },
^
codec/vpx.c:122:23: error: ‘VPX_IMG_FMT_YVYU’ undeclared here (not in a function)
{ VLC_CODEC_YVYU, VPX_IMG_FMT_YVYU, 8, 0 },

codec/vpx.c:124:24: error: ‘VPX_IMG_FMT_RGB555’ undeclared here (not in a function)
{ VLC_CODEC_RGB15, VPX_IMG_FMT_RGB555, 8, 0 },
^
codec/vpx.c:125:24: error: ‘VPX_IMG_FMT_RGB565’ undeclared here (not in a function)
{ VLC_CODEC_RGB16, VPX_IMG_FMT_RGB565, 8, 0 },
^
codec/vpx.c:126:24: error: ‘VPX_IMG_FMT_RGB24’ undeclared here (not in a function)
{ VLC_CODEC_RGB24, VPX_IMG_FMT_RGB24, 8, 0 },

codec/vpx.c:127:24: error: ‘VPX_IMG_FMT_RGB32’ undeclared here (not in a function)
{ VLC_CODEC_RGB32, VPX_IMG_FMT_RGB32, 8, 0 },
^
codec/vpx.c:129:23: error: ‘VPX_IMG_FMT_ARGB’ undeclared here (not in a function)
{ VLC_CODEC_ARGB, VPX_IMG_FMT_ARGB, 8, 0 },
^
codec/vpx.c:130:23: error: ‘VPX_IMG_FMT_ARGB_LE’ undeclared here (not in a function)
{ VLC_CODEC_BGRA, VPX_IMG_FMT_ARGB_LE, 8, 0 },

make[4]: *** [Makefile:23666: codec/libvpx_plugin_la-vpx.lo] Error 1
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxhsyYACgkQ5xo1VCww
uqWcjAgAlL8l+x1EcTQ+bIg9aqiBRNyf2/ozg94Jwpp59FsjZOYUCLsfrRrd4t9m
xtSLB9dfQ7RLktD0f1kd7BGGm8Yh6p+8AMrKwqmeHgk3S1IbbiX/zoWmO2ijmQyz
1xXt14ekHYdSK7tA6qbm8kVKKIb7qeBkiNlKzUkHIjLDkWF/PCRRusu4WynT8rp1
rwfoO9nKAanWSup1cmBBADH39l/IC3sa17BL8PZIVGSnyO+bqLxlLU4lnu9BIWy8
BZ0P7lKH3w74Pqc35h1CCNw818TDafV1y7DjkKqvHVpEcI5nL/o8Onk9UfHSAvoZ
yPYeRxiyhJDH69mAXuOVzhu9+L1Bbg==
=kiGM
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 6 years ago
(address . 34439-done@debbugs.gnu.org)
20190211185954.1cf84b53@scratchpost.org
Possible fixes:

Either make vlc require libvpx-1.7 instead of libvpx-1.8 with no other changes.

Or patch vlc to not use the newly removed constants. Reading the vlc commit log,
they say that they removed those because they were unused anyway--so it shouldn't
have a negative impact.

I've posted the latter patch to vlc-devel.

I've done the former to guix master for now.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAlxhuBoACgkQ5xo1VCww
uqVt5Af+KM1YamkH5kFEqHZYiPwHV5mCl9tPUvqOO2r/jryZKtPTFTv91ImOY2xc
49pmw0oQnZKFQyqENm6912VjJSgQSRZcd1Hm7LuFxSsqCVJvaHadECqg+C/zzfbS
hRR3+H/ojoi0J6qyLXYE4/tF9Vi4eMczXZd8S49b0Hs2UgRCXqyr7WiR1JygwBPM
/OkgGudXRWPB1RP0rWJJHUyQZR203hYB9GyJeJr55/JrP798++kxtpDKMo9teaBa
vU80nHgwARxXsue3nrtymLCAYVn0RdD+YGCtoHfdrNScbl1ZQe0xY609kic83dSn
HSL+nnjSMzcDt/QPuSuBq4B0NdPCUw==
=/BFD
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 34439@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 34439
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help